Tuya zigbee plug

And why again aren't we using the generic zigbee outlet driver with this device?

1 Like

:crazy_face:

"they claim to use the zigbee 3.0 protocol" ..... 'nuff said.

If you had your HE hub updated to version 2.3.0.123 yesterday, you need to revert back to the previous stable version 2.3.0.121

Critical device data like the model, endpointID, etc.. were playing weird today...

Go to HE Settings page -> Check for updates -> downgrade to 2.3.0.121.

The generic zigbee outlet driver should work with this device, with the exception of receiving the power, voltage, amperage data - these Tuya outlets need polling, they can not be configured to send reports automatically.

Thanks for your reply

dev:3682021-12-26 08:49:48.138 traceZCL version:03

dev:3682021-12-26 08:49:48.134 traceSoftware Build Id:unknown

dev:3682021-12-26 08:49:48.129 traceModel:TS011F

dev:3682021-12-26 08:49:48.125 traceManufacturer:_TZ3000_w0qqde0g

dev:3682021-12-26 08:49:48.070 debuggetting info for unknown Zigbee device...

I hope this helps you and of course me :wink:

above was before downgrade.

after downgrade to 2.3.0.121 this is the reply.

2021-12-26 09:01:57.781 debuggetting info for unknown Zigbee device...

dev:4002021-12-26 09:01:55.106 infoZigbee parsed:[raw:00950100060800001000, dni:0095, endpoint:01, cluster:0006, size:08, attrId:0000, encoding:10, command:0A, value:00, clusterInt:6, attrInt:0]

dev:4002021-12-26 09:01:53.966 infoZigbee parsed:[raw:00950100060800001001, dni:0095, endpoint:01, cluster:0006, size:08, attrId:0000, encoding:10, command:0A, value:01, clusterInt:6, attrInt:0]

dev:4002021-12-26 09:01:42.779 debuggetting info for unknown Zigbee device...

I got nothing. with get info. I manually turn the plug on and off. and tried info again.
this is what you get with cheap devices :frowning_face:

'Get Info' is not returning the device fingerprint :frowning:

Most likely the device endpoint is not retrieved and not stored in device Data, this may explain why the inbuilt Generic Zigbee Outlet (and all other drivers) do not work.

Has anyone else seen a similar problem with other zigbee devices?

@kkossev It works !!!
! added a fingerprint profileid in your driver and now it looks like it is working. I can turn the plug on and off. it is recognized when added/discovered
fingerprint profileId: "0104", inClusters: "0003, 0004, 0005, 0006, 0702, 0B04, E001, E000, 0000", outClusters: "0019, 000A", manufacturer: "_TZ3000_w0qqde0g", model: "TS011F", deviceJoinName: "Neo NAS-WR01 Outlet new"
I even get power updates

1 Like

after having it functional with the changed driver. I tried the get info via device again. and now that works also.

2021-12-26 09:27:12.323 infofingerprint profileId:"0104", endpointId:"01", inClusters:"0003,0004,0005,0006,0702,0B04,E001,E000,0000", outClusters:"0019,000A", model:"TS011F", manufacturer:"_TZ3000_w0qqde0g"

dev:4022021-12-26 09:27:12.237 traceZCL version:03

dev:4022021-12-26 09:27:12.229 traceSoftware Build Id:unknown

dev:4022021-12-26 09:27:12.225 traceModel:TS011F

dev:4022021-12-26 09:27:12.220 traceManufacturer:_TZ3000_w0qqde0g

dev:4022021-12-26 09:27:12.153 debuggetting info for unknown Zigbee device...

As all we already know, these Tuya devices behave very weird... So it may be a combination of different factors, such as partially initialized / corrupted device settings inside TS011F firmware. In such cases removing the plug from the mains power supply for a couple of minutes and then re-initializing the devices again may help.

The important thing is that the devices is working now! :slight_smile:

thanks for your great help. :+1: :+1: :+1:

1 Like

There is a new driver version that is published here : [BETA] Tuya Zigbee Metering Plug

Download the Hubitat app