Tuya Smart ZigBee 3.0 16A Mini Switch No Neutral

Anyone have luck controlling the new Tuya Zugbee mini switches Model TMZ02L? The new Sonoff no-neutral wire ones are too big for my boxes.

They pair quickly and I'm using the closest device driver I could find (from @BirdsLikeWires in the Package Manager). It includes the same model number plus all the inClusters and outClusters match. The light will switch using the button on device itself or using the manual switch I've attached to it, Hubitat will not see the state change or get any response from commands sent. I've also tried the generic zigbee switch driver.

This is the item I bought:

They are shown as compatible with ZHA at Tuya Mini Switch Module 16A No Neutral (TMZ02L) Zigbee compatibility although the ones they tested have a different manufacturer ID: _TZ3000_v7sopte0 where mine are: _TZ3000_txpirhfq.

Just to confirm - did you click Configure after changing drivers?

Yep. Even tried using "Device" in between real drivers

These seem like really useful switches - rated at 16Amp (although I'd never consider putting that much current through them) but mostly because they don't require a neutral. No one else is trying to use these???

I'm in pretty new construction, but the electrician only ran the hot line to switches for multiple overhead lights.

That seems weird for new construction. Isn't it code to run neutrals to all workboxes now?


I was under that impression too, but it seems there's exception cases where they don't have too. At least that's what I was told. The house is 5 years old.

Have you tried turning on the logs for the driver and having a peek at the output? If not, give it a try and post the output of switching on and off. They look pretty neat and I'd be happy to add support to the driver if I can figure out what they're transmitting and expecting.

1 Like

Thanks for the reply. I'd love to hear what you think about this. These switches don't seem to respond at all to commands. Here's a log beginning after switching the driver from Device to Tuya Switch Module TS0011 / TS0012 followed by clicking Configure, Refresh, On, Off...

dev:5032022-04-24 08:36:33.906 pm traceIsland Lights : sendZigbeeCommands received : [he cmd 0xCD18 0xFF 0x0006 0x00 {}]

dev:5032022-04-24 08:36:19.520 pm traceIsland Lights : sendZigbeeCommands received : [he cmd 0xCD18 0xFF 0x0006 0x01 {}]

dev:5032022-04-24 08:36:11.552 pm infoIsland Lights : Refreshed

dev:5032022-04-24 08:36:11.549 pm traceIsland Lights : sendZigbeeCommands received : [he rattr 0xCD18 0xFF 0x0006 0x00 {}]

dev:5032022-04-24 08:36:07.019 pm infoIsland Lights : Preferences Updated

dev:5032022-04-24 08:36:06.973 pm infoIsland Lights : Configuration complete.

dev:5032022-04-24 08:36:06.971 pm debugIsland Lights : deleteChildren() : Deleting rogue children.

dev:5032022-04-24 08:36:06.960 pm traceIsland Lights : sendZigbeeCommands received : [he rattr 0xCD18 0x0001 0x0000 0x0001 {}, he rattr 0xCD18 0x0001 0x0000 0x0004 {}, he rattr 0xCD18 0x0001 0x0000 0x0005 {}, he raw CD18 0x0000 0x0000 0x0004 {00 18CD 01} {0x0000}]

dev:5032022-04-24 08:36:06.956 pm traceIsland Lights : sendZigbeeCommands received : [zdo bind 0xCD18 0x01 0x01 6 {A4C138709CB861BC} {}, delay 2000, he cr 0xCD18 0x01 6 0 16 0 600 {}, delay 2000, zdo bind 0xCD18 0x01 0x01 8 {A4C138709CB861BC} {}, delay 2000, he cr 0xCD18 0x01 8 0 32 1 3600 {}, delay 2000, he rattr 0xCD18 0x01 6 0 {}, delay 2000, he rattr 0xCD18 0x01 8 0 {}, delay 2000]

Another developer who does a lot of Tuya drivers is also taking a look at this device but maybe you've got a different perspective on the problem. Also, too rule out having a bad switch, I bought two of these devices and neither work. I have re-paired the devices multiple times including turning off the circuit breaker. They just don't want to respond.

Hmm, it can be the case that they need a bind command to begin communicating in the way we might expect, but I've not seen this on a Tuya device before. They tend to be set up for maximum ease of use!

I need to revisit the driver you're using (as I now have the one, two and three gang versions here to test) and will see if there's anything I can potentially do without having one of these to hand.

So I had originally read that these were compatible with Home Assistant so figured it wasn't a big deal, but now I can't find any proof of these switches work in either HA or Smartthings. Searching google now, I've read about some Tuya devices using a new cluster but that's beyond my understanding of drivers.

Hmm, in which case I'll have to do more digging once I get chance. It's entirely possible there's enough detail out there already to fix the issue, I'm just drowning in "Real Life Responsibilities" at the moment. :anguished:


Real life comes first. For most of us, this is just a fun hobby.


These do look interesting if they are able to report back state change. That said, one could probably do some sort of rule that would programmatically keep up with state, yes or no?

Comparing this Tuya version to the Sonoff ZBMINI-L of which I have several, they are the same size except 8mm thinner which is helpful. They also claim no need for the capacitor I had to add for one of my use cases,

Better make sure to order the TMZ02L and not the TMZ02 which requires neutral.

Can you tell @birdslikewires if this version is what you referenced as being digital so it will not be so loud when turned on and off as the Sonoff ZBMINI-L is?

I have two of these installed for testing and they definitely have a relay. There is a solid click noise about a half second after switching on or off using a paddle switch.

1 Like

Wait, what...you mean HA isn't Real Life?!

Can't believe it, my wife was right...



My wife is usually right... but don't tell her that :grinning:


Tuya Zugbee mini switch TMZ02L (_TZ3000_txpirhfq) was added into Muxa's "Zemismart ZigBee Wall Switch Multi-Gang" driver - please try the development branch (the second link in this post) :

I've downloaded the driver and should be able to test tomorrow. I'd removed the switches and it will be easier to reinstall when it's light out.

1 Like

@kkossev The Zemismart development branch driver works! Re-installed switch, detected as Tuya Switch Module TS0011 ; changed to Device and cleared everything ; changed to Zemismart driver. Didn't work yet so I re-detected zigbee device and did these steps again and now it's working. Not 100% reliable yet but it hasn't had much time for the zigbee mesh to optimize.

Thank you!

Further report... the driver is working reliably as of now. However, on a dashboard tile the status shows only as "Sending" after switching on or off. On the device page, the status shows instantly. I'm using the switch tile but have also tried the outlet tile.

BTW, I don't see the fingerprint for the _TZ3000_txpirhfq in the code but it does include "Ver. 0.2.7 2022-06-05 kkossev" so it must be the correct driver.

1 Like

I am glad to hear we are making progress!

This is a single channel switch and it seems like the driver does not handle 1-gang switches (or light switch modules) in the best way. Looking at the code I see it may get confused because TS0011 has no children :grinning: ... Probably this driver has never been used with a sing gang switches until now. So let me look at this over the week.

And yes, _TZ3000_txpirhfq fingerprint is not in the driver code, will add it in the next update.

Do you have a wall switch connected to control the module locally? What type is it - a momentary switch or ...?

P.S. I removed the 'solution' mark, as there is still some more work to be done before the driver is fully functional.