Tuya Humidity & Temperature sensor

Darts are better than what I have right now!

It is the zigbee version. There is a reset and that’s how you get them to pair. But I’m not sure what the batteries would cause…they are triple AAA and I’m using energizer lithium. You really think that could cause an issue?

I have no idea. It's worth a try to see if it "jogs" something during the pairing process.

Otherwise; I would guess it has something to do with the "manufacturer" id. I have seen the plugin author adding new id's in the past. Maybe this one needs to be added as well?

Have you visited the device settings page; and checked what attributes are shown there? Do you have "state" variables like in my screenshot above? If so, can you please post those?

Lastly, I am tagging the plugin author.
@kkossev, any ideas here?

@chadmoss
I don’t see the device model and manufacturer in the post above. Please make a screenshot of the device web page in Hubitat, “Device details “ Data section.

Here are the current State variables:

Here is the manufacturer and model:

I can not find any information for this device on the Net ... It is either very new or ?? (the link you posted says 'discontinued' - can you check if the link to the site is still correct)?

image

rxCtr: 0 means: zero messages received from the device.... It has pairing problems with the HE hub. Is the hub C-7 or C-8 ?

Try deleting it from HE ( the 'REMOVE DEVICE' red button at the bottom of the device page) and then pair it very close to the hub. I will need the detailed information from the popup window when paired as a new device - please see this post .

Where are you seeing discontinued? It pops up for me: 1pc Tuya Zigbee Wifi Temperature Humidity Sensor Home Connected Thermometer Compatible With Smart Life Alexa Google Assistant - Tools & Home Improvement - Temu
Here is the pairing info:
Device pairing info

Manufacturer: _TZ3000_rdhukkmi
Endpoint 01 application: 46
Endpoint 01 endpointId: 01
Endpoint 01 idAsInt: 1
Endpoint 01 inClusters: 0001,0003,0402,0405,0000
Endpoint 01 initialized: true
Endpoint 01 manufacturer: _TZ3000_rdhukkmi
Endpoint 01 model: TS0201
Endpoint 01 outClusters: 0003,0019,000A
Endpoint 01 profileId: 0104
Endpoint 01 stage: 4

--

On a side note, I am also trying to setup this device, but it doesn't seem to work with your driver or any of the generic drivers: 1pc Tuya Zigbee Water Leakage Detector Smart Home Water Immersion Sensor Cooperates With Tuya Zigbee Gateway Supports Smart Life App | 24/7 Customer Service | Temu
Device pairing info

Device pairing info

Manufacturer: _TZ3000_ocjlo4ea
Endpoint 01 application: 41
Endpoint 01 endpointId: 01
Endpoint 01 idAsInt: 1
Endpoint 01 inClusters: 0001,0003,0500,0000
Endpoint 01 initialized: true
Endpoint 01 manufacturer: _TZ3000_ocjlo4ea
Endpoint 01 model: TS0207
Endpoint 01 outClusters: 0019,000A
Endpoint 01 profileId: 0104
Endpoint 01 stage: 4

Well, after several tries I was able to see the product for half of a second, before the screen changed to this :

Seems like the web site content is region locked or something similar..

Thank you for the fingerprint, I will add it to the driver and will notify you to try again.

The second device is already supported by this driver. Make sure you pair it really close to the hub.

1 Like

@chadmoss please update to version 1.3.8 2023/08/10 9:05 PM and pair the TH sensor again to the hub,

2 Likes

Strange! It must be. I appreciate your help!
I’m still having issues with both. Same type of issue on both too. I get an initial reading and then neither reports any more.


And here is the product you can’t see:

1 Like

Actually, both devices seem to be more of a time out issue than a single reading… The water sensor seems to work for about 10 seconds, and then stops working while the humidity/Around five seconds, before it stops working.

What is your hub model?
C-7?

Actually, it's a C-8.

Try pairing again (without deleting the device) close to the hub and choose ‘Pair trying to avoid Zigbee 3.0 repeaters’ option.

I tried that twice with each device - it seems like it bought them a little more time of reporting, but both still stopped and I just get a timeout when pinging.

It doesn’t help much but both of my Tuya temp and humidity sensors work great with the driver from @kkossev

At first, I tried pairing them across the room from the hub. They only partially installed so after pairing them 3” from the hub, they played nice and paired easily. Try removing the sensor and pair it again as close to the hub as possible.

Thanks @TomG - I have tried different distances from 3 ft away to sitting on top of the HE hub. lol

1 Like

Lol. Pic, please :wink:

1 Like

@chadmoss

I am out of ideas. Possible defective sensor?