Troubleshooting C7 Hub Slow Down issue?

I have 2 C7's and lately, my primary hub has started to get really slow after about a day and a half of uptime - to the point where I've had to schedule a daily reboot or nothing works properly (this at least solves the symptoms).

I just can't figure out why as my hub doesn't seem to be working very hard:

Any idea's on how to get to the bottom of this?

Support can look at your system (with your permission) to see if something strange is going on.

How strong is your zwave mesh - a slow mesh can cause the system to appear slow even though not much is running.

Perhaps do a zwave repair if there is quiet time around your house?

There is not much running as you surmised.

I was hoping there was something I could do - being in IT I like to sort things myself if possible.

My house has multiple mains powered z-wave plus devices in every room and appears to be healthy.

That is worth a go.

What was tipping me off to a problem was motion lighting getting slower and slower. I'd walk past a sensor and it would trigger, then 10 seconds later the light might turn on, or not at all. Other automations were failing too including Basic and Simple rules.

You may want to be catious about doing a "whole hub" Z-Wave repair. They can sometimes cause problems themselves...

Do you have any Z-Wave devices making a lot of route changes?

That sounds like a ZW device having issues. One bad or failing device can kill even a good ZW mesh. I have, what I consider, a strong mesh with a lot of mains powered devices, etc and after debug I found one of my blinds went AWOL and it just crushed my ZW response time.

1 Like

I ran a full mesh repair and got 2 "failed" devices. Both are working perfectly tho (respond to z-wave commands etc) which makes no sense to me.

Screen Shot 2021-09-28 at 10.44.30 am

I’ve seen this too. :point_up:

The solution was to power-off all my z-wave devices and then power them on again. (I had my hub on a UPS)

The issue was that one of my Z-Wave device was spamming the network. The reboot fixed it. I think I could have also rebooted a powered device at a time. Powering off the house was just faster…

@djos, I understand that battery devices will report as Failed Nodes most of the time during a Z-Wave repair.

That's not completely surprising, I don't think a full repair every gets them all, it could have been asleep or just didn't complete the process in time; you can do an individual repair if you want. There's also a ZW mesh analyzer app that provides a nice snap shot of the state of the mesh. You could try that and see if any device has a slow response time, too many hops, etc.

1 Like

Cheers, I'll check that out.

Good luck, ZW issues are not easy to track down.

1 Like

The "failed" nodes were mains powered devices.

Ok so I was able to fix one failed node via a repair, but the other one is cactus ... ever after power cycling it. I might try a HW reset and re-include it.

Ironically it's a repeater (Aeotec Range Extender 6) - Thankfully I dont think I need it anymore so removing it isnt a big deal.

Screen Shot 2021-09-28 at 11.44.01 am

I would also check your z-wave table and device pages for ghosts

Have you checked on your DB size? It is known to cause slow downs and Z-wave issues. Alert - Your database is growing


I don’t have any ghosts thankfully.

No but I’ll have a look.

EDIT: I'm not getting any DB size alerts.

If you just want to do a 1 time check:


Ta, it says 69

DB Size is not your problem :sunglasses:

1 Like

As my Range Extender 6 wouldn't repair and I've now removed it, I've changed my reboot back to weekly to see if the slow down issue is resolved.

1 Like