Sudden onset z-wave mesh slowness 2.2.3 on C-5

Anyone else seeing occasional issues with Z-wave on the C-5 since 2.2.3? Since the last few updates, my z-wave mesh will seemingly, slow to a crawl (over a minute for a command to turn on a light will come through). A reboot fixes it, but I'm wondering what might be going on.

The main way I notice is when I tell Alexa to lock a door, the command times out, and the door doesn't lock. During that time, if I try to issue any other z-wave commands, they are significantly delayed.

It's completely correlation and not causation necessarily, but it SEEMS to only happen after one of the 2.2.3 updates and I don't reboot a second time after the update.

Anyone else seeing similar? Thoughts? I'd love to update to a C-7, but I'm waiting for Hub Protect.


1 Like

Just about to post that. Same symptoms here.

My locks were flawless until this last update, now all they do is hang. The lock status doesn't update correctly. These are Schlage BE469 (non-zwave plus) locks, and all 3 suddenly have problems after a year or more of being perfect. It takes my locks literally 2-3 minutes to do a lock or unlock action after clicking on the dashboard. I just tried Alexa, and she timed out with "something went wrong".

I also did notice an occasional issue with some Zwave lights and fans, but nothing like the locks. Weirdly enough, other Zwave lights are so fast I cannot believe it. And these good switches are probably a couple feet from the badly behaving locks, and maybe less than 10 feet from the other switches that give issues.

I think it was the that caused it, as I just noticed this after yesterdays update. I have rebooted multiple times, and I have done a couple zwave repairs with no apparent difference in performance. I didn't try rolling back yet, but that is probably next.

@bcopeland or @gopher.ny did you make any changes that could have affected C5 Zwave and maybe in particular locks?

Add me to this list. My be469 that has been working perfectly on my C4 also is having issues on the newest update.

C4 hub.

@bcopeland @gopher.ny any thoughts?

Rolling back to resolved the issue and has the lock working normally.

No updates to Schlage drivers.

@gopher.ny I was thinking more along the lines of platform changes. Several of us seem to be seeing the same symptoms.

1 Like

Can confirm, my door lock doesnt work now

1 Like

Yep, I think it is a general Zwave issue but locks seem to be particularly affected.

Mine aren't Schlages, they're all Yale's.

Just unlocked and locked my Schlage with no issues. I will say I'm good about locking the door when I come in so it's rare that it tries to do anything automated. I'll try to leave it alone on my next few times in and see if it will lock okay based on timeout.

1 Like

Can confirm, rolling back to fixes my locks. Alexa works correctly again, as does the dashboard.

I am going to update again and see if a reboot clears things up like the OP.

1 Like

That did not work for me, I did multiple (3-4) reboots with no change. At least not a long term change anyway. It was fine immediately upon reboot, but within a few minutes issues were back.


Discouraging this lock is not supported anymore. May wind up with a couple bricks. My kwikset lock does not seem to exhibit these symptoms. Yet...

Out of curiosity what firmware are your locks?

I'm running 7.1 with a brand new one on the way. I wonder if different firmware will behave differently.

I think i've had an issue since I updated to actually.

Same here.

I think you have been around long enough to see why they are not recommending this lock anymore. I don't think they wanted to pull it from the supported device list.

But I would not read into that they are bricking it, at least not purposely. It worked well up to this point, so I think they broke something (unintentionally) in the update.

lol not implying hubitat doing anything to cause issues. Just worried that with it not being supported it may be less likely to receive serious trouble shooting time. Which as you have stated is understandable given the many issues reported over the years with it.

Then again if it is a wider zwave issues I am sure more users will start chiming in.

1 Like

I only noticed it because I had to work last night. I left the house, and by the time I got to work I had an alert that the door was unlocked. I always physically lock the locks by pressing the Schlage button, there are no autolock automations. So was almost 100% sure I had locked the door as I heard the motor whirring.

So after I got that alert, I looked, and sure enough it said the door was not locked. I tried to cycle the lock via cloud, and it was hanging. I tried a couple times with no change.

So probably if this is a larger issue, people will know today when they leave or arrive home for work and things bomb out.

And for Bryan or Victor, I tried debug logging this bug on .135, and I got literally nothing. There was no indication at all in the logs that I had even tried to lock/unlock. After the .132 rollback, I get the expected messages in debug logging like Parse, LockOperationReport, door lock was unlocked [digital], and so on.

I see this as well, thought it was just me. It's as if nothing is happening

1 Like

The behavior acts like itโ€™s Zwave mesh congestion, or the radio is just hung up with pending commands.

Next time it happens Iโ€™m going to fire up my Zniffer stick and see if thereโ€™s any actual traffic.

1 Like