Step-by-Step Custom Driver Install

Can someone please help me with a start to finish, step by step procedure to create a custom driver and installing a device with that custom driver? Example, I have a couple of LifX bulbs and they're listed as customer drivers.

I should think I need the same with an app? I need to get a Nest Gen 2 working with modes.

I'm sure the instructions are somewhere, but not under searches I'm using, or they are buried in some long threads that don't seem to have every step.

It seems like most assume I know some things I don't.

Thanks for your help! I'm excited so far. Have most things working!

First you need to find the custom DH code you want to install.
Copy the DH code to your clipboard.
In the HE hub select Drivers Code from the menus.
At the top you will see New Driver.
Click on it, copy in your code and save.
When you discover your new device it will allocate it a driver. It may be the one you just defined, if not, select your device from the devices menu.
Now click on the Type field.
From here you select the correct DH and save.

1 Like

I was able to get a custom device driver working for my First Alert Combo Smoke/CO2 Alarm. It was not hard given the instructions you gave me @bobbles. Thanks very much!

I'm still not clear on how to get LifX bulbs to work. I copied the code provided here Lifx Group of Groups Driver (ST port), and it's in my custom devices. I also have a token from LifX. Now here I sit. How do I add the token and the devices?

Also, I'd like to add very simple Nest integration, so that I can change setpoints with modes. This thread seems to indicate it can be done. Nest integration. However, again, I can't discern how to get this off the ground. I see the code, but not how to start the install process.

I may seem totally helpless, but I do have 86 devices on my Hubitat device list. So, I'm not totally helpless....

Thanks for any help!

OK, so you added a custom "Driver" which is just code that will be used by a device. When you pair a Zigbee or Z-Wave device, they will usually automatically create a device and assign a driver to it.

In the case of LIFX, I believe you will be accomplishing a Hubitat-to-Cloud integration. In that case, in your Hubitat's list of 'Devices', you will see a button near the top that says "Add Virtual Device". Click that, and then assign a unique name, network ID, etc... AND assign the correct Custom Driver. Once you do that, and click SAVE, you will see all of the options to configure the device.

This will the the Lifx custom driver that you added. Custom drivers will be sorted below all of the built-in drivers, so scroll to toward the bottom of the list.

Follow the steps @ogiewon outlined. Once saved you can enter the api key under preferences. Then enter at least one group or bulb name. It must be entered exactly as it appears in the Lifx app.

See this thread in the smartthings forum where the original driver was posted, for other details:

Thanks everyone for your input! I'm trudging through this with some success, but still having issues.

I only have one LifX light bulb. I mostly have Philips Hue, but I wanted a brighter color bulb on my front porch, so I got this thing.

I was able to create a virtual device and get a number of options in the device setting. My one bulb is called Front Porch Light in the LifX app. I created a token. As far as I can tell in the settings, I've got the same name and the token. However, I can't seem to control the light. It's currently on, but if I send an off command, the status changes to off, but the light never goes off. After 10-20 seconds the status changes back to on.

I've attached a couple of screen shots. I hope they came through.

Thanks!

Look under groups in the lixf app,android etc.
Make a note of the lights name, then enter that name exactly into the "group 1" selection in HE

I was able to get that to work @pistnbroke et all. Thanks!

1 Like

No problem,just did it.myself the other day😀