[Solved] RM HTTP GET request not working


#1

I have been trying to get a GET request to work from a piston but it doesn't seem to want to do anything. I have a sonos-node docker setup on my unraid server that process the GET requests. This worked great in ST Webcore but for some reason I can't get it to work in RM. It works if I test it using a browser but nothing from RM. Am I doing something wrong with this piston.
image
image
image


#2

I'm pretty sure the spaces in your "Goodnight Everyone..." phrase will cause problems. I'm not sure how your server is set up but you may need to URL Encode that phrase. Maybe WC had a function that did it for you behind the scenes?

Try replacing the current phrase with "goodnight%20everyone%20the%20house%20is%20now%20in%20night%20mode" and see if anything changes.


#3

Ok I will test that and let you know. Thanks!


#4

If that doesn't work, you might try replacing it with a simple one-word phrase like "testing" just to see you can get it to say something...this will rule out any issues with spaces or punctuation or whatever. Then if that works, you can try going to a more complex phrase with URL encoding.


#5

Ok that sounds like a good plan! I will test that when I get home tonight.


#6

Hey @pcgirl, it's not "piston", it's a "rule". Pistons are part of webCoRE. Rule Machine has rules.


#7

Why not create a custom command in RM to say the phrase then just execute the custom command within RM when true. OR just have the the truth action also speak the phrase.


#8

Yes, we had this discussion on another thread. Some are confused calling them Rules because there is also Rules and Triggers in RM. But I will call them Rules if that is what is understood.


#9

Rule that's a trigger, or a rule that's a triggered rule, or a rule that's a rule, or a rule that's an action...lol

I still say we should call them RM apps, "I have a RM app that's a triggered rule that does xxxx"

Adoption is another thing...


#10

Bruce is sensitive to use of the term "piston".


#11

(P)rogramming (I)'m (S)ensitive (TO) (N)ow


#12

OK then....RM Apps!:wink:


#13

How do you do that?


#14

Something is broken now when creating custom command. I am getting the following error.

When I click on Logs, it take me to a 404 page.


Can not create new custom command
#15

That got quite a grin out of me.. I remember some months back when trying to explain / untangle the difference between Rule, a rule, Trigger, a trigger, a triggered rule.. I thought it would be great to just call it a... piston. :slight_smile:


#16

Mine is doing that now too.... can't get into custom commands


#17

What browser? I can get in on Chrome for iOS. Sorry, that’s all I have to test with at the moment.


#18

I can get into Custom commands using Firefox.


#19

I'm on chrome, didn't think to try another browser.

Chrome: NO
Internet Explorer: NO
Edge: NO

Doesn't seem like a browser based issue. I don't have firefox on this computer.


#20

So when I just used one word http://192.168.1.100:5005/saypreset/speakers/Test it worked. However when I tested it with your sample it didn't work and then I tried it with two words Good Night and it didn't work.