[Solved] RM HTTP GET request not working


#21

But if I just put it in without any spaces, it seems to work somewhat that way. So if I put it in like this:
GoodNightEveryoneTheHouseisinnightmode

Except she speaks it fairly quickly and she says the house is inn ight mode.


#22

I don't know the syntax for a string with spaces - you might try:

goodnight+everyone+the+house+is+now+in+night+mode


#23

I think it's going to depend on whatever server is running at that endpoint. @pcgirl what are you sending the request to?


#24

I am sending it to a node docker on an unraid server. I did try the +’s between the words but that doesn’t work. It is weird because I didn’t have any trouble in ST just using the actual sentence.


#25

Shooting in the dark... Try hyphen and underscore too and see what it does.


#26

So the hyphen seems to work better. Although you can't seem to get a pause between sentences. Underscore doesn't work as she says the word 'underscore'. It was funny though.


#27

What happened when you did this one?


#28

I said all of the percent 20 between the words.


#29

can you share an exact screenshot of the piston that used to work? Curious if this was encapsulated at all.


#30

I didn't have a piston for a Good Night Routine in ST because there was an actual routine, so I created on in HE. But this is a piston that greets us when we get home and lets us know when someone has left. the GET request is down at the bottom but the random sentences are up closer to the top.


#31

Need to see the actual URL, when you take the "green" snapshot in hides it. Can you go into that piston and copy/paste that get request?


#32

http://192.168.1.100:5005/saypreset/speakers/{announce}


#33

have you tied using quotes?

On a separate note: At first, it was confusing for me to read piston but then see a screenshot of a rule


#34

Quotes didn't work. But thanks for the suggestion.


#35

What did you quote?

Like this:

http://192.168.1.100:5005/saypreset/speakers/"This is a test"

Or like this:

"http://192.168.1.100:5005/saypreset/speakers/this is a test"


#36

Good point. I meant the first example. And if that doesn't work just grins try double quotes.

http://192.168.1.100:5005/saypreset/speakers/""This is a test""


#37

This is the way I tried it. I will try a double quote when I get home and I can hear it (or not :wink:)


#38

Also if you copy and paste this link onto a browser at home, what happens:

http://192.168.1.100:5005/saypreset/speakers/This is a test

copy and paste the entire thing though. Don't just click on that


#39

It works from my browser. This is the funny thing. It works from a browser and it works from a piston but it doesn't work from a RM rule. It is like it doesn't even recognize it at all on the node server. No error when it doesn't recognize the syntax.


#40

I'm betting you are going to have to add some debugging code to the node app and see how it's receiving and processing the successful and unsuccessful requests.