[Solved] RM HTTP GET request not working


#41

Send it to https://requestcatcher.com/ to see what it's sending.


#42

bingo! Just need to see the one direct from browser vs RM.

This is what happens when you type this: https://whatever.requestcatcher.com/this is a test

/This%20is%20a%20test


#43

This was already suggested and it didn't work. Everything was said including the percent 20 between all the words.


#44

I want to see the output of what RM is saying VS what I was able to get from a straight get call in a browser. That will tell us what the difference is.


#45

How do we see that? Lightbulb just went off. I think I know what you are saying.


#46

you go here: Send it to https://requestcatcher.com/ to see what it's sending.

punch in a unique name like hubitattest leave that browser window open

then in RM replace your URL with

https://hubittest.requestcatcher.com

execute it...let us know what you get


#47

It isn't catching anything. Here is the test Rule in RM. When I turn the virtual switch on it says it fires in the logs but the request catcher isn't catching anything. It catches it when I put it directly in the browser though.

image


#48

Stupid question (I'm good at these) - why not use the built in capability in RM to send the message to Sonos? I made a much simpler rule to test it . . .


#49

Well I have tried that but when you have it go to multiple sonos speakers it really sounds weird because they don't speak simultaneously.


#50

It sends the request if the words are separated by periods,

https://blahblah.requestcatcher.com/This.is.really.a.test

Not sure what that does on a Sonos though.


#51

Ah, yes, I know what you mean. That makes sense.

We need some way to group Sonos speakers.


#52

Yes, it did catch this from RM.

But it doesn't work sending it to node-sonos.


#53

Well that's weird. So it seems like RM isn't sending the URL with spaces at all. There is your answer.

Maybe see if you can parse periods (.) to spaces in node-sonos.....


#54

I am using this api in my node-sonos settings. http://www.voicerss.org/api/. I am wondering if this has anything to do with causing a problem with RM?


#55

I believe Hubitat already does TTS for you... I know nothing about node-sonos...

I'm assuming you are running something like this:


#56

Exactly! I started to wonder if this might be the case with RM. I will try to take out the voicerss api and then see what happens when I run the command from RM.


#57

Didn't work. Nothing said.


#58

But when I did the http://192.168.1.100/saypreset/speakers/This is a test from a browser it worked. Only it was a different voice.


#59

Could it be something about how the text string is terminated? Period? NewLine? CR/LF?


#60

I will test this when I get home and I can hear it. I will report back. I am also going to try a different TTS api. I was using voicerss but I will try microsoft api and see if it makes any difference.