Smartwings Zwave shade driver issue

I've got a large installation of smartwings zwave motorized shades. Here's the issue. The shades respond as expected to close or set position commands but won't respond to open commands. The open command seems to set the position to 100%, but the shades won't respond. Set the position to 99% and they work like a champ. As a result they won't respond to voice commands from Alexa to open. Is this an issue with the driver? The driver doesn't have a way to limit the open % to 99.

The workaround I've come up with is to build a rule that checks to position of every shade every time a shade position changes. For every shade position at 100%, it changes it to 99%. It kind of works, but is tedious to build, not highly reliable, and probably resource intensive.

Anyone have suggestions on why this is happening?

2 Likes

My z-wave Smartwings shades respond to "open" on the device page and from Alexa. They open to 99%. If I "set position" to 100% they do not respond. 99% is perfect. I wonder if that is related to the limit settings when the shades were first setup.

I probably have close to 30 shades and all of their limit settings were set during installation. If it was related to that, I'd expect at least a few would be fine.

It appears that "open" from alexa equates to 100% which the shades don't like. I'm curious why alexa works for you. If you're looking at a shade device page when you do an alexa open, does the position go to 100 or 99?

New user to Hubitat here - I'm also experiencing the same issue as I'm attempting to setup my Smartwings Zwave shades. Open position is equivalent to position 99, so that when I try to setposition 100 or utilize a Google Assistant Integration, they won't open as they don't seem to like 100%. Would love any helpful tips for a Hubitat newbie

I just installed my smartwings shades this week, and have the same issue. 'Open shade' from Alexa issues the 'setPosition' command with a value of 100, which is invalid. Smartwings apparently only accepts values from 0-99 as valid. 'Set blinds to 99%' works fine from Alexa, but not exactly wife friendly... Is there a community z-wave driver that we can use, or is there a way to get the official driver to limit values to the accepted range?

I also attempted setting up a rule for this, but could not get it to trigger, since the command is rejected before processing (thus no position change) and there is no event that I can trigger on.

I haven't been able to find a proper fix so played around with a number of work arounds. While tedious to set up, I wrote one simple rule per shade. Trigger is if the position is ≥ 100, then set position to 99. The open command works perfectly.

Originally I tried a single large rule for all shades but found it killed the hub performance when you did any kind of mass shade opening (open all).

Hope that helps.

I started another thread on this issue, it appears there was an issue with the smartwings driver that should be fixed in the next release.

1 Like