Smartthings Multipurpose Sensor F-MLT-US-2

Can you try switching them to the smartsense multisensor (not the v4, one just above it) and see if it reports contact state?

Mine work fine using that one, we will look into why the v4 driver doesn’t report contact. I have several on my garage doors but they work in garage door mode (3 axis).

I believe I already tried that, as well as the generic zigbee contact sensor. I will try it again tonight, thanks for your quick reply.

Strange, I have the first Gen STSS-MULT-001 and I can only get contact state and nothing else with the above 2 Drivers.

Are you referring to the really old original first gen ST Multi Sensors? The ones with the 2 x AAAA batteries? If so, how did you get it to pair at all? Mine are never discovered. I can add and remove them from my ST hub all day long, but Hubitat never discovers them.

OK, I tried the other driver again.

Just changing the driver did nothing, HOWEVER, once I was using the non “v4” driver, hitting refresh a couple of times caused the “contact” state to become “live”. I then was able to return it to the “v4” driver and the “contact” state remained intact. I also opened and closed the contact a couple of times after the refresh before it started working.

I’m assuming this is some of kind of bug in driver, but maybe it has something to do the the latest update too?

Thanks again, hope this helps someone else.

1 Like

Yes, that’s the one with the AAAA batteries. To reset. Press and hold the white button until you see the LED then let go. Put the hub in pair mode and press the white button once.

1 Like

Thanks for the quick reply. I’ve tried that numerous times, using that exact same procedure, with no luck. Maybe the new .698 hub firmware made a difference? I’ll give it a try tomorrow. Again, thank you!

@Navat604 - I couldn’t wait until tomorrow… I gave it another try tonight and was able to finally get it paired. I had to change the Driver from “Smartsense Presence” to a “Smartsence Multi” and now the “Contact Sensor” portion is working.

Thanks!

2 Likes

I got it paired before the new update but I guess the new update made it easier.

I think the big difference this time was that I found an errant “Device” in my list of devices called “Device”. It must have been from a previous failed attempt to pair the sensor. I deleted that, and then it paired almost immediately.

Knowing you had done it meant I knew it could be done. Now we just have to get it reporting temperature and movement…

2 Likes

@Navat604 and @ogiewon did you successfully get the v1 AAAA multisensor working on Hubitat with acceleration reporting? I plan to more devices over this weekend and I have one of these on my garage door that would also need to come over. If so what driver are you using?

@ritchierich - unfortunately, no. I really am not a very good Zigbee/Z-Wave Driver expert. I am hoping someone with more driver writing skills will eventually come through with a solution.

Have you tried the new built-in driver for the
STSS-MULT-001 in the new hub 701 firmware?

You’ll need to update to 701 and then if your device is already discovered as something else, go into the device settings and switch the driver to the new built-in driver.

2 Likes

@ritchierich - So, I took @rayzurbock's advice and tried the 701 firmware's 'SmartSense Multi v1' driver and it works! All features are now reporting successfully!

@mike.maxwell - the only issue I see with the 'SmartSense Multi v1' driver is that the 'temperature' attribute seems to disappear as shown below. It is present in the first picture, but goes missing in the second picture.

Temperature Attribute appears on Device Page immediately after a device update....

HOWEVER, the Temperature Attribute disappears from the Device Page after a few seconds.

2 Likes

I hadn’t seen that. Thank you for mentioning. I did upgrade to 701 after it was released. I will pair it and make sure it is set to that driver.

@ogiewon thank you for confirming this works!

1 Like

Tried for almost an hour this morning and I can no longer be able to discover the device in Hubitat. I have 4 of of this old aaaa sensors. I deleted the one that was paired before I upgraded to 701.

they need to be completely reset.
Delete the device in the deice list if it already exists…
then hold the internal button down on the device until the led goes off
enter device discovery on the hub
tap the device button once, it should then pair

1 Like

I did exactly that. Is there a Zigbee limit per repeater like ST?

the number of children a repeater will route for is determined by the repeater, not the platform.
Are you trying to pair this through a repeater, or near the hub?

Tried 5 feet from the hub and 20 feet with at least 3 repeaters around. Very strange. I just added another centralite plug with no problem at all. Just these multi sensors. It was OK before the firmware upgrade.