Slow web interface


#123

I only did it after support found that the database was corrupted, I was still surprised that this could have affected my Zigbee radio. If you haven't already I would contact support and they can take a look at the internal logs.


#124

This is exactly why I replaced my Crees with Sengleds.


#125

I had basically just started with my newly install HE and was getting this issue—extremely slow load times on the web interface. My HE had just the official Amazon Echo Skill, Hub Link (to ST hub), and Rule Machine for apps (no custom apps) and just GE Z-Wave Plus Dimmer and GE Z-Wave Plus Switch (from https://raw.githubusercontent.com/Botched1/Hubitat/master/Drivers/) for custom device drivers.

I discovered, in looking at the details pages for one of my devices, that it had somehow gotten an orphaned Rule Machine child app associated with it. This “orphan” did not appear as a child app under Rule Machine on the apps page, but it did appear on the device details pages for the associated devices. My guess is that I aborted the process of creating a RM child app partway through at some point, but Rule Machine left that orphaned child app behind.

Immediately after I deleted that orphaned RM child app by linking to it from the device details page (as the orphan didn’t appear under Rule Machine on the apps page), my HE performance went to normal (i.e., pages load quickly), and it has remained normal for about 12 hours now.

Can’t prove a relationship here, but I would guess one actual root issue causing these slowdowns may be within the official RM app or may at least be surfaced from some other source by RM. Some earlier posts on this thread mentioned that they have only apps A, B, and Rule Machine or apps X, Y, and Rule Machine… it seems to be a common factor and may be one culprit.


#126

My web interface is slow also and seems to get slower the longer it goes after a reboot. I have tried all the app disables, etc.

@hans.andersson You mentioned a device that said it was associated with a rule that didn't exist. I have some that say they are connected to an app or rule when they have been deleted from that app. How would you clear that from the device? Don't know if that's the problem, but can't hurt.


#127

@j715, for orphaned rules that show up in device details pages, I just clicked from there into the orphaned rule and then deleted the entire thing. For other apps, this approach may not work.


#128

Just took me 15 minutes to create this simple rule. Everytime I clicked on something I had to wait from 5 to 15 seconds before the next selection came up. Frustrating. I have done all the things suggested above and nothing speeds it up.


#129

Do you have a netgear switch attached to the hub by chance? If so, reach out to support, they may have a fix for you.


Reliability of ethernet port
#130

No on the Netgear. I have an Asus router.

Chuck.schwer contacted me and pushed some change to my hub. It helped a whole lot. Gonna see what happens over the next few days, but so far it looks like it worked.


#131

Patrick, you mentioned in the live chat the other day that certain router chipsets were having this slowdown issue. Is there a list of which of these chipsets are having this issue?


#132

No list of choosers, we know that certain Netgear and Asus devices are effected and the fix works.

We are tracking this and applying a fix as we get reports.


#133

I've been having a lot of slowdowns lately (the last 3 months) - is this a known issue with TP-Link switches? I have the original version of the Hubitat (the one with the radio USB stick). It is frustrating that I have to reboot the Hubitat every 3 days, to avoid the massive slowdowns in the UI. If I leave it for another day or so, the rules also delay by many seconds, getting progressively worse - I've seen it delay by 30 seconds or so. And then they never fire at all! Disappointing. I cannot recommend this product to friends anymore, although it was working well for a year with the same switch.

Running firmware 2.1.1.122, after updating from 2.0.

I suppose I should open a ticket, although soon my house will be under renovation so I may have to wait a few weeks.

In the meantime, I will try disabling devices to narrow it down - I do have DLNA Player devices (3 Fabriq speakers). I have to disable them to avoid annoying the contractors anyways - maybe I will get lucky and it will mitigate the slowdown and hangs...


#134

My web interface is slow too and I have an Asus router. What do I need to do?


#135

My C5 hub had the patch applied about 5 days ago. The next day after the patch the hub stopped communicating totally. I redid the ends on my cables to no avail. I discovered the patched C5 hub now will not connect to the TP-Link switch it had always been connected to.
I moved the hub to my cisco switch and it works fine. The same cable & switch that would not work with my patched C5 hub, ran my Hue hub no problem, but refused to connect with Hubitat hub after the patch. I had not changed anything else on the switch or hub and all my devices have static IP's.

My main C4 hub does also have slowdowns, that a reboot fixes. 7 seconds for a light to come on via motion