Sensor that works unlike Zooz 4 in 1?

I bought Zooz 4 in 1 sensors but they appear to be useless. I can look and see motion detected, reports out humidity and light sporadically but often enough for general purposes. But I cannot use them to trigger anything to happen. I can use my SmartThings motion sensor or my hardwired security motion sensors to get lights to turn on. Replace with Zooz and logs always show motion detected by them but then do not do anything. Also cannot get constant led blink off despite updating the setting and syncing. Then one of them constantly turns off enable logging on its own. So returning Zooz and looking for suggestions on proven sensors that work. Need motion/lux and motion/humidity or humidity only.

1 Like

First, regarding the settings/parameters, I know you said "syncing," but to be clear, did you mean waking the sensor so that the new configuration got applied? If so, you'll need to do that to get the new configuration applied unless you want to wait for it to happen on its own after the sensor's next wakeup (by default every 12 hours) passes. If not, this would be one reason why your configuration doesn't seem to have applied. To be extra sure, you can also use the Basic Z-Wave Tool and the manual (with Z-Wave parameter numbers and values) to set anything to whatever value you want in case the driver doesn't provide that option, or use it to verify your settings (the device will, again, need to be awake for the "get" or "set" of these to go through).

But something even more odd: it sounds like you're getting events from the sensor but your apps/rules aren't responding? That is odd and more likely to be a problem with that app (or rule) instead of the device/driver since you're getting events. I'm not trying to steer you back towards the Zooz sensor if you don't like it--just trying to avoid further disappointment if that isn't really the problem. Feel free to share the app or rule configuration if you're not sure, or at least try clicking "Done" in the app, which will usually "reinitialize" it and make sure all its subscriptions and whatnot (that it will need to wake up and respond to events) are set.

I have a few Zigbee sensors that do some of these: the Iris v3 do motion, temperature, and humidity but were short-lived, discontinued, and probably hard to find now (but I did get some on eBay a while back; the v2 sensors are much more common but don't have humidity). The NYCE ceiling sensors report the same and are still in production but likely more expensive. The community-made "environment sensor" here can do all of this except motion natively but requires USB power and will probably need a case if you want it to look pretty. The Hue Motion sensors, indoor or outdoor, report motion, temperature, and lux but not humidity. The Sonoff temperature/humidity sensors report both of those and could be paired with some sort of lux and motion sensor if you don't mind having more than once device. (But I do have to say that nearly all my lux devices happen to be Z-Wave, even if I don't use them for motion that they otherwise support.)

Thanks for the info! I will check out the sensors you listed.

To go back over a few things on Zooz:

Yes I am syncing the new configuration. I wake them up with a single poke and it will say syncing then it will change to synced. One of them does it with the first wake up, the others it takes multiple attempts to wake up and get sync to happen. Even though they say synced and no longer say there is a pending change, they still blink all the time. I’ve tried excluding them, factory resetting them, then including them back and going through sync again. Same thing, says syncing, then changes to synced status. Still blinks. Since this is the only changed parameters from defaults I am a little annoyed it’s so difficult to make the blinky stop.
And I too kept thinking it was the rule applied because I originally had triggers around lux and on and off. So I broke it down to bare bones to just of motion detected and turn lights on. When I try it out it will either say in the log that motion active followed by a line saying lights already on (they are not) or motion then a line that says debug then a list of parameters being used which looks all correct as it seems to just be the configuration parameters although the event(8) vs event() that shows up differently I’m confused on. Sorry for the not so accurate description of logs as I just woke up and going off memory. If I change out sensor to ST sensor, hit done, it updates, rule is run just fine. Motion detected, lights come on. Switch back to Zooz, and hit done, nothing happens again. I switched to different Zooz, nothing happens, switch back to ST sensor, lights come on.
The third Zooz I had setup and installed in bathroom to get idea of humidity it detects over next couple of days to figure out to set up a rule for bathroom vent to come on. It was working detecting motion on and off entire day, had humidity of 43% which is about what my humidifier said, noticed before bed it was set to motion detected and it just stayed there, I tried to wake up and see if it was just stuck and could unstick it self. But nope, set to always motion active. So I had to exclude, factory reset, and include again. Cannot get that one to sync new parameters bc it’s already up on the wall with the sticky pads and do not want to take down until I get new sticky pads to use so I could try to get some readings this week maybe. So it’s frustrating to say the least.

Are you on a C7 generation (newest) of the Hubitat hub? If so, the ZSE40s don't work well and may even break your Z-Wave mesh. The issue is the ZSE40s only join to the C7 with S0 security. S0 is "chatty", draining the ZSE40 battery and affecting the mesh. The only way to get them to work correctly, and they will, is via a secondary controller (Z-Stick).

Ahh, I am on C7.
And update, it works today (although they still freakin' blink!!) . So apparently they just need sit and think about life overnight before they can start working as well as the fact they show 80% battery after I think less than 1 week of use (two at most, pandemic weekends are blurring together but almost positive I just added them first time on Friday).

I get why i had to wait overnight when I was messing with Mode manager and changing modes manually over and over to test functionality of some things. Changing a parameter like that a lot and expecting it to follow the sunset rule for Evening I had 20 minutes after was sorta expected behavior I think. I went to bed and next morning mode manager was running beautifully and has been ever since (ya know past two weeks)

I do not understand this with the Zooz sensors though. I know I added the ST sensor last week and immediately set it up to run turning basement light on and it did it immediately. No wait time needed. So what is the difference between these sensors? (besides zigbee vs zwave vs different manufacturers vs different drivers.....ok...answered my own stupid question)

Overall it seems that Zooz is a not so fun sensor for an impatient person like me to use to have to sit through every time I want to add new functionality. Especially right now when I am in my initial setup phase, learning Hubitat, and playing for first time in a bit as I had given up on ST play time as I never got sunrise/sunset to ever work there.

So it seems like using the Z-stick may allow me to continue using these sensors if I stay with them. I'm new to z sticks, so I have zero familiarity with potential quirks adding z-stick is going to have. Any tips on that for me?

also THANK YOU SO MUCH to @Bertabcd1234 and @bill.d for the very helpful replies!

You mention that your Not particularity patient which I read as going to be your biggest challenge with any Zigbee and Zwave based home automation system. :blush:
You will need patience.

If you’ve not read the How to’s, I encourage you to do so .... How Too..

These little devices seem to have a mind of their own and “adapt and route” based on the electronic environment in which they’re installed with little regard to actual physical distance.
I’ve found that pairing a device to your hub should not immediately be followed by making it do something !
Go to the beach, go to the movies or leave the house for several hours just to let the device / mesh settle. :+1:t3:

I've got 4 of the zooz 4-in-1 sensors, and I don't appear to be having the trigger issues. If you're also asking for a recommendation for another sensor, I've been having good luck with the Inovelli sensor, although I only use it as a motion and temperature sensor at the moment.

For me, the zooz sensors seem to pick up motion when there isn't any, but my placement might be a result of that. I just don't use them for the home monitoring. I did end up sending one back (was defective out of the box), and they gave me a warranty replacement. My brother had a similar issue with his (from the same order) and also replaced his. He's also a fan of the Smartthings sensors, but it might be 2 years before Aeotec starts selling them.

What does configVal7 say on the device page? The device can flash for temperature and/or motion, and I assume you've selected no flashes at all.

All 4 of mine show S2. Is this a firmware difference, perhaps? Are you confident that you have the zooz sensor and not the identical looking monoprice one?
image

Ian

The easy to spot difference is the battery. I think the Zooz takes the single CR123A battery while the Monoprice has the AAA's.

2 Likes

Do you use these sensors as well? I've only had my hub a few weeks, and haven't had issues that point to the motion sensors.

Mine are on the C5, which apparently doesn't have the same (supposed) issues as the C7.

So yes I have a couple of each (Zooz and Monoprice) but I haven't encountered issues due to being on C5.

1 Like

Check your Z-Wave Details page in the Security column, not the device page. The ZSE40s only go up to S0, they do not have S2 capability. On any firmware version.

Ah, yep, it's S0 there. I wonder if that could be causing some of my devices to randomly not update status. It seems odd that both zwave and zigbee do that to me, if this was the cause of the problem.

EDIT: Later discovered that only a single zigbee device was having the issue. After manually adjusting the driver for that device, all is well on the zigbee side.

1 Like

Alright, I will admit I've only skimmed a lot of the general documentation like the Z-wave one now that I'm moving to Hubitat but I read quite a bit several years ago when I first started with ST, I built my Z-wave network with physical switches by installing them partly where I wanted automations and partly putting some switches at locations necessary to build a strong mesh as I do have a large 4000sq ft house. I guess there are just some differences I need to get accustomed to as I move away from ST sensors only and start using different brands - I'm strange where I typically like to just pick a brand for some category and stick with that brand so I had all my wireless sensors ST and rest are from my wired security system set up with Konnected. I had stopped buying ST sensors as I could never get ST hub to do presence or sunset rules correctly so I never finished out a lot of the automations I am excited to get working in Hubitat now. I'm also trying to get out of that single brand in a category mindset with Hubitat and pick sensors based on what I need first/ ease of use second/ price last. Zooz came up multiple times in my search so I gave them a shot along with Dome water leak sensors. ST sensors added quickly and started working quickly in rules in Hubitat despite me just excluding them from ST right before. My new Dome water leak sensors implemented very quickly and were set up and sending alerts right after. Then I added the Zooz sensors. I thought that if the logs were showing motion detected correctly and reacting pretty quickly, that the mesh was established and happy and stable. This is also what threw me for a loop working with Zooz for first time as it is the first time I've run across this scenario. But it does make sense that this may not be the case for all sensors I try now. So it is a very good lesson learned here. Although, they still blink and this is not good for some places I'm using them, like when I sit on couch to turn light on. I have it right next to the couch so lights are not triggers as I just walk through to get to the kitchen. Blinking light next to your face is just not cool. So I will need to try some other sensor if the blinking cannot stop.

1 Like

I do have the Zooz branded ones, not monoprice. Zooz branded box and the CR123A battery. Mine show the same as yours and are on firmware 32.2:

  • zwaveSecurePairingComplete: true
  • S2: 128
  • deviceId: 8449
  • deviceType: 8225
  • manufacturer: 634
  • inClusters: 0x5E,0x98

And I did change the LED indicator mode to be Temperature off/motion off. I woke up the sensors and synched. One of them refuses to sync now as I put it up using sticky tape and reset it afterwards b/c it got stuck on motion active always. So now it's a bit far away from the hub. and I did take them into the same room as the hub when I set them all up originally. So it is working correctly for humidity now as it is turning the fan on when requested...just the blinking light. The other two say they've synced but blinking still so it is like that parameter is just not being updated into the device at all. I am going to wait until it naturally hits the 7 day wake up interval and see if they update the blinky then. If so, great, then it's just a matter of SUPER patience when working with these, if they never update...well, they will be repurposed into areas that won't kill my soul every time I see a blinky light.

OH, thank you for linking to this discussion. I have exactly 3x Zooz 4 in 1 sensors. So it seems as though I am destined to NOT add any more no matter even if the blinky stops auto-magically. Good to know.

1 Like

Well, thanks to you adding that previous conversation, I knew immediately when all my GE zwave switches stopped responding last night on why it probably was so after never having them stop working. Took 2 of the Zooz sensors out, kept one as I don't have a humidity sensor on order. And everything was able to start working again. So 3 Zooz sensors may work for a bit but does break things after a few days it seems. I hope Zooz comes out with the new model soon, the whole 4 in1 sensor is very useful, so many ways to use them and although not the most attractive, having them all look the same throughout the house was going to please me.

1 Like

I bought two of the 4 n 1's. I didnt read the compatability issues with C7 before I bought. I included one last night. It looks as if it doesnt update status on anything unless I pull battery and replace it.

I have to use the zwave wake button consistently until configuration changes take place when I made changes. Right now it looks inoperable.

Maybe zooz can make a custom driver?

It's a firmware issue, not fixable via driver. Silicon Labs could fix it in the Z-Wave firmware or Zooz could in the device. But they have a new device in development, so it's unlikely they're going to do something for the C7. The inclusion via secondary controller is easy and you should probably have a Z-Stick if you have an extensive collection of Z-Wave devices.

I emailed zooz and asked them. Im sure people have in the past. Its just disappointing. I have had nothing but great experiences with zooz stuff and hubitat and the 4 n 1 actually has 4 sensors that I can use regularly.

Can you mesh a c5 and c7? include the 4 n 1 on the c5?

I just did exactly that two days ago. So far everything is working fine.

Download the Hubitat app