Sengled E21-N1EA RGB zigbee bulb

Has anyone managed to get the Sengled E21-N1EA RGB zigbee bulbs to work? I just bought 2 and they simply come in as a “device” I tried the other sengled drivers and they do not work.

Amazon links here

Sengled Smart Light Bulbs, Color...

I have 5 of those and 9 of the E11-N1EA full color as well as 9 E11-G13 dimmers. I cant get the sengled drivers to work on any of them. The advanced Zigbee drivers work great however. For the E21's and E11 full colors I use the Advanced Zigbee RGBW bulb driver. For the E11 dimmers I use the Advanced Zigbee Bulb.

@eric22, okay, super weird behavior. I had already tried the “Advanced Zigbee RGBW Bulb” and it did not work. After some trial and error I found some buggy behavior that was causing this in the HE. Perhaps @mike.maxwell can look into this behavior if it’s an HE issue?

Step 1.
Joined bulb to HE and it came in as Device. The bulb flashed several times, and changed color then went solid white.

After about 10 or 20 seconds, a second, duplicate “device” showed up in HE. I named this as well and hit save, immediately, the same bulb flashed again several times and changed color then when solid white.

This was odd, because only a single device appeared to have actually saved into the HE device list. Even more odd, a 3rd device showed up, but it was the first device and said “previously connected”

Step 2.

Changed the device driver to “Advanced Zigbee RGBW Bulb” and saved.
Hit configure on the device and waited. After several minutes, the bulb would still not operate.

Cycled power on the bulb, and waited a few minutes. Tried the configure button again and nothing. The bulb would not work.

Rebooted the HE and tried the two previous items, and still nothing.

Step 3.

Went to add new zigbee device, turned power off on bulb, and started add zigbee device.
Powered on bulb and HE found the “previously connected” bulb.

Went to the device and turned off in HE. Instead of turning off, the bulb flashed several times and then turned blue.
This time, I noted the current state for the device now said blue. So I went to change the colors and it then worked.

This process was repeatable for the 2 bulbs I received. Right down to the “BLUE” color state when I tried to turn it off after finding it the last time after changing the driver.

Very odd behavior. Certainly a lot of steps to just add an RGBW bulb I think.

Yes mine go to blue too when I configure them but they paired first try.

The advanced drivers run tests as part of their configuration, normally these tests complete before users get to sending commands to them, the tests take 5 to 10 seconds, and only need to be done once.
The issues you had with inclusion were just that, be sure to only add one device at a time, which usually means only powering up new devices one at a time...
I think I already have the fingerprint for this new firmware, but if you could post it thay would be great.

@mike.maxwell to be more clear, my first attempt to connect, I only added the device 1 time. After about an hour, it would still not work. I had to reset the bulb then run the steps I previously listed. Either way, the bulbs were not treated as anything other than a “device” on discovery. I presume the signature is different than expected.
This is the signature I have for these bulbs. Perhaps they are new?

  • endpointId: 01
  • application: 26
  • softwareBuild: 00000026
  • inClusters: 0000,0003,0004,0005,0006,0008,0300,0702,0B05,FC03,FC04,FC11,FC13
  • outClusters: 0019
  • model: E21-N1EA
  • firmwareMT: 1160-80CC-00000026
  • manufacturer: sengled


I have these bulbs in the house and use the Sengled Element Colour Plus driver.
Works great here.
Good luck

I get java errors in my logs when I use that one ¯_(ツ)_/¯

Not new, just newer firmware and different fingerprint.

There does appear to be a difference between your units and mine. Different versions of applications and firmware.

Okay, so is this fingerprint not setup in the HE? Can it be added in future updates?

Yes, that's the reason I ask for them.

Re my last post, disregard!

i just purchased two of the A21-N1EA. I was able to pair them fine and im using the “Advanced Zigbee RGBW Bulb” driver, but they would not change colors. they just stayed blue after config. After some tinkering around, i found out that resetting them to a Color temp (any shade of white, then give them about 0.5 second, then i could change to another color. So i had to add this to my RM. It is not ideal as the bulb turns white for 0.5 seconds and then changes to the color i want. I assume this is because the newer versions have an updated firmware. Any one else get the newer version bulbs to work?

THAT WORKED!!!!! Weird! Thank you.

1 Like

I'm seeing the same behavior on mine. The only way I've found to change the color is to change the color to a white first... If anyone has resolved this, please share your wisdom!

Ooh! I just switched my driver to "Generic ZigBee RGBW Light" and it worked as expected. Then I tried the "Sengled Element Color Plus" driver and it seems to change colors even more smoothly than with the "Generic" driver.

1 Like

Thanks for the thread - very helpful with my Sengled E21-N1EA bulbs from Amazon. I was able to get 2 of four using the turn on during search approach, but not all. The third I just banked on bulb-to-bulb transmission and that worked, but the last would not join no matter what. So I cheated and used a socket 4 ft from my HE hub and it joined. I then moved it to its final location (I know, bad policy) out in front of the garage which meant a link through 2 outlet routers and 2 more bulbs and darn if it didn't connect within an hour! Impressive but as you say, a lot of work just to get some color bulbs added to to my house!

Yeah the issue is that the Sengled bulbs don't repeat so there is no bulb to bulb transmission, they are going directly to the hub (or nearest mains powered repeater) Not repeating with these types of bulbs is a good thing but the down side is you do need more repeaters in the mesh (the upside of that is you can't have too many repeaters!)

1 Like