Sengled Bulbs unresponsive


Symptom: Sengled bulbs are consistently going unresponsive, only way to get them going again is power cycle.

Bulb Device Data:

  • endpointId: 01
  • application: 01
  • manufacturer: sengled
  • model: E11-G23
  • softwareBuild:
  • inClusters: 0000,0003,0004,0005,0006,0008,0702,0B05
  • outClusters: 0019

Bulb Driver: Advanced Zigbee Bulb


  • changed the bulb driver to Zigbee Generic Device Toolbox > Save Device > all 4 clear buttons (State, Config etc) > Save Preferences.
  • changed the driver to Advanced Zigbee Bulb, and clicked Save Device > Configure > Save Preferences > Refresh.

After this, the bulb worked fine for a period of about 3-4 minutes before going unresponsive. Multiple bulbs are exhibiting this behaviour after working rock solid for over a year.

State Variables (at point when bulb is AWOL)

  • tt : {level=0000, off=0A00, on=0000}
  • checkPhase : 0
  • groups : []
  • hexLevel : {current=FE, requested=FE}
  • lastAddress : 9627

Logs when the bulb is not working:

  • Debug logs for the bulb: show nothing when you click the 'on' or 'off' button in the device page.
  • Zigbee logs: also show nothing.

Logs when it is working
dev:62021-02-03 16:02:21.236 infoLiving/Stairs-Sengled(white) was turned off
dev:62021-02-03 16:02:21.233 debugdescMap:[raw:catchall: 0104 0008 01 01 0040 00 9627 00 00 0000 0B 01 0400, profileId:0104, clusterId:0008, clusterInt:8, sourceEndpoint:01, destinationEndpoint:01, options:0040, messageType:00, dni:9627, isClusterSpecific:false, isManufacturerSpecific:false, manufacturerId:0000, command:0B, direction:01, data:[04, 00]]
dev:62021-02-03 15:58:23.923 infoLiving/Stairs-Sengled(white) level was set to 100%
dev:62021-02-03 15:58:23.916 infoLiving/Stairs-Sengled(white) was turned on
dev:62021-02-03 15:58:23.910 debugdescMap:[raw:catchall: 0104 0008 01 01 0040 00 9627 00 00 0000 0B 01 0400, profileId:0104, clusterId:0008, clusterInt:8, sourceEndpoint:01, destinationEndpoint:01, options:0040, messageType:00, dni:9627, isClusterSpecific:false, isManufacturerSpecific:false, manufacturerId:0000, command:0B, direction:01, data:[04, 00]]
dev:62021-02-03 15:57:48.939 infoLiving/Stairs-Sengled(white) was turned off

Had the same problem a few months ago aswell. I ended up removing all mine as i got sick of them but from memory i also changed my wifi channel around the same time but i'd say that was more of just a coincidence but maybe something to check.

hmm thanks @welby1978 in my case there's no change in wifi channel. i'm sitting firmly on Zigbee channel 24 with wifi on Channel 1 so should be as noise-free as possible in that spectrum (of course the neighbours will have an impact but they havent moved out and distance from their wifi router is always the saving grace :slight_smile:) .
i have considered throwing them out in the last week or so with all the complaints from the family, but Hue bulbs are just so damn expensive. AND these worked just fine before so I can only assume its an introduced bug of some kind, as its hard to imagine that about 6 bulbs failed in the same way at the same time.

Yeah i feel your pain, i ended replacing mine with nue switches and a few tasmota bulbs. Wasn't the cheapest option but worked lol.

Please send all Sengled bulbs to me, I'll pay shipping. :wink:

Just kidding, but mine are working fine, best they ever have, w/the new Advanced drivers in 2.2.5. I only have three in use, though, (two color, one extra bright white) so maybe there's a penalty/issue when you have a lot more going at the same time?

How old are the bulbs, and did you ever do any FW updates on them (requires Sengled hub)? Mine are all purchased in the last six months...if yours are older and never updated, maybe they have older FW that isn't playing well w/newer Advanced Zigbee driver?

1 Like

I have a Sengled element classic(E11-G23). It's a couple of years old.
It has been working with no issue using the ‘Sengled Element Classic’ driver.

When the advanced drivers were released I tried the ‘Advanced Zigbee Bulb’ driver...and it stopped behaving well. So I switched back drivers.

Have you tried the Sengled Element Classic driver?

hi there, no i never connected to a sengled hub, so no FW updates. you could be right that...something has changed and its not just the new Adv.Zigbee driver, also happens with the Sengled Classic driver.

I have also had strange things happen with my Sengled bulbs, a lot of them started appearing in the Zigbee repeating table (and some still do) and report as bad repeaters. Sengled do not repeat so didn't make sense and couldn't get an explaination from staff or Sengled as to why

1 Like

Try removing them and adding them back. One of the recent updates (around the time of the new drivers) rendered mine useless. I simply removed/added back with the new driver and they've behaved so far.

I have 10 bulbs at one location and 8 at another. But I haven't updated those hubs to the latest Hubitat version, I have a policy if it works don't break it. All the bulbs are either using the generic ZigBee or regular Sengled driver. I do use scenes with the bulbs so group commands are a must to avoid the popcorn effect.

The last batch of bulbs I purchased, on Woot, were 3 revisions behind on the firmware. I keep a SmartThings hub around for flashing their firmware. I just did a upgrade to my development C-4 hub and will be joining these bulbs there to try out the advanced driver, scenes and other things before I make any leaps.

yeah i've been avoiding that, because being the serial automater that I am - and i suspect i am in company here - the bulbs are in plenty of rules.
do you know a way to remove and add back devices without the tedious and error-prone process of removing all the rules from each device, delete/re-add, then go back and re-apply all the rules?

** note i do know how to replace a device without having to do this, but not remove/re-add...

thanks Shane. did you see this Bad Repeater description in the hubs Zigbee Routing Table?

if so i haven't seen anything along those lines.

or is there another hidden page i have not found yet that could help troubleshoot?

lol great advice in anything tech... if it aint broke don't fix it.
problem is these guys at hubitat keep adding support for products & new features i want to use. i am :slight_smile:

i am a ST refugee and have a hub in my collection of old useless tech gathering dust. confirming you can upgrade sengled bulb firmware from a ST hub? if so that could be a last ditch attempt at stability.

Yep it's in that table. My study light and porch light are Senglend but I also have 4 living room bulbs that are the same bulb. The only difference is I added the study and porch 6 months after the living room. Else I bought them all at the same time. I also have 6 other sengled bulbs bought at a different time that also display in the table which I've kept off the network for now

Neighbor Table Entry
[Repeater (Rm Pro), 16D3], LQI:132, age:3, inCost:7, outCost:0
[Repeater (Kitchen Kettle), 33ED], LQI:254, age:3, inCost:1, outCost:5
[Lidl Plug, 737A], LQI:255, age:3, inCost:1, outCost:1
[Repeater (Porch), 8F18], LQI:115, age:7, inCost:7, outCost:0
[Study Light Group, 8F5D], LQI:1, age:7, inCost:7, outCost:0
[Porch Light, 9AFD], LQI:123, age:3, inCost:7, outCost:7
[Living Room Extension Lead, 9DEB], LQI:107, age:3, inCost:7, outCost:0
[Kitchen Light 2, A694], LQI:220, age:3, inCost:5, outCost:7
[Kitchen Light 3, A81D], LQI:255, age:3, inCost:1, outCost:7
[Repeater (Master Bedroom), B983], LQI:229, age:3, inCost:5, outCost:7
[Kitchen Light 1, F6C6], LQI:252, age:3, inCost:3, outCost:7
[Repeater (Hive), F9F2], LQI:253, age:3, inCost:3, outCost:7
[Pantry Switch, FCF4], LQI:182, age:3, inCost:7, outCost:7

My Sengled bulbs are a little wonky. I have a rule called by a Pico that should cause a bulb to turn on to 100%. Sometimes it works, other times it turns on to only 50%. If I press the Pico a 2nd time then it goes to 100%. This on a C-5 and 2.25.124.

did you change to the new drivers? if so, did you do the sengled bulb dance?
( after changing the driver to Advanced Zigbee Bulb, click Save Device > Configure > Save Preferences > Refresh )

Not seeing Refresh button...

sorry. my bad. i mis-typed that because i had used a community driver (generic zigbee device toolkit), which allows wiping all configs/states/variables etc.
it has a refresh button.

but you can also use the built-in 'Device' driver for the same function

Unfortunately, I don't. I've got some really complex settings/rules on specific devices and it's brutal to rebuild them all when the device misbehaves (I'm looking at you Zooz Zen23s).

I usually take screenshots of everything the device is involved in. I don't do the remove device from all the rules step. I just remove the device, re-add, and rebuild. Worked so far, but it's definitely painful. Huge fan of cloning rules and that functionality.

Wish you could put a rule "under construction" and do some sort of device place holder that could be addressed once you've fixed the troublesome device.

1 Like

Just did this, and it’s working great at the moment.
Hopefully it will continue!

1 Like