Schlage J-series (JBE109) working, but wondering about driver and setup

Just purchased a Schlage JBE109 Deadbolt
(My other non-smart locks are all Schlage, my other smart devices are ZWave, and according to Z-Wave Alliance this lock is ZGM130 radio/zwave version 7.11.1 -- so this 700 series Z-wave lock felt like the way to go)

Have a couple of questions, but first, here is the background:

  1. I tried to add the lock using SmartStart (the first time I've used SmartStart)
  2. I scanned the QR code and waited. After a few minutes, it didn't appear to work--no indication of anything. So...
  3. I decided to try and add using typical Inclusion BUT when I went to put the device into inclusion mode the device seemed to balk.
  4. Tried an exclude and it also balked, so just before factory resetting and trying again I...
  5. Looked at Settings::Z-wave Details and there was a new unnamed device (by Allegion, the parent company).
  6. So I went to devices...no new devices...
  7. Went back to Z-wave Details and it was still there so...
  8. I clicked on the device URL (which had a name like 'Device' or something generic, can't remember) and...
  9. A device page showed up without a name or a driver. So I added a name, a label, and chose Generic Z-Wave Lock driver.

Lock seems to work now, including with Lock Code Manager (it has only been a day or so). Once in a while seems a little slow to respond or stubborn to update the icon in the dashboard, and it failed with a couple of Z-Wave Repairs, but seems to work better after the last (successful) repair.

So...here are the questions:

  1. I am guessing I should've waited longer with SmartStart (user error)? or might it have been something else?
  2. Should I remove, factory reset, and re-include it? or just go with it?
  3. Will there likely be a new driver for J-Series, or does it matter (just use Generic)?

Thoughts? and thanks in advance.

Jeff

@jeff11 Make sure you did not create any ghosts. Check your z-wave table.
Ghosts will not have anything in their routing column. These must be removed before you do anything else. Now with using smart start, let your phone sit for about 10 mins, the device will eventually show up in the device list. When pairing in the classic style, you need to pair the device within 3 feet of the lock due to their whisper connection that passes the encryption. Locks must be paired with encryption. (Leave everything else paired without)

As to the slowness to respond that could be a few things. How does your mesh look? (Post a copy of your z-wave details page) With Schlage, putting a beaming repeater nearby always helps.

1 Like

Ahh...should've waited 10mins (or longer?). So it was a short-attention-span user error. (Should have done a little more research on SmartStart and maybe I would've found the "within 10 minutes" in the Z-Wave Manual | Hubitat Documentation and maybe also SmartStart How long does it take? and What is the point of zwave smart start?.)

I am attaching my Z-Wave Detail Devices Table and Topology and you will see the lock is device 0X68. It must have been 'mid-add' and in Z-Wave details but not in devices until I clicked on it in step 8 above.

So now...

  1. should I remove the device and re-add? or just continue?

  2. Any other thoughts on my Z-wave mesh? (you will notice two Zooz devices 0X12, 0X14 which I have powered down because they weren't working correctly, and I haven't had a chance to work on them).

  3. Driver thoughts? Use Generic driver? another Schlage model? hope for Hubitat to make an official for J-Series? is there a community driver? (my search didn't yield one).

  4. Also, how do I tell if a device or repeater is "beaming"?

Thanks again community!

Is this what you recommend I post rlithgow1?
Seems like the lock got added in the end during steps 7-8 above.

Do you see anything of concern with my mesh?

Would like to understand it more, but still new to it. I don't have a Zwave stick or anything, I've been wondering if I should get a stick and use some of the tools mentioned in other threads to study my mesh and figure out what else it might need. (Also wanting to get a version of lewis.heidrick's antenna mod.)

0x12 and 0x14 should probably be re paired without security. Other than that it looks pretty decent. How is the lock working at this point?

Lock Code Manager seems responsive. I’ve wrapped it in [Release] Reliable Locks because it seems a little sluggish to respond and if I trigger it directly once in a while it puts a question mark on the dashboard (not reporting status correctly?). So paired, but signal issues?

I have a couple Zooz switches (Zen 71 and Zen 73) in that same room and they are a little sluggish sometimes. I also have an Aeotec Extender 7 about 15ft away through a wall.

(Also, newbie question, but how do I tell if a lines powered device is a ‘beaming’ device? I know in other threads you’ve mentioned having a beaming repeater next to the lock)

Mains powered devices are repeaters but if they are in metal boxes that will hinder single.

You would be hard-pressed to find a line-powered z-wave device made within the last 5-10 years that is not a "beaming" repeater. Beaming repeaters simply repeat the message until the battery-powered LSS/FLiRS device receives it.

One way to confirm that a product supports beaming is to look at its "Z-Wave Protocol Implementation Conformance Statement" from it's product page at products.z-wavealliance.org

For example, the conformation statement for the Aeotec Range Extender 7 that you mentioned having has this within it:

Thanks so much for the explanation.

1 Like

Download the Hubitat app