Schedule hub reboot at a specific time

Hi
I noticed lately I get delayed automations especially when it comes to light with motion detection where sometimes light won't turn on for 4 or 5 seconds or even longer after motion is detected. This usually happen when hub has been on for few days
Rebooting hub or power cycling it fixes the issue and automation becomes instant
Is there a way to schedule reboot of the hub like sometimes during the night or something
I appreciate your assistance
Thx

You should not have to, and it's not recommended. It's better to find the issue. But if you want to, you can do it like this with a switch and @ogiewon HTTP as switch. There's other ways to do it in RM too. I was using this for a short time, but I found and fixed my issue so it's disabled.


1 Like

It's easy to schedule something for a specific time using RM4.
For example:

2 Likes

what could be the issue? network or what? I'm not sure how to troubleshoot

Disable custom code to start. No need to uninstall. Disable is instant and easy. From there you can re-enable to see when the issue occurs. Yes this can take a while. Sometimes weeks. Better than living with the issue and rebooting.

How to disable is at the bottom of each doc.

Devices
https://docs.hubitat.com/index.php?title=Devices

Apps
https://docs.hubitat.com/index.php?title=Apps

Look also for orphaned Zigbee devices you no longer have paired with HE, and if there are any, delete them and give the hub an overnight database cleanup.

If you find orphans in the Z-Wave devices list, exclude those devices if they are available.

Also have a look at scene transitions. Too many transitions or too many light bulbs transitioning at once slowed down my Hub to a halt...

I did that but not sure if it's really rebooting
can you let me know if this looks right?

2 Likes

Check your system events. It will show when the hub rebooted

1 Like

I'd like to also suggest that after you do a reboot, you "turn off" the zwave radio for a few minutes. (Post "disabled", to the zwave settings page.)
(Thank you: @SmartHomePrimer )

1 Like

I don't see any reboot event on system events, something is wrong I believe in the rule

how do you accomplish that inside the rule?
Thx

You forgot the port 8080

2 Likes

As part of the Action of a rule, the following command executes a reboot (after a 5 minute delay):
image

Happy new year all! I don't see any resolution to the OP's underlying problem, so just wanted to note that I have the same issue - on occasion, automations respond to triggers super slow or not at all until a reboot, and then all's normal for a while...I've tried looking through logs for problems, disabling 3rd party apps, etc. but can't figure it out, so I'll be doing the regular reboot now as well :frowning:

I attempted to create a rule with the following action: (json) http://192.168.0.60:8080/hub/reboot
I left out the delay for now while testing.
I get the following error message: Error 404 ### The Page requested could not be found
What am I doing wrong? What goes in the Enter body for POST field?

Hmm... looks OK to me ...
Do you have security turned off for your hub?
(i.e. is it possible to sign into your hub without a username/password)?

I seem to remember that one recent version had a problem with POST.
Which version are you running?

This simple app handles auto reboots and security easily! it works like a charm

2 Likes

Security is enabled.

Hubitat Elevation® Platform Version
2.1.8.115

or you can reboot using curl from another computer - like an RPi.

Negative

Not sure what you're saying? That @dman2306's app doesn't work for you? Or something else?

If his app doesn't work for you, you should report the outcome/logs etc. on the thread for that app so he'll be sure to see your post and help you figure out a solution.

If that doesn't work, I'll be happy to share shell scripts that work under Linux (and maybe cygwin) to reboot the Hubitat at a specific time.