Rule Machine suddenly having problems with thermostat

Recently my RM 5.0 rule (Setting Morning) for morning settings (duh) is having issues. It's simple, it's worked fine for quite a while...

It's the Bedroom Thermostat.
The action triggered at 6:15 this morning - but didn't change the thermostat.
I manually changed it at 6:17 using Home App on my phone (HomeBridge)
Here are the Events...

And here are the Logs which show that nothing was logged at 6:15...

This is a regular occurance now.
Is it me? Am I missing something?

Looks like the rule sent the command, but the thermostat didn't respond for whatever reason. Enabling all logging for the rule will show you more details, including what it's actually trying to set it to (something you can't see in the event/command history) and is generally a good step for app troubleshooting.

What kind of thermostat is this?

Z-wave thermostat. CT100. I've tried the CT101 device type and the Generic Z-wave device type. Same result.

I'll enable more logging and see what I get.

We have seen a couple of other reports about issues with CT100 recently. We will investigate.

1 Like


@random could you PM me your hub id?

Yes, haven't PMd in here before - that's just the Message icon when I click on your name, right?


Did your other thermostat in this rule get set properly? The Cantina Thermostat?

Yes. It changed as expected.

I have ordered one of these thermostats for testing

1 Like

While we wait for the thermostat to arrive.. Can you turn on debug logging on the thermostat driver page and trigger your action again?

Okay, debug logging on. And I set the thermostat to 17 using Home app (Homebridge) so that it wouldn't be 18. Then triggered the action.

Can you see the results, or do I need to screenshot some stuff?

Screen shot, please ..

:thinking: Ok.. I see the command got sent to the driver.. Did the thermostat update the setpoint?


Very strange... Ok.. while it's in debug mode still.. Can you set it manually like you did before? I want to see if the command being sent is different somehow..