Rule Machine: Motion detector initiated rules just stopped working

Hello,
I had successfully configured several rules to use motion detectors to to turn on lights, fans, etc. All was good until recently (7/18 to be exact). The actions no longer work.
EXAMPLES:

  • I step into the dark laundry room and see the zooz 4in 1 motion sensor blink (motion detected) but the light is not turned on.

  • I step into the office and see the motion sensor (zooz also) blink yet the fan does not turn on

  • The bathroom sensor (same) in the bathroom does not turn the exhaust fan on when humidity is 60%

No changes were made to these rules. It only seems to be the rules that use these motion sensors. In the device details they all show a "last activity time" on the 18th.

I enabled logging on the rule and dot see much at all

I rebooted the hub (when in doubt?)
I "refreshed" the rules and devices by opening, editing (no real edit...turned on logging) and clicking 'done'

Anyone have an idea or point me in the right direction for troubleshooting. Maybe I should reset the sensors? Although Id prefer not to.

Thanks in Advance.

On the events tab of the device page for the motion detectors, do you see the active/inactive events?

Is this a c5 or c7 hub?

Here is a snag of what I see. It has been quiet since 7/18. I walked into the laundry room at least 5 times today and walked in right before sending this to confirm that I get a 'motion blink" on the sensor.

Rev. C7

Hmmm, could be a low battery, i.e. enough to power the device but not enough for the signal to reach the hub.

Just to confirm, you're having the same problem with three separate motion sensors, all zooz 4-in-1? I've not had the best of luck with these, and I think you'll find if you do a search that's not an uncommon thread. The newest ones seem better by all accounts.

Might indeed be a low battery as @thebearmay suggests. Can you post your zwave details page? I wonder if they show up with routes or not.

Yes 3 different motion sensors. All are zooz 4 in 1. they all display that batt is at 100
2022-07-20_13-59-13

I was unaware that these have a history of problems (that sucks) they worked well for so long and its odd that they ALL stop reporting back motion detection on the same day. They also report illuminance, humidity and temp still. I dont recall any changes made to the device, app or driver..or hub for that matter.

Do you think I should reset them and re-discover them?

Thanks

I am having the same problem but with my Sengled color light bulb automations. I've even tried reverting back to simple automations. And I use a mix of Third Reality, Sonoff, and Hue outdoor motion sensors. The Hue automation for lighting in my kitchen is working, but it's different for me because it does not contain a Sengled color bulbs. Hmm

If you do, do so WITHOUT security. If they are the 500 series sensors you will need a z-wave stick paired as a secondary controller. If they are 700 series, just skip when prompted. I recommend you use @jtp10181 's custom driver for these.

Are you using the zooz 4-in-1 sensors?

Thanks I will try. I dont recall using drivers for the sensors. I just 'added device' and zwave discovered and added. Are you suggesting I install the driver anyway? these are the 700s.

Yes, his driver is much better than the native one. It's available in HPM. That said I would still include it without security (as well as anything else except for garage door and locks

Got it. Thanks the info and your time! Ill post an update as soon as I get one.

Ok so the Saga continues...
I "refreshed" one of the motion sensors by pressing reset button twice with paper clip and nothing changed. the sensor still not reporting motion to the hub/rule and light is not turning on.

I reset the same motion sensor and tried to add back via 'add device' and z wave inclusion would not find the device to add. I also tried excluding then including but the device was not found/ added.

I also installed the Zooz Advanced motion sensor driver by @jtp10181 as suggested. but all I got was the following message

In the hopes of proving that it isn't the sensor I tried adding a brand new one (out of the box) and was unable to add the new device. This is weird. Could it be that I have too many devices add to the hub? Have I reached the limit and it is ignoring my 5 motion sensors?

Other devices work fine. I have bulbs, switches, buttons, etc. all are working good. Maybe a zwave thing? its weird that its only affecting the zooz 4 in 1 motion sensors at the same time.

At this point I am kind of lost and throwing every search I can think of against google and this community search bar..haha.

Can you post your z-wave details page?

That and also do a full power down of the hub, unplug for 10 seconds then boot back up. Sounds like the zwave radio has gone on strike, the power down will restart it.

1 Like

Sure, Is this what you are looking for? If not Please tell me where I can find the details you are asking for (still a noob!)

Thanks!

no settings>>z-wave details in full (including routing column)

Yeah Ok, will try that now. Thanks!

Download the Hubitat app