Rooms Manager: Smarter Rooms: Personalized home automation with Occupancy


#749

button press refers to use of a button device. pressing the light switch button will not work as button press. however you also have an option of setting the occupancy state by turning on a switch. if you check the occupancy settings you should find it there.

so long as the motion sensor can cover the entire room one motion sensor is enough. for most rooms it works best to put the motion sensor such that its on the corner of the wall where the door is and it faces diagonally to the other corner of the room.


#750

So it can be done like I mentioned by just turning that specified light on? I just had the wrong area ?


#751

right. specify it in the switch settings for occupancy.


#752

Quick question. If a room is set as Engaged because a specific switch is turned on, and the Checking command is manually triggered for that room, should it still show as engaged since the switch is on? If so, it doesn't seem to be working correctly for me.

I created a virtual switch that sends the Checking command to all of my rooms. I made it for situations where there are multiple rooms still waiting for the occupied timer to count down, but I know I don't plan on going back there. It seemed like an easy way to turn off all the lights with one button press. The problem is it seems to be setting the room I'm actually in to Vacant as well even though it should be Engaged since I have a specific switch turned on. It seems like it's only checking for motion.


#753

Feature Request:
DimOver is currently being applied to both turning on lights and turning them off. Are people using this. I would like to suggest that this only apply when lowering the level of the lights. i.e. if the level you are setting to is lower than the current level.

A 30 second dim to off feels smooth when a room is going vacant. A 30 second set level doesn't really work when you walk in to a dark room.

Otherwise, can we get a separate setting for raising the light level or turning lights on?


#754

I do use the dim on, but I agree that it would be good to have separate settings for dimming on and dimming off


#755

right. sending a manual checking command will do that. it assumes the intent of user is to change the room to vacant unless off course they happen to go back in the room which would then trigger motion and cause it go back to occupied or engaged.


#756

i will add separate controls.


#757

update to github with the following changes … remember to update driver and all apps because version check will fail otherwise. no subscriptions have changed so dont need to save settings.

Version: 0.99.5

DONE:   1/17/2019

1) exposed command optimization setting in general settings
2) check switches on is now any on instead of all on
3) room vacant check bug fix

@talz13 try turning on command optimization for your rooms and see if it makes a difference when multiple rooms are triggered together. i would try turning on a couple at a time and make sure it still works fine before turning on the nexts.


#758

:grin:


#759

Updated. I now have all my rooms migrated to hubitat and it is working great.

I do have a small suggestion.

If you change the Source link in the comments header to the raw url. i.e if you change

 * Source: https://github.com/adey/bangali/blob/master/smartapps/bangali/rooms-child-settings.src/rooms-child-settings.groovy

to

* Source: https://raw.githubusercontent.com/adey/bangali/master/smartapps/bangali/rooms-child-settings.src/rooms-child-settings.groovy

Then people can simple copy the url out of your source header into the import popup in hubitat when updating.


#760

Does anyone have an example of the device connectivity check working? I've tried everything I can think of to get this working. But I have never once seen it send a text.


#761

EDIT: you are right it wasnt working. there was a bug in the time check routine. fixed and updated rooms manager only code to github though the version numbers have not changed. update only the rooms manager app code and save the settings for rooms manager to fix.

sorry for the trouble.

heres one:


#762

I thought i was the only one haha Will test later today. Haven't updated in a few months before and everything was really stable. Nice work!


#763

Building on the separate dim on / dim off settings, do you think it would be possible to add the dim timer to the maintain rules settings? It would be nice to be able to have different fade times for different situations.


#764

sure … will add to my to do list.


#765

Still no luck unfortunately. I had a motion sensor go out on me and I didn't hear a peep out of the rooms manager sms alert. My setup is a bit different than what you have displayed above though. I don't have any TTS devices. Nor do I have anything set up for color announcement.


#766

Do I need a second rule to turn the light off when the rooms goes vacant or is that automatic ?

By using contact sensors it seems it will only trigger if that contact is left open?

Can I keep the lights off in a room by turning off the switch and they stay off even though there's motion? Like for watching TV. I know I could create a movie mode and do it that way, but I don't want the whole house changing the mode since hubitat doesn't support secondary modes.


#767

dang it. will check this weekend to see if that might affect the notification by removing the battery from one my devices and letting that sit for a few hours to trigger notification.


#768

I just tried installing rooms manager today, and after I set up my first room, I tried going to "All Settings" in that room and got the on-screen error and log errors:

On-screen error:

All Settings

Unexpected Error

An unexpected error has occurred trying to load the app. Check Logs for more information.

Error: Child app not found for namespace: bangali and name: rooms child settings

Log errors:

app:290   2019-03-06 09:10:35.878 am   error   hubitat.exception.NotFoundException: Child app not found for namespace: bangali and name: rooms child settings on line 1400 (pageAllSettings)
app:289   2019-03-06 09:10:35.867 am   error   hubitat.exception.NotFoundException: Child app not found for namespace: bangali and name: rooms child settings on line 1400 (pageAllSettings)

I followed the driver installation instructions to comment and uncomment specific lines to work in HE.

Is there something I did wrong with the installation or somewhere else?

PS: I searched the community pages for these errors in case someone else ran into them but couldn't find this exact error.