RM 5.0 Bug

@bravenel l am moving some RM 4.0 rules to RM 5.0 to use the new Hub variables.

I am doing a simple compare of one variable to another. Both variables are local decimal variables.

If I change the Variable* or Select variable dropdowns both change to the same thing and I never get a done button.

This is a direct rewrite of an existing RM 4.0 rule that works.

Just a guess but maybe you need to click Create to create the connector so the value can be seen by the rule?

I moved some global variables to hub variables and it wouldn't work until I clicked Create and the type was displayed in the Connector column.

These are not hub variables just local variables. I don't want or need them to be connectors.

If someone could verify if they see the same thing it would be helpful. Maybe it's my system, but I have rebooted the hub, and it made no differnce.

I created a new RM 5.0 rule with just two local decimal variables called temp and temp1. I can not do any kind of comparison of the two variables.

I just tried and see the same thing you described. No Done button. If I put 0 or any other number in Variable Offset for the 2nd variable the Done button is displayed.

1 Like

I will investigate. Thanks.

1 Like

There seems to be other issues as well.

I cloned a working RM 5.0 rule. I then updated it for the new device. This rule creates a formatted string which displays the energy cost for a energy device, which I can then display on a dashboard. When going through it I decided I did not need to use the KWHCosthold variable. So I removed all references to that variable and deleted that line, first line of the rule below. It then caused several lines of broke actions. Also shown below.

csrule2

The actions that broke have nothing to do with that variable. So I just added back the actions that broke and deleted the Broke actions lines from the rule. Now the rule will not run. See updated rule and log output below. It is stopping right after the first action that broke when I deleted the line so I assume it has something to do with that. Maybe I am missing something but this is an exact duplicate of another rule that is working under RM 5.0

Another issue I came upon was in my first attempt to edit the rule instead of inserting a new line above a broken action I selected the broken action line to edit. It seems I had done that in RM 4.0, but not 100% sure.

After selecting the line I could no longer edit the rule. It displayed broken action where you would normally see the line you are editing, but there was no option to do anything else. Every time I left and came back to the editor it was stuck at that same place. I just had to remove the rule and start again.

Kind of like the old joke, does it hurt when you do that, so don't do that. It seems, however, it should handle it a bit better.

Just so I could see if I could get this working I went back and cloned the working rule again. This time I only changed the variables I needed to and left everything else as is. It now works.

This one is fixed in upcoming hotfix release.

I will investigate this... Thanks.

Fixed. Can now compare variables, Thanks

2 Likes

Another interesting one:
I created a rule with several variables to act as presets with which to compare outside temperatures (see screenshots below) and started building conditions. I got to a point where I could no longer select variables when building a condition. I wanted, for example, to compare the humidity with the outsideHumidity preset. When I get to the point where I check the "relative to a variable" box and try to choose a variable, nothing comes up. I am using the Accessibility/screen reader mode, so I thought I'd turn it off and try in case it is a bug specific to that, but unfortunately no variables showed up.

Thanks,
Zuhair.




I will investigate...

2 Likes

Another possible bug in RM5, I setup a couple of new rules using hub variables that had the same name as the old global variables.

Anyway, the new RM5 rules worked great so I deleted the RM4 rules and the old global variables…. And then my 2 new RM5 rules both stopped working.

When I went into them, the IF statements referencing the new hub variables were broken with blank spaces instead of variables comparisons.

This problem arose do to the released version being too restrictive about the type of variable that could be used in the comparison. For instance, humidity is an integer attribute, so Rule 5.0 was limiting the choices to Number variables. But you have Decimal variables, so those were not offered as choices. The next release will relax this so that either Number or Decimal variables can be used for comparisons.

4 Likes

I think as a consequence of the update, everyone might need to go back and check any rules that used a real comparison. I just noticed this morning that one of my cost displays looked funny so I went back and looked at the rule and in two places where a compared a decimal variable to a constant the line had been deleted. In every rule, I had five, that did the same thing and both lines were deleted in each rule. I have others that do comparisons of two decimal variables that seem to be OK. I still only have a few RM5.0 rules, and my RM4.0 rules seem uneffected.

The first was IF FractPart <0, and the second was If FractPart < 10

Hello, I moved the following rule from RM 4.0 to RM 5.0 and it doesn't function as it did previously:

What happens is the notification and TTS never trigger now when the sensor reports that it's wet.

When the Sensor is Wet and I click "Run Actions", then the TTS and Push Notifications trigger, but even then it reports the device name as "null", and the status of the sensor as "0".

I noticed that my rules with repeating actions seem to be the only ones with issues in RM 5.0.

Another one that doesn't work quite properly from RM 4.0 to 5.0:

In RM 4.0, when the windows open, it send a notification to our phones, but then stops sending the notifications when the windows are both closed.

In RM 5.0, the trigger conditions start the notifications, but when the windows are closed, it never stops the repeating action until I click "Update Rule".

I noticed that my rules with repeating actions seem to be the only ones with issues in RM 5.0.

This is the expected behavior when you “Run Actions” because, in that instance, the rule is not triggered by a device event.

1 Like

Turn on logging for Events, Triggers and Actions. We need to see the logs for the sequence of events that represents a failure.

@bravenel
Turned on logging and noticed that when my RM 4.0 rule is active,
-the logs show the Water Sensor change from dry to wet
-The RM 4.0 Rule Shows up and reports logging on the app
-My Speakers show up because they're in the rule

When I pause the RM 4.0 rule and reinstate the rule in RM 5.0, that has the exact format:
-the logs only show the Water Sensor change from dry to wet...that's all that shows.

This may be completely unrelated, but another thing I noticed is that in RM 4.0, when I created/selected the trigger events, the same trigger events were available for selection when I created the action. In RM 5.0, I notice that after I create/select the trigger events and then go to create the actions to run, I have to manually select/create the conditions under which the rule should run. Is that change by design?

Yes, this is a change in Rule 5.0.

Please post a screenshot of the Event Subscriptions section of the Rule 5.0 App Status page (gear icon).

Download the Hubitat app