[Resolved-Router Issue] Cloud connection is unavailable

I've got a Hubitat c7 that' stuck on v2.30.0121. The Hubitat sort of works. I've been able to add devices and can toggle them on/off, adjust lights brightness, etc. For some reason I'm unable to get my Hubitat to update. In the top right corner of the Hubitat screen I get the error 'Cloud connection is unavailable.' I assumed that was a pay service but after reading many posts about the error 'Cloud connection is unavailable' it seems this is necessary in order to get updates?

I've got my Hubitat on a multi-vlan setup that's currently on my main computer/desktop vlan. I don't have any rules restricting this vlan. I've tried all the Network tests @ and all of them pass.

I've emailed support@hubitat.com multiple times but only get the canned response pointing me to community support forums. No human from Hubitat has ever emailed me back in over a month. I only see an option to request a warranty claim but it's odd to me they'd grant warranty submissions without first troubleshooting or attempting to assist a customer.

I see multiple posts with the 'Cloud connection is unavailable.' error but I don't see any clear details on how people have resolved this other than checking firewall rules.

Can anyone help me resolve this?


@ray.beck Yes, support is contacted through the forum. Just tag @support. That said, I'm gonna bet you likely have a static ip? If so, press the reset button on the bottom of the hub with a paperclip or toothpick for 7 seconds. This will reset your network settings ONLY on the hub. Then set a reservation in your DHCP for the hub. As long as there isn't some weird routing issue between your vlan and main network you should be fine. If it doesn't go through then move the hub to your main lan and see if it works. If it does then you know something is up with your vlan setup. Please report back.

1 Like

@support_team I already had a DHCP reservation for my hubitat. I reset my hubitat via paperclip as you suggested. The hubitat reset/rebooted but I still get the 'cloud connection is unavailable' error message. The hubitat is on my main desktop/computers vlan with no firewall restrictions (allow any for both source/destination). I can access my hubitat from other vlans but for some reason it seems it's unable to talk to hubitat servers. Is there anyway to push an update locally?

No... No local updates like that. I suspect something is up with your vlan config. I would move it off the vlan to your normal raw network to test. (make sure it's passing DNS) and test that way. (Eliminating vlan's all together for test purposes) The fact that you can get to it shows it's online so this is likely something with the way your vlan is configured. If you go into the diagnostic, can you ping

1 Like

I'd need a separate router to work off the 'raw network' which I don't have.

I'm not sure where you're talking about when you refer to 'go into the diagnostic'. If that's the hubitat Network Test page, then yes I posted all those results in the image above showing ping successful.

Sorry I see that now. The fact that you can reach that shows that the hub can connect to the internet but I suspect somehow inbound packets are being blocked at some point. That's why you need to move it to a "raw" network to test and work backwards (I'm a network engineer so without being there this is how i would work with playing process of elimination)

1 Like

I guess I'll have to return this for warranty then because I can't take down my entire network down to put in a separate router and troubleshoot this.

I'm really disappointed in the lack of support from Hubitat themselves. They need to fix their email canned message to let people know that they don't respond to emails and that you have to reach out to them in the community forums but even here it seems their support is sparse.

They are quite active here and very responsive including @bobbyd. Replacing the unit under warranty will not solve your issue. You are going to run into the same issue unless you solve your lan problem


Thanks for your feedback. Have you tried connecting the hub to your primary network to see if that allows the hub to connect to the cloud? The only thing that is under our control that may prevent a hub from connecting to the cloud is if the internal time drifted off. Other than that, as @rlithgow1 suggested, is related to your local network setup. To ensure that the time is correct, go to Settings, then select Hub Details and click on Update Time from Browser. Allow a few hours to see if the hub connects.

As for auto-response, we have clarified the message this past weekend:

1 Like

I could connect it directly to my cable modem but that isn't going to do me a lot of good as I wouldn't be able to connect to it with my network down.

I may have to try to hack something together with a laptop connected to a hotspot and try to share the internet via a usb>ethernet. I don't know if that will work but it's the only thing I could attempt as I don't want to take my entire network down nor do I have a separate router to test on.

You got a response from Support within 4 hours of posting here. Iโ€™d say thatโ€™s pretty quick, wouldnโ€™t you? Especially for a ~$100 product.

Thanks for your constructive input. I've posted previously, no one from support responded and those issues are still outstanding.

Could you post links to those other topics? Because I agree with you that they should be resolved.

When I search the forum I can only find 2, including this one. Both of which seem to result from the same network issue. So it would be good to know what the others are.

1 Like

Get a cheap 20.00 tp link switch at Home Depot. Plug that into your router and plug your laptop and hub into the switch (make sure you're getting dhcp from the router) and that should allow you to test everything. You can always return the 20.00 switch to Home Depot

I only have one other post. I supposed I should have created a separate issue because I sort of lumped it on to my previous post. It's regarding connecting my Hue hub to the Hubitat. The Hue Bridge Integration app gives no input... it just says discovery is started but nothing ever happens. I never know if/when it's discovery was completed, regardless it never finds anything.

Had the same problem the above post by support fixed it.


Thanks for the reply. I did see your support post and tried those settings but unfortunately didn't resolve my issue.

1 Like

We are very fortunate for the efforts that our active users make to share their own experiences, and to help others based on those experiences. Our staff chimes in here often for built-in software and hardware issues.

Most effective way to reach out to us for any hardware related issues, is to visit support.hubitat.com. There you can open warranty cases, as well as to seek help for any subscription related questions.


What happens if you go to http://your.hubs.ip.here:8081/ (diagnostic tool) and try downloading latest version from there instead of the main hub UI?

1 Like

I wasn't aware of that page but I clicked on 'download latest version' and it appears to be updating.

1 Like