Removing ghost devices

I have 16 ghost devices that I can not get removed. They have no name on the Z-wave details page, I push refresh and then the remove button pops I up. I push it a dozen times and nothing happens.

I had read that if the device is still powered on, it can get stuck. I took my hub to work, connected it to the network, and then logged into the hub. I ran a Z-wave repair and of course, everything failed. I went to the ghost devices, hit refresh, remove popped up, I pushed it, and nothing happened, I did it several times, and nothing.

I have heard that the hub deletes ghosts at night, these have been on here for over a year, it’s causing a regular repair to fail nodes that are good, and it’s causing slow downs in my system, I really need them gone.

I have a Z-stick, I tried to use it before, and it didn’t do anything, now I can’t remember how to use the software, and the version of the software that the instructions I have isn’t available anymore.

If you have the Z-stick, this has instructions on how to use the software:


That’s the instructions I had, the software from Simplicity looks nothing like that

Are you talking about the Simplicity Studio 5 stuff? That interface is TERRIBLE... can you post a screen cap?

Also look in the upper right hand part of the window.. click on "launcher" and that should show you the "# Tools" menu on the upper left... same row as launcher button/tab but on left.

Edit: I usually just have a shortcut that goes directly to the PC Controller sw here:

1 Like

That’s what I’ve got, what do I do after I hit launcher? I’m gonna drag my surface tablet, my $10 wifi router, my hub, and my Z-stick to work tomorrow and try this again if I can figure out the software.

I just did a refresh, holy crap everything is down, nothing can find it’s way back home.

Look again at the guide, and pay attention to step 2, which tells you how to download the Simplicity software and then use it to access the PC Controller app:

Once you are in the PC Controller app you can begin the process of removing ghosts w/your UZB stick,steps detailed in the remainder of the guide.

And note @erktrek's excellent advice (included in the guide in step 2 above, and noted by him here in this thread) to create a shortcut to launch the PC Controller app directly.


That’s what I needed, I couldn’t figure out how to get into the PC Controller.

I was able to remove all but 3 devices. That’s a good start. I think the switches I have left are on the circuit with all my internet equipment, so I can’t just kill the breaker. I’ll just haul this stuff to the office with me and do it there.


Glad to hear things are starting to ease up for you. For the switches that you can't kill a circuit, if they have an air gap you can pull that and that's the same thing as taking them off the circuit and then you can remove them.


Thanks for that tip, I’ll do that now


So I’m not having any luck with these last 3 ghosts. They are listed as “SPECIFIC_TYPE_POWER_SWITCH_BINARY” I am guessing these are light switches. I have all the breakers off in my house except for the ones I need to power my hub and my network equipment, I’ve pulled air gaps on all the switches that still have power, and unplugged all wall wort devices.

Now I get this message when I click “is failed” or “nop” like it’s not contacting the hub.

That is a new one to me. Taking a few other, smarter folks to see if they have any ideas.

@erktrek @csteele @jlv

I’m guessing the stick is able to communicate with the ghost still, might try wrapping the stick in aluminum foil to block the signal.


Yeah that sounds strange - maybe your air-gapped switch only cuts power to the load?? --> this is a silly thought apologies!!

I think @thebearmay's idea is worth a try.

I might click on the Pc Controller device, then in the bottom right frame click on "update" button to refresh the controller with the Hub info (Gateway).

Another thought would be to exclude the stick and reinclude it again for giggles. You do this by starting the "remove" process from the HE device page then in the PCS clicking on "Select Learn Mode" / NWE...

Yet another thought is to reboot your hub to clear out any cobwebs and maybe try another removal from there.. My usual would be to suggest the old power pull / wait but it seems like this might actually not be necessary according to staff member Bryan the resident Z-Wave expert and all around good doobie..

1 Like

Side question, I have never been able to get my Schlage FE599 to pair to HE, there has been a couple times we’re it starts to initialize, but it never finishes. Can I use the z-stick and the PC controller to bring it into HE? Will it still work after the z-stick is removed from the HE? I have my old ST hub still, and I have thought about pairing a couple repeaters and the lock to it, and bringing it in via Hubconnect, but I’d like to avoid that. Right now I’m using Hubconnect, but just so that I can use the device buttons on my Harmony remotes, which it looks like there is a way to do this in HE now, and to bring in my SmartDry so that I can run a webCoRE piston that marks my dryer as running, and the washer as empty. I have GE smart appliances, so I’m hoping that now that they have released an API, someone can create a way to bring that all into HE natively. Right now I have a power sensor to mark the washer as running, and a SmartDry to mark the dryer as running, and use a virtual switch linked to IFTTT then to the GE connect to mark them as done. The less platform hood I have to make, the better in my view. I had to switch my integration to Alexa, FrontPoint called me and said I had to stop using the HE smart app because it was against the TOS and was making to many calls to their server, and I use Alexa to activate my Ecovac vacuums.

Pairing it with the stick should work. You’ll have to pair S0 as it’s a perimeter device, but it should still work after removing the stick.

1 Like

I tried to use the community Harmony integration for device buttons a few weeks back, and it doesn't appear to be working anymore. I think it's more about something Harmony has disabled then there being a problem with the Harmony integration.

What do you mean by device buttons? i use it for the main activities and it is still.working fine ie turn on xxxx also pause xxx etc.

They have a version of the remote that has additional smart home device buttons at the very top that were added to allow controlling devices like hue lights which were supported by Harmony.

Or maybe likely you're aware of that and are asking something different?

Still working still working great for me! :sunglasses:

1 Like

Yeah, as I understood it works if already set up, but it would not setup for me when I tried a few weeks ago, repeatedly.

Have you tried to set it to from scratch reverently?