Removing a dead z-wave device?

I have a C4 running 2.2.4.158. On 12/16 I had some "filament" type LED bulbs fail in an odd way (one bulb had 3 of 4 filaments fail, the other died altogether) and took a GE Z-Wave Plus paddle switch with them.

The switch was completely dead and making a soft relay clicking sound every second or so. Pulling the air gap and cycling the breaker didn't bring it back to life or allow me to exclude it (I tried a half dozen times but the hub timed out every time). So I renamed the device, removed it from rules, maker app, dashboards, etc, and I replaced it with another switch.

I've seen a number of posts that indicate that the Z-Wave details page will eventually allow removing the dead device. Two weeks later, there's nothing on the Z-Wave details page that allows me to remove it which leads me to believe that this might not be an option with a C4 hub. Short of selecting "Remove Device" on the device details page, what's the best way to proceed?

Here's what I'm seeing on the z-wave and device detail pages:

So the switch itself is no longer powered and gone? If so shut down the hub from the menu. Unplug power to the hub for 5 mins.(unplug it at the wall not the hub itself) Power it back up, go to z-wave details and then remove it (might take a couple of clicks) Go in to your devices page and make sure it's gone. If not remove it from there too

1 Like

Thanks for the suggestion. Alas, no joy. I tried shutting down the hub and pulling power for 10 minutes twice. In neither case was there an option to delete the device on the Z-Wave details page.

The device has been removed but it would be trivial to wire it up to a line cord, put it in a plastic outlet box and plug it in (I already have a rig set up for such case). I'm not sure that'll do much for me though since the device seemed to be unreachable before I pulled it (Z-Wave exclude timed out every time I tried).

hit refresh a few times on the ghost
, the remove button should show up

I've had a situation while trying to pair a device that another already paired device pops up for inclusion instead. The problem is the device shows up with no label so if you add one and save it you overwrite the settings of the existing one. This has happened a couple of times in the past and generated much confusion.. The last time it happened to me the devices were different enough I could tell something was up...

One thing you could try is hit refresh on all the similar devices on the details page. If a "remove" button appears on any one of them that's probably your device.

Refreshed a dozen times. The only thing that happens is that the "Last Sent" time stamp is updated on the Z-Wave details page for the dead device. Other than that, nothing.

I only have 8 switches so it was easy enough to do this but still no remove button.

1 Like

Ah okay was just a thought. Can you cut the power to all the switches and see what happens? Also apologies for bringing this up over and over - have you considered using a secondary controller like a UZB-7 or Z-Stick+?

Even though it's not a "ghost" maybe more like a Zombie you still might be able to get rid of it that way. Also a secondary controller is handy for other things as well.

Also it would allow you to force remove from HE and then remove from the PC Controller Sw.

2 Likes

Thanks-- looks like that might be my only option at this point. Tagging @bobbyD in case support has any other ideas/options.

So oddly, I've had a second GE Z-Wave Plus paddle switch fail. What's odd about that you ask? The second failure happened at my primary residence located 600 miles away from the first failure. Like the first, it was also controlling outside lights. In this case, the LED bulbs being controlled were not the Feit filament type and the bulbs did not fail which is what I'm guessing caused the first switch failure. I think both switches were purchased around the same time so it's possible this was a batch related issue but who knows.

I'm also now reasonably sure that the "Remove" button on the Z-Wave details page doesn't exist on the C4 hub. The screen shots for the C7 Z-Wave details pages looks very different than that on my C4.

Anyway, does anyone have a recommendation on which Z-Wave stick I should buy?

This is the one I got from DigiKey, works well.

Silicon Labs UZB-7

2 Likes

The UZB-7 that @672southmain mentions is very good and very reasonably priced. Totally worth it.

The Z-Stick+ is good too but more expensive and is 500 series not 700 - its claim to fame is an internal battery that allows you to unplug it from the computer and get real close to things in order to exclude. My understanding is that it may even be able to include things (with no security) that way as well - Note: have not done this so ymmv.

I have and use both... For me the Z-Stick+ is preferred when working on my residential client's systems since I may end up running around the property without a laptop.. I always have both with me though.

2 Likes

I have both, too, for the exact same reasons you give.

2 Likes

There apparently were some (many?) bad switches due to capacitors dying. Like all devices of this era, tv's included, the caps are just not up to the task long term.

I have seen a YouTube video about this in the past, and there was even a recent (2-3 weeks ago?) post on Reddit that showed the whole repair process.

1 Like

Yeah doesn’t look like anyone made it clear during your previous messages, but as you figured out the C4 zwave page is much different than the C7. You won’t ever see the remove button that you see mentioned elsewhere, that is a C7 only feature.

1 Like

Thanks for the info everyone--much appreciated.

I assume it was this one? Posting here for posterity.

1 Like

Edit, yes that was the one.

Here is the Youtube video.

1 Like

Looks like the hardest part to the fix is un-soldering the 6 pin header. All in all though, well worth a try and it's likely I have the cap in my bin o' components.

1 Like

So I just had the same problem removing a dead inovelli switch from my C-7 and I figured it out.

I clicked "remove" and "yes I'm sure" from the device page for the dead switch. That leaves you with a popup telling you to "follow the mfg instructions for excluding it from a network" which only has a single "Cancel" button on it. While looking at this pop-up JUST WAIT. While that popup was up, I searched around, and ended up reading this thread. When I went back to the browser tab that had my HE device removal popup on it, it now had a new red button labeled "Force Remove". Click that. Job done.

2 Likes

After seeing this thread: FYI GE/Jasco upped warranty to 5 years I contacted Jasco and they sent me a couple of replacement switches. They didn't want the old one back so I replaced the 10uf capacitor referenced in the video and that did indeed fix the issue. Replacing the caps on two switches took approx 20 minutes total from start to finish. Unsoldering the 6 pin header was very easy. I had a knife tip for my solder iron that was big enough to touch all of the pins on the header which made separating the boards trivial. Well worth the effort.