[Released] Button Controller 3.0


#61

Indeed it did!


#62

Well, I'm stumped. I set it up exactly like yours:

Then I went into button 3 pushed and deleted the Off: Office action:

Then I hit Done with Actions for button 3 pushed:

So you can see that I am not able to replicate your failure. What build are you on? What browser are you using??

I'm wondering if this might be a browser issue. Please try this with a different browser. By "this", I mean add a second action to some button. Then delete it. Hit Done with actions to return to main page.


#63

Using Brave. I will re-do with Chrome.


#64

I was using Brave, so that's probably not the issue.


#65

Ha, Ha.
I just used chrome. Very interesting response.
It quickly flashed "Unexpected error" (or something like that - it was too fast to see!).
It then deleted the correct part of the action,and came back.
Please forgive me, I just don't understand what's going on....


#66

Did it delete the whole button section on the main page?


#67

Nope. Just the part that was selected.
Case closed?


#68

I'm not able to interpret this response.


#69

My apologies for not being specific enough.

The issue was that the Button Controller was having issues when deleting one condition out of a rule. Furthermore the issue was that under certain circumstances, entire button actions were deleted.
As I tried to describe, the response when using using chrome to do that (instead of Brave)::

  1. the browser flashed an error message very quickly, and then it disappeared
  2. it correctly deleted that part of the action which was selected
    So, in conclusion "it worked".
    I think that it certainly indicates that Brave doesn't always react like Chrome.

#70

Except that I couldn't get it to fail on Brave (on a Mac). Brave on Windows? It's a fairly bad bug.

What I meant earlier about the failure you saw not making sense is that there is no relationship in the code that would allow the one action (deleting an action on the Define Actions page) to have the observed affect (deleting an entire action section on the main page). Those two actions are on different pages, and there is no code for the outer page that would delete an action section based upon anything that happened in the inner page.


#71

One other idea, if you're willing to test for us. Go back to Brave and reproduce the circumstances. Disable plugins in Brave and see if it does the same thing.


#72

I just checked. I'm not using any plugins in Brave. That is, no extensions.


#73

I had a similar situation today. I used the 4 button Sylvania switch to control different outlets on a Zooz power strip. I had all 4 buttons programmed to toggle 1 of 4 outlets. I decided to change one button, which was set on a held to toggle 2 of the outlets. I deleted the action for that button, thinking I would be able to add a new action of turn on, but the button option completely went away, and would not let me pick held for that button. It seemed like BC still thought that the held function was tied to an action, but it was not shown in the list of programmed buttons, if that makes sense.

This was on a PC using Chrome.


#74

If you've read this thread, this is a real mystery. Any screenshots you can share? Can you reproduce this?


#75

I believe so... stay tuned... I am working to try and capture video of it all, so nothing is missed.


#76

Ah, I just figured it out. IT IS A BUG in BC!


#77

Squash it dead!


#78

Hard to find, easy fix. Next release.


#79

By the way, is there this same bug in Rule Machine ?


#80

I'm not sure if this is the same bug or something different. I go to BC, select New, give it a name, select any pico device and then select one of the prefill options. After that, if I select any button I get the following:

After I select ok, any Select Actions button will bring it back.