[RELEASE] WyzeHub - Wyze Device Integration (minimal cam support)

I just installed the Wyze App and Wyze Cam drivers. All devices are connected. I'm trying to turn on a light when motion is detected and can't find the correct device in Rules to do this. I've tried switches but nothing happens. Wyze cams don't show up in motion detectors or contact switches. Has anyone of you set this up?

1 Like

Hi Jake:
New to the group and Hubitat due to the WINK shut down. I have many wyze devices and would love to integrate them into HE.
I'm not at the point where I know how to add these files. I have cameras, switches, indoor and outdoor plugs, vacuum and LED and bulbs.
Richard

also sensors

Since no one chimed in with a solution, I figured I’d post what I came up with. I didn’t want to have to use a cloud based solution but I had no choice. I just made a virtual color temperature light button and connected 2 applets in IFTTT to turn the floodlight on/off. Since my Flood light is set to automatic inside of the Wyze app and will turn off after 3 minutes of PIR detection I also had to make a basic rule in Hubitat > (When Flood Light turns on and stays on for 3 minutes … Turn off Floodlight) or else the dashboard button will not stay in sync in certain conditions. Hope this helps someone until the floodlight is properly integrated.
**

2 Likes

There is a lot of discussion above about using these for motion detection.

For what its worth, after that post, I did discover an endpoint to pull events from the API.

I've been testing the setup for a bit and it seems to work ok. I am still polling for data so it is never real-time motion alerts, not close enough for things like security/lighting.

1 Like

Hi,

I'm trying to replace my finicky IFTTT applets that enable and disable motion detection for my Wyze cameras. In the Wyze app this corresponds to the toggle under Event recording/Record an event when camera/Detects motion.

There appears to be 3 issues that are preventing the migration:

  1. While the Set Motion Recording button yields the proper outcome from the Hubitat device page, issuing the setMotionRecording(true|false) from webCoRE appears to be a no-op: no impact on the device in Hubitat or the Wyze app and no logs for the device in Hubitat. These are the webCoRE logs:
+167ms	║║Executed physical command [Wyze - OfficePan].setMotionRecording(false) (114ms)
+168ms	║║Executed [Wyze - OfficePan].setMotionRecording (115ms)
  1. The setMotionNotification command in webCoRE doesn't accept parameters while it requires true or false from the device page.

  2. (minor) It looks like motion notification (Notifications in Wyze app) and motion recording (Event recording in Wyze app) are inverted in Hubitat.

When toggling it in the Wyze app, the outcome is as follows in the Hubitat device view (after hitting Refresh):

Wyze App Hubitat device current state
ON motion_notification : true; motion_recording : true
OFF motion_notification : false; motion_recording : true

I guess what you need to show what webcore displays for the device command in question in regards to options to the command.

You can turn on logging in the device for it to show what it is receiving.

I cannot seem to get this to work with IFTTT. On a "push" action things trigger as expected. But I cannot get motion trigger to work. This is Wyze doorbell - not a camera specifically.

Screen Shot 2022-08-07 at 10.24.35 AM

Interestingly - it works with cam v3 - but not doorbell.

In webCore, when adding the action if does not show parameters by default. But you can add a boolean parameter. Click the parameters button then select boolean.

Thanks for the suggestion. This did allow me to add the parameters in webCoRE.

Unfortunately, still no changes from the device side. Last recorded state change was triggered from IFTTT earlier in the day:

According to the logs, WyzeHub did receive both calls from webCoRE. Somehow, they had no visible effect:

^^^ bump. @anyone?

I only have one camera so don't have any experience with the doorbell to help. IFTTT works great to send motion alerts to a virtual switch in Hubitat for me with my one camera I have in my garage where it appears to be nearly instant. I would reach out to Wyze if IFTTT isn't working with the doorbell for motion, might be something they don't have support for.

So Wyze is going to force MFA on all accounts - will that break this integration?

1 Like

@jakelehner I suspect the same change needs to be made on lines 85, 86, and 87.

I am trying to authenticate with the wyzehub app and new to wyze devices. I have the devices linked to the wyze native app. Where do you find the authentication token, the screenshot shows manual entry?. Am I needing a wyze sense physical hub to connect to?

I was not able to get a Wyze Lamp Socket working without modifying the driver to send floodlight commands.

Within the driver the floodlight on/off control will control the lamp socket. So a smart home driver that controls the Wyze floodlight via the Cam V3 should control the lamp socket.

I modified this driver by changing the on() and off() methods to control the lamp socket and creating new commands for turning the camera on and off. After that I could connect it to Alexa as a normal switch through the normal Hubitat Alexa app. I now have normal Alexa voice control of the (dumb) bulb plugged into the Wyze Lamp Socket.

Modifications (replace old on() off() methods with these):

def on()
{
setFloodlightPowerstate(“true”)
}
def off()
{
setFloodlightPowerstate(“false”)
}

I cannot seem to get my Wyze Bulbs (color or white) to dim using these drivers. They'll dim fine if I use the wyze app and have the google app linked to use the my Wyze account instead of the Hubitat linked account.

I use google home mini to control my Wyze devices with my voice.

First, Thank you for the hard work this get this going.

I think an update may have broke the camera code? I was able to import the WyzeHub App with no problem but when I attempt to import and save the camera code (https://raw.githubusercontent.com/jakelehner/Hubitat/master/WyzeHub/drivers/wyzehub-ctbulb-driver.groovy) , I get the following:

If you read the error message (first line in the screenshot), you'll see you tried to paste the camera driver code into a new app window, not into a new driver window.

I strongly suggest install Hubitat Package Manager, and then use that to install this (and any other app/driver). It avoids this type of error and makes adding/updating custom code much trivial as clicking 'install'.

Thank you for your input John.

That's correct, I attempted to import using the App. It has New App on the upper left on my previous screen shot. I installed the Hubitat package manager and reboot my hub. I am getting the same error on line 73.

image


image

Download the Hubitat app