[RELEASE] Snapshot - Monitor devices and sensors - see status on dashboard, by notifications and speech


#41

The dashboard tile will not refresh until I turn off and ON the control switch every time. Even I checked the snapshot virtual device if it is getting the refreshed data without it, not until I turn ON/Off the control switch. I have setup the child app trigger frequency to every 2 minutes.
Is this supposed to work like this?


#42

Just took a quick look and think I found a typo. Download the latest version and try again. If it still doesn't work for you I'll need some screenshots on how you have this setup so I can reproduce it.

V1.0.9 - 04/10/19 - Fixed a typo in repeatSwitchHandler


#43

For Realtime: "Too many devices updating in real time WILL slow down and/or crash the hub"
How many are too many?
Perhaps an option to display every xx seconds instead of minutes would be nice.
(Realtime may be too fast but 1 minute is too slow).


#44

Too many variables. Everyone's system is different depending on what else is running on the hub. I have about 50 devices on real time without any problems but it could happen so that warning is there. All you can do is add your devices and see how it goes.

For now it is what it is.

thanks


#45

It works fine now. The tiles are getting refreshed without the control switch turned ON/OFF. Thanks!


#46

Exciting enhancements coming later tonight... :thinking::sunglasses::wink:

Be sure to have 'Follow Me' and 'What did I say' updated, if you use them.


#47

New version on Github...

V1.1.0 - 04/12/19 - Added voice and pushover notifications to Priority Devices

Receive priority device notifications on demand with both voice and pushover options. Great for checking the house before setting the alarm or going to bed.


#48

Thanks for the updates. It would be nice to monitor battery levels. A single tile that tells me if a device needs new batteries would be great.


#49

Device Watchdog will already do this. :grin:


#53

Hi @bptworld,

I have noticed lately that the tile does not refresh when devices are of type Temperature.

To explain:

  • I use your great app for two tiles, one for Contacts and one for Temperature.
  • I might be a version or two behind (not at home so I can not check exactly [and no, I have not yet installed your version checker app/tile. :slight_smile: ]).
  • Contact tile works great and keeps refreshing as we have doors/windows open this time of the year - finally spring!
  • I have the app set up as real time, have the 'show all option' and have 5 temp devices being watched.

However unless I toggle off/on the control virtual switch, the temps do not update. I have not watched it close enough to determine if it never updates after the initial from the virtual off/on, or if it only works for a day or an hour etc...but it definitely gets stuck.

Let me know if there are any logs you want to see and which those are, happy to work with you to make it better.

For now, I have dropped in a rule to toggle the switch off/on, once a day.

Cheers


#54

Thanks.

Definitely need to update, there has been a lot of changes in the last two versions. :grin:


#55

Updated to latest. I'll let you know if the thermo stops updating again.


#56

New version on Github...

V1.1.3 - 04/19/19 - Fixed a bug with Presence Sensors


#57

Loaded Snapshot with latest version and followed all instructions. Was at the point of adding a tile to a new dashboard I created called, guess what, Snapshot.
Selected the snapshot tile, then attribute, but no way to add 3rd option of say snapshotSwitch1-6 as an example.
So went back over everything to make sure I had selected the devices and when I went back to adding a tile in the new dashboard the device 'snapshot tile' was missing.
Not sure where to go from here. thanks


#58

Go to the virtual device you created and make sure there is data in there. It won't show up on a dashboard until there is data in the attributes.


#59

I see tons of stuff in the snapshot tile virtual device page. But snapshot tile still does not show as a device in the list.


#60

Alright, then the app is doing it's part. Now let's see how your trying to setup the dashboard.

  • Most common reason and not refreshing the dashboard. Get completely out of the dashboard (close your browser). Then open it back up and see if it's there.
  • if it's still not there, make sure you have added that device in the Dashboard Configuration page.

#61

I did not add it to the new snapshot dashboard as a device so now that I have I can see the snapshot tile device again! I am now able to create the tiles! Thanks a lot for your help! Rookie mistake!


#62

No problem, glad to hear it's working for you!


#63

How would I clear out all the extra information/reporting that is not valid (gives null results)