[RELEASE] OwnTracks for Hubitat Presence Detection

Don't disagree. I'll switch the log type.

1 Like

This error seems to be showing up.

Ahh ok, that's probably why it's not clearing as expected. Fixing this...

1 Like

Honestly, I don't know. The log entries have a ton of info on them and I'm not exactly sure what I'm looking at.

And since I'm they only one seeing this behavior, I'll just turn off notifications from the OT app and Resume the paused RM rules I was using before the functionality was added to the app. This appears to be an edge case on my end and I don't have a problem using RM for my notifications.

Can you grab the latest update? It should address that issue. @Jani as well as the issue with those maintenance boxes not clearing.

Not sure if this update was addressing this but the update did not fix the maintenance issue where selecting a family member to update. The selected family member stays selected even after hitting done and it's still not scheduling any region, location or display updates.


With the most recent version I am seeing this error every time I hit Done now.

It's the error you listed below that is stopping it from clearing. What do you have in the device prefix box:

I have never changed the prefix.

My devices were created long before the option to change them was added. Could that have something to do with it. A migration issue of sorts.

"Sort of". Some hub models don't save those settings until "done" is successful. So even though it's showing "OwnTracks - " it's actually not defined yet (it's just the default being loaded), causing it to throw that error. Give me a minute, and I'll fix it up.

Mine is a C5. Should I update to the most recent version of the HE firmware so that Java is updated? I usually hold off for awhile but if that will help you I can do that.

Ok, so there s something with the SW that does this. No need, it should handle this more graceful. I'll have a version in a second.

@oldcomputerwiz can you grab the latest version. 1.7.15 should fix that error.

Unfortunately it still isn't clearing the selection, or scheduling an update and getting the error in a different line.

Can't remember, have you tried starting over? Blow away things on your phone and on HE and re-set things up? Just seems like you have a gremlin in there that may not be killable expect via "extreme" measures... :slight_smile:

1 Like

I just pushed a new version that adds error protection on that name change which should unblock you.


It's a migration issue that appears to be handled differently on different hubs. That's why asked if updating the firmware to the newest version (because of Java) would help. I bet I could just go in and retype "Owntracks - " and it would fix it. I think he wants to fix the issue because it will surface again when someone who has been along for the entire ride has to reinstall the app on their phone.

Yes, the nuclear option would fix it but I really don't want to do that. I have a lot of options that I have tweaked.

1 Like

Nice of you to throw yourself under the bus for the greater good. :slight_smile:

Hopefull the newest version is the charm...


That fixed it. No errors and the update is scheduled. I am curious though is this a java issue. Would the firmware update make a difference?

1 Like