[RELEASE] OwnTracks for Hubitat Presence Detection

Yep. Latest update did some really bad things in a big picture. App is not working anymore.

1 Like

I'm finally getting the errors in my kids as well.

LOL - meant errors in my logs. :wink:

1 Like

Since latest Hubitat update I am receiving an error on the phone app(Android)
HTTP code 500:Unable to resolve host "cloud.hubitat.com". No address associated with hostname.

I can ping cloud.hubitat.com from the same wi-fi network as the phone is on and I can ping cloud.hubitat.com from the phone (using Fing App)

Also seeing this is the Hubitat log file

app:25252024-02-08 08:39:31.029errorjava.lang.StackOverflowError: null on line 1110 (method webhookEventHandler)

app:25252024-02-08 08:39:30.472infoOwnTracks: Requesting a high accuracy location update for Greg

app:25252024-02-08 08:39:30.469errorOwnTracks: updateDevicePresence: Exception for member: Greg java.lang.NullPointerException: Cannot invoke method toDouble() on null object

I tried a new install. I can't open it all all. I get in a loop with this screen.

Here is the log

BTW Previously I selected my name and clicked done many times and no device was ever created.

Thanks again for your help.

I think it's clear we need to hold off on updating for now... :slightly_smiling_face: @lpakula will sort it out.

Looking into this one still. Just need to figure out how to drop multiple pins on a google map.

1 Like

Can you pull the new version (1.7.13)? Missed an issue during the migration to the different recorder URL.


Anddddd.... we're back! It's working again. Thank you!!

1 Like

Thanks @lpakula. For some reason, my wife blames me for the location and related messages not working. I tried to explain that it wasn't me to blame, but she didn't believe me. :smiley:

1 Like

Sorry, totally missed that when blindly banging on the keyboard last night. :rofl:




FYI...updated but that did not solve the issue immediately.

I had to manually open owntracks app on my phone and hit arrow key. After that those red errors disappeared and now we are good to go. All phones reported same errors and arrow key needed to be pressed only in one of the phones.

after requesting high accuracy got this:

It seems that the dropdown menu where to choose high accuracy users doesn't reset anymore. If you choose user x and y and hit done. Then if you go back to owntracks app main view those devices are still in the menu. And same with the other menu in the maintenance section.

Well, YOU implemented home automation, so it's still YOUR fault, regardless! :rofl:


Everything was working until this morning's update. My wife left after the update and I have the following errors:

What do I need to do to fix this or will an update fix it...


As a FYI. My wife left the house and went to work. The system is not logging her as existing anywhere, even if I look on my phone, she does not show up...

She is using an iPhone if it matters...

Update it..

Hi Since the last update I'm getting new errors been running perfect up to now own track recorder stop updating...Update: went in to own tracker app checked tracker IP address saved and error stopped and updated for me, the wife is still 2 hrs. behind so far. both Samsung android phones.

1 Like

Not clear what you mean...you updated and things are fixed?

Do you mean you went into the Recorder setup screen below and then hit next and Done on the main screen of the OwnTracks app?

My errors are gone after updating to the .13 release. Thanks! :smiley:

1 Like

Yep that is what I ment to say. :slight_smile: Esanders said that things were not working after update from the morning. And lpakula had already Released fix for the issues.

1 Like