[RELEASE] OwnTracks for Hubitat Presence Detection

I thought someone else mentioned that they got the official Beta directly from the Play Store - not sure how you get the Play Store to offer that one instead though. That version would address your issues as well.

I've seen on other apps a "sign up for beta" button (or something like that).

They do currently have a beta option on the Owntracks app in the Android store.

Current play store beta version info:

Link: https://github.com/owntracks/android/releases/tag/v2.5.0/

Screenshot from Play store:

Not sure if companies can block signing up for Play store betas on phones that are locked down...

Yeah im able to install Beta but last time couple of weeks ago as I tried it.. It did not work at all. It threw a lot of errors to app log and I couldnt figure out what is the reason of the behavior. Also though that yep.. Its Beta so that could happen.

EDIT: decided to give it a new try. Installed beta..and it works. So I'm going to test now :slight_smile:
EDIT: I'm taking my words back. First of all I joined beta and waited while. When it says Beta after owntracks app name in play store I downloaded app and installed it. I though that was beta 2.5.0 but it wasn't. It was 2.4.something and the name was still owntracks beta. Now as I checked play store it said that there is an update for owntracks and the version is 2.50. Installed it and it still doesn't work. Same thing as last time.

App says "connecting" but nothing happens and nothing comes to hubitat log.

Ok so the problem with 2.5.0 is that it doesn't connect to hubitat when I'm at home. It updates location and manage to connect hubitat only when I'm away from home.
It doesn't matter if I'm disabling wlan so that setting doesn't f**k it up. Any idea what causes this?

One log line which I do not understand:
app:13842024-06-07 20:43:27.403warnADDED FOR TESTING THROUGH THE BROWSER LINK - not currently handled

Went another short trip away from home and location seems to update and log lines on hubitat side tells that too. Then when I arrive home there is absolutely nothing. It feels like cloud.hubitat is not reachable when I'm at home and using version 2.5.0. My daughters phone does the same with beta app.

Uninstalled owntrack on hubitat and thought that it could fix my issue but it didn't. I set all up once again but none of the phones are able to communicate with hubitat when using 2.5.0. Am I the only one?

I feel like I'm the king of the owntracks discussion. No one else is here. :smiley:
Anyways.. I decided to installa 2.5.2 to my kids phones and that version works. Only thing that I didnt yet get to work was map view with app. For some reason there is no map on the background at all but app now sends location information and it seems to work. So..version 2.5.0 beta does not work for our family so I suggest people to stick with official play store version or if possible.. install 2.5.2 which is unofficial and not play store version.
I need to downgrade back to official none beta version and maybe someday I¨m able to use newest version.

Ok so I just found out that if I leave owntracks beta program, uninstall owntracks app, wait until "beta" text disappears from the end of the app name on play store, then install owntracks again ->
I will still get version 2.5.0 for some reason but after installation connection to hubitat starts to work.

Weird as hell. Now I'm running 2.5.0 supposed-to-be-beta, kids are running 2.5.2 and my wife's phone needs to be fixed tomorrow. I will do same steps as I did for my phone. Leave beta, still install 2.5.0 and check if it works for the second time.

1 Like

If you are using the APK from post two then see the notes to make the map work:
This build does not contain a Google Maps API key, so the Google map will not display in the app. Click the layers button on the bottom right of the map screen, and select "OpenStreetMap". Once selected, it should retain that view after opening and closing the app.

1 Like

[owntracks/android] Pre-release v2.5.0-beta3 dropped an hour ago. I'm still running your forked version of beta 2 and it's been solid! Just came here to check if your forked version was still better since it included a few additional fixes. Or to see if you were going to release a forked beta3.

Side question, and maybe it's because I still have one phone running your old 2.4.17(?) fork (post 2 version.) But I am getting three Region entries on my hub. If I go in and delete them, they eventually return. I've tried deleting them off the hub only as well as off the hub and push to the phone. The only thing I haven't done yet is collect all the phones and delete them from there.

And to add to the confusion, I have a second hub that I send to. I've never had it query for regions and my local hub is getting regions from the remote hub. Maybe this is why there are three? Again, I've deleted on the hub(S), but they still return.

My guess is Beta1 (which was broken), Beta2 and Beta3 all show as "2.5.0". Probably wouldn't pull the latest until you removed or something?

1 Like

No need to update to this. I have most of those changes in the 2.5.2 version already.

Your region issue might be them coming back from the other hub.

Oh okay thanks for the information. It was a tuff night trying to figure out why I can't get owntracks to work.

Yeah it seems like this is the case. It is annoying as hell. I had no idea why it shouldn't work but later noticed that on owntracks github there was discussion about beta 1 which cannot create http-connection at all. Beta 2 fixed it I guess and I'm not sure if beta program shares older versions like beta 1 for the beta users. Makes it more difficult to test.

But yeah. Slept over night and 2.5.0 is still working for me. Version 2.5.2 is 50% working because noticed that my sons phone is still "pending" from last night. Have to check what's up with that.

Would be easier if they up-reved on each Beta (at least for troubleshooting).

Let me know what the deal is with 2.5.2. Unless it's in battery save mode or something like that, it should be calling home every 30 minutes by default.

2.5.2 seems to be rock solid. I found battery setting from one plus phone which was set wrong. Everything is now fully working. Im not seeing big difference between 2.5.0 and 2.5.2 but going to test more.

1 Like

Both should act about the same. Biggest change was from 2.5.0Beta1 to Beta2 which I forked from and then pulled in most of their updates.

One notable change is 2.5.2 will show others on the OwnTracks map, 2.5.0 currently does not.

Now it does. At least the 2.5.0 version that I have is showing all members.

Does it show thumbnails as well? Previously that wasn't working.

Nope. Thumbnails are not working.

1 Like

Thought so. I have a fix in there pipe for that, but not sure why they aren't just pulling it in. It used to work on 2.4.12, still works on the iOS, so my proposition to them was to add the fix to make it work like it did/does on the other versions. :man_shrugging:

Those running 2.5.2 have that fix in there.


Just had a weird issue today. One of our phones stopped reporting location to the Hubitat OwnTracks device at about 2PM (the other is working as normal) so my wife who is home was showing several miles away. The location settings etc on the phone (iPhone) remain as 'always allow'

I opened the device page on the hub and then opened the OwnTracks app on the phone. At that moment, the screen on the iPhone app started constantly refreshing as did the 'Current States' on the device page, while about a hundred events came through until it was up to date again.

Is there any reason the app should freeze like that? Thanks

Which version of the app are you using?