[RELEASE] Other Hub SmartThings Integration 2.0

community_driver
community_app

#182

Well, looks like there is still an issue. The app did create the devices and used the 'other hub button' driver...but there is no way to 'push' it. It just says pushed all the time.


#183

SmartThings and Hubitat have different implementations of buttons so this integration is not 2 way.

If you use the ST device in an automation and push the physical button it will/should trigger the automation in ST.


#184

Seeing this for a device that was linked and working previously. When I try to turn it off in ST, I get this:

app:22018-10-27 12:13:52.063:debugDevice '1' Not Found

app:22018-10-27 12:13:51.772:debugapi_action()

Device type is "Other Hub Switch" It's a light.


#185

I can't reproduce the problem... Did you recently update Other Hub or are you still on an older version?

What is the device network id for the device in Hubitat and SmartThings?


#186

Well, as I said earlier...it's a virtual button so there is nothing to physically press. The only thing I do with Other Hub and ST is tie the devices into Google Home. Google isn't seeing any of the new Buttons. So no way of telling Google to push them.

Oh well, looks like I need to find another way to get them into Google Home. I'll figure something out. :slightly_smiling_face:

As always, thank you for your time and a great app!


#187

Latest versions.

HE: 1/2
ST: XX-Device1/2

It's a HUE bulb.


#188

I don't believe Google Home Supports buttons so even if I did implement button as 2-way I'm pretty sure it wouldn't work.

Just use virtual switches instead...

Or use the official Hubitat ST integration since that's meant to be used from SmartThings to Hubitat...


#189

@krlaframboise is there any support for a RGBW device on Other Hub? I have a app on ST that does not work correctly over here yet because SONOS isn't fully integrated yet so i'm still using it over there but it also used coloured lights.


#190

No, just dimmable switch.


#191

I'm having an issue with an Ecolink PIR Motion Sensor, Zwave Plus. On HE it correctly shows as a generic Zwave motion sensor. In ST it shows as an unuseble to me, "Other Hub Device". Any quick way to change this to a Motion Sensor?


#192

Change the Device Type in ST on the Smartthings portal to "Other Hub Motion Sensor" [wording may be slightly different; can't recall exactly]

J


#193

Thanks, that fixed it :grinning: I hope it sticks.

Weird, I tried doing exactly what you suggested before posting, but it kept stating the device was being used by another device and refused to change it. Welcome to my ST exit.

For the record it took me almost an hour to Exclude the device after removing it from ST, including a call to Ecolink support. The ST exclude failed to exclude it. Finally, the HE exclude and a battery remove and reinstall excluded it. Then it took a lot of battery pulls and pushing the factory reset thing with a pin, until it paired. This device was a true PITA, but now it's done.


#194

WTF! Checking the device list I found this device installed and working in ST, and also paired with HE. I thought this was impossible.

Ok Sanity partially restored, refreshed the ST phone app My Home Things list and it's gone


#195

Do I need to install all the DH even if I don't use or have all of these devices? Or do I just need to install what I need?


#196

Just install the ones you need.


#197

Is this just for seeing devices from Hubitat in ST or does it go both ways? You would be able to see ST devices in Hubitat?


#198

This allows Hubitat Devices to be created as virtual SmartThings devices. The communications are two-way, thereby allowing changes to the ST Virtual devices to actually cause the Hubitat physical devices to be changed.

This integration does not allow for ST Physical devices to show up in Hubitat. To do that, use Hubitat’s built-in software and custom ST app to do that. But, that communication is one way, from ST to Hubitat.


#199

OK, I am trying to figure out a way to have my iphone presence sensors show up in hubitat so I can use them in webcore pistons. I am currently trying to migrate to hubitat from ST but there are some things that have to stay in ST at the moment because hubitat can do it yet.


#200

Here you go!


#201

Thanks, I just found this also!