[RELEASE] Inovelli Device Drivers

You don't. :slight_smile: It's built in to Hubitat (unless, I guess, you are running a super-early 1.x hub firmware version for some reason). If you're following earlier versions of Inovelli's installation instructions, they used to require a custom Inovelli child driver but recently switched over to using Hubitat's instead to make this easier.

ok, thats fine.. then after i paired and set it to this driver... no children showed up
what makes them show up :slight_smile:

thats not going to work... its a different name and namespace...

Which child devices? If you want the notification child devices then you need to set the 4 settings for each notification in the preferences. If you want the child devices that allow you to set the default level or enable / disable local protection from various apps you need to click on the sliders in the preferences section. Of course, after changing the settings, you need to click on "Save Preferences".


thanks Ericm!
and great product!


1 Like

Can you guys add StartLevelChange() and StopLevelChange() to the LZW31-SN dimmer driver? I have a 3-way (using a LZW30-SN and LZW31-SN) and would love to be able to dim from the LZW30-SN using a "held" command.


Edit: Nevermind... I just looked at the latest driver and it appears you already have it added. I'm on an older modified driver. Would update to yours. Thanks!

I noticed an issue with the StartLevelChange() and StopLevelChange() commands. If the "minimum level" or "maximum level" has been changed, these commands would only dim the light down to that level instead of 1 and 99 respectively.

As an example, I have my "minimum level" set to 30 because my bulbs turn off below 30. When I dim from the switch, it works great and 30 is remapped to 1 (so the LED indicator is all the way down). When I "set level" from the app to 1, it dims all the way down without turning the bulb off. However, when I do a startLevelChange(down) from the app, it only dims down to the new 30 level (maybe original 50 level) so the bulb is nowhere near dimmed.

Hope it makes sense. Thanks

So when you change the minimum or maximum level the firmware adjusts range of the attached load internally. So if you set the minimum to 30 then the 30% becomes the new 1%. If you set the maximum to 90 then 90% is the new 99%. So the dimmer always has 1-99% available as per Z-Wave specification. An equation like this is used:

value/100 = x/(max-min) then add minimum level to the results.

So if my min is set to 30 and my max is set to 90 and I send a BasicSet(44) to the dimmer:

44/100 = x/(90-30) or 44/100 = x/60. Then x = 26 + 30 (minimum) = 56. So we tell the dimmer to dim to 44 and it responds that it is at level 44, but internally the actual level is 56.

Probably more information than what you were asking for, but in my testing of using start level up & down both the bulb and the LED bar honor what I have described above. So there must be something different in our configurations if you are seeing something different. Can you maybe explain a little more?

1 Like

Thanks @ericm. I actually understand that. BTW, my username is gbenrus25 on the inovelli site...

So I set the minimum to 30 and left the maximum at 99. As you said, the old 30% becomes the new 1%.

The issue I have is when I use start level down, the bulb stops dimming down at the new 30% (internally, that's 30 + [30/100'*[99-30]] = 51) instead of the new 1%. I can manually dim further down all the way to 1%.

Is there anything else you can think of that might be preventing start level down from respecting the dimming all the way down to the new 1%?

Also, I should note that I've updated my dimmers to the beta firmware. Think there might be a bug there that might be preventing it from dimming all the way down? Can you please try it on yours using the beta firmware?

I'm testing on a dimmer that is running the original firmware so let me update the firmware and test it again.

1 Like

Ok, so that does look like a bug that is in firmware 1.41. It isn't in 1.43, but I haven't posted yet about that firmware release because I haven't tested it fully yet. I'll try to post it in the Inovelli forums either tonight or tomorrow.

1 Like

Nice! Thanks sir

No problem. Here you go:

1 Like

Nice thanks! Updated the 1st switch and startLevelChange now works great. Appreciated!

1 Like

What is the difference between these two settings in the Inovelli device settings?


I believe the 2nd pic showing the selection option toggle creates a child device so you can enable and disable the function in RuleMachine.

1 Like

Yep, @daweeze is right. The latest driver has a better label for that setting:



After the latest Hubitat update my NZW37 stopped updating it's state. I had to change line 186 of the driver from hubitat.zwave.commands.multichannelv3 to hubitat.zwave.commands.multichannelv4 to get it working again. Just FYI if anyone else is having the same problem.