[RELEASE] Hubitat Package Manager (HPM) -- HubitatCommunity

Never the less, it has been released and my tests show it as fixed.

Screen Shot 2022-07-12 at 5.55.26 AM

Screen Shot 2022-07-12 at 5.55.02 AM


The announcement gets sent out using a staggered approach - everyone will not get the announcement at the same time. (Thus the reason I have a check for it in Hub Information.)


Oh I get that. But I also got the impression from the wink emoji that it was felt that I should have known the update was available when it had not been broadcast to me yet......

I am subscribed to the Hub Release forums. But, I had not gotten that notification either.

12 posts were split to a new topic: Missing Community Notifications

Knowing Bryan, I think it's more likely it was intended to be an "Ask and ye shall receive!" wink. He's not a snarky guy. Sometimes we hit the limits of emoticons... :slight_smile:


I installed v1.8.7 (current latest release that I found), but it kept giving me an error that my user name and password were incorrect from the Hub Security credentials (problem existed whether I checked Hub Security, in this app, or not). I had confirmed my Hub Security user name and password as directed at Hub Login Security - Hubitat Documentation

I had to reinstall the HPM app, but using v.1.8.3 for this app to work.

Sorry am new to HE. What am I doing wrong?

EDIT: I think I may have discovered the issue (?). I was using a possible forked update on Github that was not the most current official update. As far as I can tell (now), v1.8.3 is the most current working update. Right?

No, v1.8.7 is the new fork, which most people would recommended now (the original developer has left the platform, and 1.8.3 was the last release by him). Do you see any errors in Logs when this problem happens? Do you have hub security enabled? If so, it's possible something went wrong between now and then and hasn't been discovered yet. I suspect many users do not have it enabled. Otherwise, the setting in HPM needs to match whatever is configured in the hub (including being disabled if it is disabled).


If you simply Repair HPM:

Screen Shot 2022-07-17 at 12.19.36 PM

You'll transfer yourself to the correct fork.

There's a chance that a repair of itself can interfere with itself. It will hang and you'd think it didn't work... it did. The new code is found and installed and it's only the display of "succeeded" that gets lost. Just use the App menu on the left and go back into HPM. You'll quickly see that you're on v1.8.7 because of the upper right corner:

Screen Shot 2022-07-17 at 12.23.49 PM

I just did this entire recipe... I have a hub that does not have/use HPM and I installed it from the original github repo. v1.8.3. I did the match ups, I did an update pass, and so on. Then I did a Repair of HPM and am on v1.8.7 now. :slight_smile: Easy Peasy Lemon Squeezy


Done and fixed. Thank you both for your help.

Hi there!
I updgraded HPM today to 1.8.7. I've removed the older version, removed deprecated apps/drivers.
After matching everything, I've tried installing, repairing, and updating various packages and each time HPM hangs. I've waited up to 20-30 minutes, which never took so long before. So I'm not sure it's actually connecting to anything to be able to install/repair/update. (And I don't have Hubitat Security enabled.)

Any tips for troubleshooting?
Hub version

Logs please.

Didn't look at my log OR this thread before upgrading :scream: :sob: The upgrade from 1.8.2 froze and (not paying attention) I either refreshed the page or clicked on Apps --> HPM then re-ran the HPM update. The second one completed but now HPM shows 2 installed instances. Tried repair on both (no change) and uninstall on either one gets this error:

Error Occurred During Installation
An error occurred while installing the package: Failed to uninstall app https://raw.githubusercontent.com/HubitatCommunity/hubitatpackagemanager/main/apps/Package_Manager.groovy, it may be in use. Please delete all instances of this app before uninstalling the package..

Sooo, before I mess things up further, any ideas for cleaning up my mess? Should I try deleting the HPM app?

Do an Unmatch on the oldest instance and you should be good.

1 Like

Or, follow along with the step-by-step that walks you through the same...

1 Like

Once I figured out how to find the Package Manager Settings button, it worked like a charm. I posted a tweak to the instructions in that thread. Thanks!

1 Like

I'm quite confused on the steps to replace 1.8.3 (Dominic's version?) to 1.8.7 (@csteele 's version).

There is no "update" showing, so is it just a matter of replacing the HPM code in the original install with the code in the link above?

The simplest path is to open HPM, click Repair, find HPM in the list and click Next.

  • Screen Shot 2022-07-25 at 2.57.31 PM
  • Screen Shot 2022-07-25 at 2.57.50 PM
  • Screen Shot 2022-07-25 at 2.58.26 PM

The latest code is downloaded into the Apps Code area. Since HPM is running at that moment, there's a rare chance that swapping the code out can cause a fault with the display of the "success" message. Imagine the code is at Line XX and then the code gets swapped. Instead of running line XX+1, it's running YY. It doesn't damage anything, it just gives a log message and sometimes, appears to hang. (No "Success" message.)

Click on Apps in the Left Menu and start HPM again.. check the running version shown in the upper left corner:
Screen Shot 2022-07-25 at 2.58.48 PM

An Update from 1.8.3 to 1.8.7 often has another cosmetic issue where two instances are shown. v1.8.7 has a new feature called UnMatch that, along with its other uses, also clears the two instances display.

Thanks - it took 2 tries like you said. The first attempt gave the following error and it never got to the "success" part.

Date/Time: 2022-07-25 19:21:41.116
Message: java.lang.NoClassDefFoundError: user_app_dcm_hpm_Hubitat_Package_Manager_58$_copyInstalledItemsToNewManifest_closure87 on line 3573 (method performRepair)

I then followed @thebearmay 's suggestion earlier on in the thread and did the repair again. It finished and the code is v1.8.7

Would this be in the Apps section? I'm not seeing a duplicate either there or in Apps Code section, so :crossed_fingers:

Thanks for your help

Click View Apps and Drivers at the bottom of HPM's menu. You might see:

Screen Shot 2022-06-12 at 7.46.42 AM

And now you have the method to fix it. :smiley:


Thanks - only seeing one listed!