[RELEASE] Hubitat Package Manager (HPM) -- HubitatCommunity

I believe that I'm doing everything correctly. Here are some screen shots.

Trying to update and getting an error:

Do a repair on it instead and you should be good from that point forward.

Hmmmm it shows up twice on the repair list.

Pick the first one, do a repair; then go to Options and unmatch one of them.


This link is up a few dozen messages, so it might be helpful again, days later...

1 Like

This worked but to clarify

  1. Repair the first Hubitat Entry in the drop down
  2. Once completed, go to Package Manager Settings
  3. At the bottom, click on Remove a Matched Package

I had to click around to get the exact steps above, this removed the entry for v1.8.4 while keeping my v1.8.7

Removed Rachio from HE to use on a different HE controller.
and HPM now gives errors.

Unable to update or repair HPM
What are the steps to repair?
Should I remove HPM?
HPM says update available.


What versions, please??
What version of HPM are you using and what version of the platform?

Hum, only get "Unexpected Error" and if Click on Logs get this.
No info about version?

The hub is clearly saying it is unable to reach the Master repo.

Try browsing to it...


Just click on the above and the Repo will be shown. It's not missing :smiley:

It's even telling you why.. "Temporary failure in Name Resolution." It means that the hub can't even find the IP Address for "raw.githubusercontent.com" It's not that the repo can't be reached, it's all of github your hub is saying it can't reach, because DNS is not working for it, at that moment.

If you click on the above and get the Master Repo displayed, then DNS is working at your home, just not for the hub. If you click above and don't get the Master Repo either, then you have a larger problem. :slight_smile:

I will say that for 3-5 days about 10 days ago I also had a house wide DNS problem. I don't know what was up with DNS out on the internet, but it was exceptionally flakey. I don't know where you reside, but perhaps it's regional and while it's working here right now for me, maybe for your region, it's not.

Yesterday I noticed the following strange behavior of HPM.
HPM states "Update available" but if I want to update the relevant app I only get a "null" stated.

Log file doesn't show any errors and I can figure out the app which will be updated.
Screen shot below from one line item but not sure if this helps

Had the same situation yesterday with different apps and tried a repair and got rid of the "null" statements but currently it seems to be back with each new update.

HPM version 1.8.7
Hubitat version

Any ideas?
Please help, thanks!

Same problem with my setup, noticed it yesterday too.

A workaround for HPM is to close the dropdown menu and the open it again. Driver/app name should appear on the second try.


Thanks, you are right, workaround worked for me too. Never tried to close and open the dropdown menu again

1 Like

Hubitat was able to replicate and will release a fix for this. It exists in only, as far as I can tell. I rolled back to .134 and didn't see it.

v2.3.2.136 fixes the display issue.


Hubitat V
Can ping from router
Cannot ping from Hubitat ?
Did reach MaterRepo ok

Still working on the issue . May just wait for fixe to 135 then see if I can update Hubitat
May not be able then either? Hubitat check for update just spins and spins

I had changed the HE from DHCP to Static. Used the DHCP address for Static to match CSS coding I put into HE.
Turns out that goofed up DNS?
I could ping from Router but not from HE.
Reverted back to DHCP. When checking network settings all seemed well.
But the HE then could not Ping
When checking my router, the router said the HE was still Static! but was set to DHCP in HE.
Removed power from HE, restarted Router, Powered on HE then network settings set HE to DHCP again, Aha finally got a check mark in HE network settings that DHCP was set.
Power cycled HE one more time, Router now said HE was DHCP.
HPM is on 1.8.6 and is asking for an update to 1.8.7 and is working ok! with HE set to DHCP.
Will in a few days try to get HE to a Static IP.
Got me HE Network test still can not ping but HPM is working ok.

The problem I was having post 200

Removed Rachio from HE to use on a different HE controller.
and HPM now gives errors.

Unable to update or repair HPM
What are the steps to repair?
Should I remove HPM?
HPM says update available.

If hub is running 2.3.2, try using multiple DNS servers in format below. One of them got to work...,,,,


Yes, works sorry didn't mention that.

For some reason seems to be unreachable from the hub I have noticed this in a couple of threads recently. If I try to ping it also fails from the hub. I have seen it reported elsewhere as well. Not sure why?