[RELEASE] Hub Watchdog - Simple way to monitor if your hub is slowing down or not

im having trouble with the hub watchdog reporting child..
see the screnshots the virtual device is still being tested every hour and the landing page on the reporting device shows that..

But in the details it is not showing any data since 12:59

any ideas

I'm seeing something strange on my reports the last two runs on virtual (left) where 30sec apart but showing like 30min apart

Re run with logs.on


see differnce between lastupdated / list1 and datapoint1

Yup, that's the way it's always been. datapoints1 is one reading behind. Never been an issue. :man_shrugging:

1 Like

ok changed the attribute to list1 and its there but the font size control dsont effect list1 only datapoints, thats why i used that as the attribute on the tile

List1 is not meant to be used anywhere, it's just a placeholder.

this is whats confusing me, list1 IS being updated where as datapoints1 is always 1 event behind, so shouldnt the list/data your using in the tile be current


@bptworld, I'm not getting only warning messages but if I turn on the "Sometimes you may want ALL..." switch then I do get all. Bug? I just checked and I am running the latest version.

thanks, I'll add it to the list

Am I the only one experiencing this?

Ever since the number of data points were dropped from 80 to 40, the report only shows 19 data points for me. Did I miss a setting?

Edit: I use HPM, so I'm always on the latest Parent and Child apps.

1 Like

I added it to the list, will take a look

Same here

A few things.

I'm having troubles when I point to a switch to pause the app. It seems that it wants to claim the app is "paused" regardless of the on/off position on the switch.

I guess I don't know what the "Examiner" child does--I can't figure out how to make it do anything. I created three Hub Watchdog children to test 2 zwave devices and a virtual one.

I listed those in the 3 slots in the Examiner. When I run a raw report, I get an error.

The "paused or disabled" was there because I pointed that child to a switch--it goes away when I uncheck the link to the virtual switch I used to pause it.

[Update] It seemed to start showing stuff sometime after I created the 3rd device. It doesn't seem to work with only 2.

Now, I'm seeing this odd error:

The latest one seems to be related to my having clicked on one of the buttons in the driver to clear/set values (it put a "null" in the datapoint1 list).

New version on GitHub...


I now see the 40 data points, only issue is that the latest reading is not on the list. The first on the list is always the one before the last.

I'm trying to understand this report.

Why does it state Maximum Delay: 0.322? Based on the raw data listed, it seems to me the maximum delay is 0.246.

These values are fractions of a second, correct?

What does "null" indicate?

I do see 40 data points now. Thanks for the update. Concur with @MrPancake doesn't show the latest value

I run it every hour, its 21:54 now, doesn't show the 21:20 value. On the Examiner child app, it does show the 21:20 value.

Not sure, if it still is off, show me 'list1' from the data device. Also show what it should be from the report.

The numbers are just a representation of time, something you can track.

You need to setup the 'type' in each data device.

Already talked about this one many times. Not a big deal.

1 Like

There is a bug in the hub watchdog code.. I am trying to use a switch for double duty it is used to turn on a night light at night and off in the morning so I added the times for maint. mode. but it is not enforcing it.. Whenever the switch is turned on during the maint. times. the test to turn off fires and turns it off.

See the logs..