[RELEASE] Homebridge Hubitat v2.0

Does anyone here know how to specify a glass break device?
Is it applicable to HomeKit, and if so, under what category do we put it in Homebridge v2?

I have a samsung multisensor which has vibration but in HK it's a motion sensor.

Just Got an Aqara zigbee smoke detector, got it connected to Homebridge via zigbee2mqtt as there is no driver for it yet, but its not showing in the Homebridge hubitat V2 app, any idea how can I add it to HE or force it to show on the app?!!

The Homebridge app only exposes HE devices to HomeBridge as far as I know not the other way around..

Did you pair the smoke detector with HE and try these drivers maybe?

Otherwise you could install Node-RED and use the Homebridge nodes and a virtual HE device OR HomeAssistant with HomeAssistant bridge. Either way a bit more circuitous than you'd likely want to go with.. unless using HA/NR with other stuff as well.

Note: you could use HA and install the Zigbee2MQTT addon eliminating an extra layer potentially.

1 Like

All you need it to do is tell you there’s smoke or there isn’t smoke right? You can just map Hubitat virtual switches to Homebridge, then create Homebridge automations the close the virtual switches when there is Smoke.

If you want to have smoke detectors in HE to use with HSM, it’s very easy to create a driver that is both a switch and a smoke detector.

Alternatively, I believe there is a more current HE driver for Aqara smoke detectors. This one was created to work with an Aqara natural gas detector and I used it successfully for many years. It was coded to also work with the smoke detectors. But it’s old and I don’t know if it’s able to run without errors anymore. I no longer have natural gas lines in my home.

Thanks for your reply, already tried Markus driver but didn’t work, I got the latest smoke detector (2022 model) and I guess the driver is not compatible,
The smoke detector is already connected to Homebridge.

1 Like

Thank you for your reply, already tried this driver as well as Markus driver, both didn’t work,
I live in the middle east, which is too hot during the summer, recently we had a couple of AC smoke at night with the neighborhood, the smoke detectors I got are interconnected, so the idea is, whenever smoke is detected at any detector all the detectors will go off (to wake everyone) and turns on all the lights, so I guess will try the virtual switch.
*sorry for the long reply.

1 Like

As an alternative there are devices that listen for alarms...

1 Like

thank you @erktrek, as i already connected the smoke detector to zigbee2mqtt, then to Home kit via HB, I set an automation to within HK, its not what I was hoping for, but its working for now.

1 Like

I'm getting an error when I try to control the color or brightness of my outdoor Philips hue light. it Works flawlessly if I control it from device page in Hubitat. I get this error when controlled from HomeKit. I'm pretty positive I could control color and dim level before not sure when I started getting this error I don't really change the color of this light to often. I've tried using other drivers but still doesn't work correctly. Been using the advanced zigbee rgbw bulb driver since it was first available.
2022-10-04 11:51:34.331 PMerrororg.codehaus.groovy.runtime.metaclass.MethodSelectionException: Could not find which method setLevel() to invoke from this list: public java.util.List advancedZigbeeRGBWbulb#setLevel(java.lang.Object) public java.util.List advancedZigbeeRGBWbulb#setLevel(java.lang.Object, java.lang.Object) (method setLevel)

1 Like

I’ve seen this error for a long time, and it happens with the Advanced, Generic, and Group drivers intermittently only when controlling them from Homekit. It only happens with one group of 6 lights in my daughter’s room. It’s not consistent for me and I’m not sure what causes it because I’ve been unable to reproduce it consistently. I’m able to control the lights from Homekit and Hubitat without any noticeable issues.

1 Like

I'm thinking this error I'm getting isn't a homebridge thing. I have full control over the light when using the Hubitat hub that this device is connected to. But if I try to control colors through my other hub that the light is hub meshed to I get the same error as if I was using Homebrige.
2022-10-06 07:29:56.732 PMerrororg.codehaus.groovy.runtime.metaclass.MethodSelectionException: Could not find which method setColorTemperature() to invoke from this list: public java.util.List advancedZigbeeRGBWbulb#setColorTemperature(java.lang.Object) public java.util.List advancedZigbeeRGBWbulb#setColorTemperature(java.lang.Object, java.lang.Object) public java.util.List advancedZigbeeRGBWbulb#setColorTemperature(java.lang.Object, java.lang.Object, java.lang.Object) (method setColorTemperature)

I’ll have to try that in the morning. That could be it with mine as well.

I've noticed these type of errors with a few other rgb bulbs as well. Just really weird that I only get this error when using a hub meshed or homebrige with rgb bulbs. Can turn them on and off but no color changing if I'm using HomeKit or Hub mesh to control. Maybe the latest updates changed something. I'm also having trouble changing colors of some other rgb bulbs that aren't meshed that I know for sure use to work perfectly.

I can’t get it to not work using Homekit or a meshed rgbw light. Color and level changes seem to be working and I can’t get the error to show up now. Maybe try hitting “configure” on the driver page.

Sorry, it took me so long to actually work on this damn app but I fixed the HSM alarm trigger errors under Homebridge. It should now function like it's suppose to now :slight_smile:

9 Likes

Having issues since updating. Basically, when using my laptop I can go into homebridge and see all my Hubitat accessories, even operate them from there. But my app on my phone and my home can not see my accessories and just shows as no response, so I’m pretty confused as to where the disconnect may be. Any help would be greatly appreciated!

That sounds like a Homekit/Homebridge issue personally, as I've seen that as well sometimes but not exclusive to Hubitat. I'd suggest restarting your Homebridge server and your iPhone to see if that clears it up. I've noticed sometimes coming on and off wifi (local lan) on my iphone can put me in this state.

It HAS to be something along there, just can’t figure out why. I’ve restarted my server several times, hard reset it, reset my phone, and reset Hubitat and none seems to get it to come up. Like I said, my laptop is on Wi-Fi and can see all my devices and even operate them from the web interface, but voice commands to HomePods tell me the device has no response and trying to use my app on my iPhone 13 shows 41 items as no response. Something is preventing my HomeKit from interacting with HomeBridge, I just can’t figure out what it may be. Bond, Ikea, and Philips Hue devices all work fine

What are you using to run Homebridge on?

Download the Hubitat app