[RELEASE] Homebridge Hubitat v2.0

@tonesto7 Thanks. I just tried and it works with my phone. It may be that I hadn't updated at the time of my post. However I've just tried with my Apple Watch and it's not resolved there - I'm currently up to date on watchOS 8.5.1. A bit strange that they haven't quashed the bug there also.

1 Like

Hi there! I bought a Minoston Z-Wave Plug Dimmer Smart Plug-in Outlet on Amazon, and it shows up in Hunitat as a dimmer. But when I use this plugin to bring it into Homebridge, It only appears as a power switch ....NOT a dimmer.

What can I update and where so it appears in Homebridge (and then Home) as a proper dimmer?

Thx

....and by Hunitat I mean Hubitat.

Sorry about that.

@user708 go into the app on Hubitat and go down to "View Device Debug Data". Find your device in there and select it to reveal the debugging. Post the results. This will point us in the right direction.

1 Like

Thanks @jtp10181 - here ya go:

{
    "name": "New Deck Dimmer",
    "basename": "Minoston Mini Plug Dimmer",
    "deviceid": "98",
    "status": "ACTIVE",
    "manufacturer": "Unknown",
    "model": "Minoston Mini Plug Dimmer",
    "deviceNetworkId": "11",
    "lastActivity": "2022-04-11T13:52:51+0000",
    "capabilities": [
        "Actuator",
        "ChangeLevel",
        "Configuration",
        "Refresh",
        "Switch",
        "SwitchLevel",
        "TemperatureMeasurement"
    ],
    "capabilities_processed": {
        "Actuator": 1,
        "Refresh": 1,
        "Switch": 1,
        "SwitchLevel": 1,
        "TemperatureMeasurement": 1
    },
    "capabilities_filtered": [
        
    ],
    "commands": [
        "configure",
        "off",
        "on",
        "refresh",
        "setLevel",
        "startLevelChange",
        "stopLevelChange"
    ],
    "commands_processed": {
        "off": 1,
        "on": 1,
        "setLevel": 1
    },
    "customflags": {
        
    },
    "attributes": {
        "level": 99,
        "switch": "on",
        "temperature": null
    },
    "attributes_processed": {
        "level": 99,
        "switch": "on",
        "temperature": null
    },
    "eventHistory": [
        "2022-04-11 06:52:51.83 | [level] | (99)",
        "2022-04-11 06:52:51.141 | [switch] | (on)",
        "2022-04-11 06:52:51.139 | [level] | (31)",
        "2022-04-10 20:37:55.243 | [switch] | (off)",
        "2022-04-10 20:37:55.241 | [level] | (0)",
        "2022-04-10 20:37:54.495 | [level] | (70)",
        "2022-04-10 20:37:51.686 | [level] | (99)",
        "2022-04-10 20:37:50.935 | [switch] | (on)",
        "2022-04-10 20:37:50.932 | [level] | (30)",
        "2022-04-10 20:36:46.025 | [switch] | (off)",
        "2022-04-10 20:36:46.023 | [level] | (0)",
        "2022-04-10 20:36:45.286 | [level] | (69)",
        "2022-04-10 20:36:44.318 | [switch] | (on)",
        "2022-04-10 20:36:44.315 | [level] | (31)",
        "2022-04-10 20:10:12.073 | [switch] | (off)",
        "2022-04-10 20:10:12.071 | [level] | (0)",
        "2022-04-10 20:10:11.326 | [level] | (70)",
        "2022-04-10 20:10:02.579 | [switch] | (on)",
        "2022-04-10 16:20:09.407 | [switch] | (off)"
    ]
}```

In the Hubitat homebridge app, do you have this selected as a Light or an Outlet? Cannot tell from the debug info.

Couple of things to check, in the Homekit app (on your phone), long press the device to get it full screen and swipe down to the settings. Check "Display As", possibly due to the "Plug" in the name it set it as an outlet by default, and you may need to change that to "Light" to allow dimming.

If that is not working, you could also try removing the device from the homebridge app, rename it in Hubitat to NOT include Plug in the name, and then add it back to Homebridge (as a light). Then again check its Display As setting to make sure it is set to Light.

Thats the only things I can think of, the debug info looks correct, it has the capabilities for a dimmer.

Wow! Ridiculous?

It auto-detects for a reason in my use case.
I name my devices based on their functions.

You could submit a fix for others since it’s such a nuisance to you.

2 Likes

Lets work on a way to accomplish your goal without parsing names. What drivers do you use and what capabilities do you want for them?

Wanted to let you know that I went in to the Hubitat app and changed it from type plug to light and rebooted and that appeared to work - it's no in Home as a light with brightness control. Thank you for your quick response. Sorry, I did not realize I could manually reclassify it!

1 Like

@tonesto7 created this integration (and if I’m remembering correctly, the previous Homebridge integration that was converted for use with MakerAPI). He has been kind enough to share this with the community and keep it maintained.

6 Likes

I posted about this sometime ago and didn't get a response but would like to resolve it. All of my curtains connected to Qubino Flush Shutter Modules permanently show "closing" as shown below:

Though in the status bar at the top of the room page they correctly show their status as below:

The Homebridge debug for the device is shown below:

{
"name": "Lounge Curtain",
"basename": "Qubino Shutter Module",
"deviceid": "476",
"status": "ACTIVE",
"manufacturer": "Unknown",
"model": "Qubino Shutter Module",
"deviceNetworkId": "76",
"lastActivity": "2022-04-12T07:00:08+0000",
"capabilities": [
"Actuator",
"Configuration",
"EnergyMeter",
"PowerMeter",
"Refresh",
"Switch",
"SwitchLevel",
"TemperatureMeasurement",
"WindowShade"
],
"capabilities_processed": {
"Actuator": 1,
"Refresh": 1,
"Switch": 1,
"SwitchLevel": 1,
"WindowShade": 1
},
"capabilities_filtered": [
"TemperatureMeasurement"
],
"commands": [
"calibrate",
"close",
"configure",
"off",
"on",
"open",
"refresh",
"reset",
"setLevel",
"setPosition",
"startPositionChange",
"stopPositionChange"
],
"commands_processed": {
"calibrate": 1,
"close": 1,
"off": 1,
"on": 1,
"open": 1,
"setLevel": 1,
"setPosition": 1,
"startPositionChange": 1,
"stopPositionChange": 1
},
"customflags": {

},
"attributes": {
    "energy": 19.1,
    "energyDuration": "372.65 Days",
    "energyTime": 1617451429185,
    "level": 99,
    "position": null,
    "power": 1377.2,
    "powerHigh": 1380.2,
    "powerLow": 0,
    "switch": "on",
    "temperature": null,
    "windowShade": "open"
},
"attributes_processed": {
    "energyDuration": "372.65 Days",
    "energyTime": 1617451429185,
    "level": 99,
    "position": null,
    "powerHigh": 1380.2,
    "powerLow": 0,
    "switch": "on",
    "temperature": null,
    "windowShade": "open"

I'm guessing that Homebridge uses "windowShade" to show "open" in the rooms page but I'm not sure where it is getting "closing" from. I've compared the debug data with a Fibaro Roller Shutter 3 that controls my garage door. It appears identical in that it shows the "level" attribute but not the "position" (shows null), except the garage door is correctly displayed. Any help appreciated.

I don't even know if there is a detection for the name plug. Based on the users response who was having the issue, there is not, it was Home Kit in fact which auto-selected plug (based on the name possibly). Also the developer based on feedback not that long ago added the option to disable the automatic light and fan detection as you pointed out. Personally I have it disabled because I want more control but I also know what I am doing. But in the case above if the user had named the device with "Light" in the name the app would have solved the problem itself, since they did not know you could reclassify some devices in HomeKit. So it can be good for users in some situations.

@tonesto7 keep up the good work we are lucky to have your apps available for free or optional donations!

5 Likes

Well, you have all the Groovy sources for @tonesto7’s HomeBridge integration. So you can modify it as suited for your needs. One would think that would be a more productive use of time.

4 Likes

Let's all work together to create and share awesome things, and spend less time criticizing others' efforts. One way to accomplish that, is to improve the discussion in some way, however small. If you are not sure your post adds to the conversation, think over what you want to say and try again later.

12 Likes

This is a tricky one as most of the issues I've seen with the blinds revolve around the drivers doing something weird.
I tried to build the logic using the built-in shade drivers, I will try to look and see if I can find the code for the driver you are using.

No problem -thanks

I've been using this great App to get Hubitat devices into Homebridge with success but am now wondering how I get Homebridge devices into Hubitat. e.g. leak sensors. Is that not possible or am I missing something?

Thx

  1. Create Hubitat virtual switches that correspond to each of your HomeKit sensors and expose them to HomeKit via Homebridge.
  2. Create HomeKit automations that flip switch state based on sensor state (eg. wet = on; dry = off)
  3. Use switch status within Hubitat to trigger Hubitat automations.

Hope this helps!

3 Likes

Ya, that's what I thought. Not a terribly elegant solution, in my opinion. I was hoping Homebridge devices could be imported into Hubitat with their native type preserved.

You know Apple doesn’t share. Same thing with Homekit. It’s still nice to be able to use the Home app and maintain local control.

4 Likes

Download the Hubitat app