[RELEASE] Homebridge Hubitat v2.0

Yeah, I set them up for emergency use and specific needs, but mostly just use Apple Home if I need a dashboard.

1 Like

That's what Home Assistant is for.

I did some testing.

It seems to be the door locks itself. Not the hub or bridge. The notification are still a hit and miss. Notification is instantaneous most of the time but there some delay or missed here and there sometimes even no notification at all.

The lights are instantaneous every time. (no notification since it only set to door locks and garage door only which it how I wanted)

The door locks are probably getting commands instantaneously but the onboard circuit probably delay itself 3-5 seconds before locking or unlocking the door.

I am impressed with lights and Homekit features but not quite impressed with notification yet. It may be Apple cloud side of thing and the hub and bridge are doing it job as intended.

So I am going to leave it as for now and maybe post in Apple support forum about the notification issue to see if it can be tweaked somehow.

1 Like

This is odd. Notifications work so well my wife disables them. I don't think i've had a missed notification in many many months.
I wonder if one of your home hubs is having issues.

1 Like

Only hub I have is Hubatit V7 and Apple TV. Hoobs is on a Raspberry PI

Hi There,

First post! I have just installed my first Hubitat unit (Rev C-7, 2.3.0.124), installed Hubitat Package Manager and then the Homebridge v2 v2.5.14 (app) to be able to connect to my homebridge docker install. All this went to plan and I now have it connected. However, I now have Hubitat Safety Monitor showing in homebridge and therefore HomeKit...

But I have not installed the Hubitat Safety Monitor app. I know I can hide this in homebridge, but this is unexpected so just asking if anyone else as seen this?

Thanks, Simon (from NZ).

I haven’t seen this. I have this enabled on one HE and disabled on my other HE without issue. Do you have the option off in the HE Homebridge app?

@sedinh1 - Were you able to get this working? Or gave up for a different solution? I'm running into this exact problem and just noticed this thread.

For anyone who might be able to help. Here are some more details.

  • Created a virtual device (I've tried all - switch, button, motion senser, etc) in HE
  • Added virtual device to Hubitat plugin (tried adding under Lights, Switches, Other)
  • Virtual Device shows up on HomeKit
  • State changes from HE are not reflecting on HomeKit.
  • State changes from HomeKit do get sent to HE.

I've checked the debug logs in the Homebridge plugin in HE and I see logs under ' Last (25) Commands Received From HomeKit:' for the virtual device. But there are no logs under ' Last (25) Events Sent to HomeKit:'.

Other things to note:

  • This only happens with the Virtual Devices I've tried to create. All my non-virtual devices work fine and can send/receive state from HomeKit.
  • Around the same time, I setup the Alexa Hubitat plugin. I'm able to expose the Virtual Device there, and state changes work fine in both directions to Alexa.
  • Also tried changing Bonjour to ciao on HomeBridge but no luck.

Seems like the main issue is around why Homebridge plugin isn't sending state changes for Virtual Devices. Or could it be that Hubitat is not sending events to the Homebridge plugin? Not exactly sure how it works, but if anyone has any guidance, happy to dig into any other logs to pinpoint the root cause better.

Info on my setup:

  • Hubitat:
    • HE Platform Version: 2.3.0.124
    • Homebridge Pluging:
      • Version: v2.5.14
  • Homebridge:
    • Version: v1.4.0
    • NodeJS: v16.13.2
    • Npm: v8.1.2
    • Alpine Linux (3.12.9)
    • HE Plugin:
      • Version: homebridge-hubitat-tonesto7 v2.5.14

Seems like some combination of things in our setup causing this given that it works for the majority? Any one have any ideas how to debug this further? Hoping to avoid doing a hard reset for my HE hub and starting from scratch, but that will be the last resort.

Thanks in advance for any help on this!

Does the change show up in your Homebridge log? If not, it’s probably just a configuration mistake.
When moving the device from one category to another (light, switch, dimmer) I have found that I need to remove it, then hit done all the way back to the apps page, then go back and put it in the other category and done back out. I was seeing duplicate devices under Homebridge which was causing similar problems a while back and had to remove them from Homebridge-config-ui-x under Homebridge settings; remove single cached accessory.

2 Likes

No, the change was not showing up in the Homebridge log. Since you mentioned issues with caching, I ended up trying a couple of things and one of them did end up fixing it.

I first tried to just uninstall the Homebridge plugin on HE, deleted my virtual device. Re-installed, recreated the device, and re-configured the plug-in. That didn't end up fixing it. Regarding caching issues, I did notice Homebridge still showed the old devices even thought Hubitat should no longer be sending those devices over. So, that got me to my next attempt.

I then ended up deleting the Hubitat plugin in Homebridge, re-installed that, and copied over the plug-in config that is generated in HE's Homebridge plugin, and Voila! That did end up fixing the issue. So, not sure exactly what the root cause was, but you're probably right that it may have had something to do with the configuration that I set in the HE plugin in Homebridge & possibly stale caching related issues.

Thanks for providing me with the spark! Off I go to hook up my virtual device with the Rinnai/ControlR accesory. :smiley:

1 Like

@Ken_Fraleigh Okay. Dang, I think I was creating some more virtual devices and hit the issue again and I think you're absolutely right about having to click 'Next'->'Done' after making any changes in that Homebridge plug-in page. It's extremely deceiving that the page seems to show that the changes have persisted, but still not fully pushed through.

1 Like

I have this up and running and can see all my HE devices in homebridge, all working great. How do I get a homebridge plugin to show up as a device in HE?

You can’t. At least not directly. However, for some devices, you can create a Hubitat virtual device that mirrors the capability of the desired HomeKit device, and then use an Apple Home automation to “synchronize” the two.

Eg.

HomeKit contact sensor opens, turn Hubitat virtual switch on.
HomeKit contact sensors closes, turn Hubitat virtual switch off.

4 Likes

No never was able to figure out what going, switched to maker api and haven’t had issues since.

I'm pushing scenes created in HE over to HomeKit and they show up switches or lights, depending on the categories I define them as. I don't see a category for scenes in the homebridge config to send them over as scenes, and I don't see the ability to redefine them as scenes in HomeKit, is there another way to achieve this?

You can just create the scene in HomeKit instead of trying to push it from HE.

2 Likes

Thanks @Vettester, I did do that but seems duplicate. Would be nice to have some over instead of creating a scene to switch a scene

Since 15.4 update, opening/closing shades is no longer supported by siri!

1 Like

Seems to be just Siri:

"Hey Siri - close the lounge curtain"

"Hmmm- there are no accessories that support that"

Still opens and closes from the devices icon in the Home app - strange

2 Likes

This was resolved with iOS 15.4.1

3 Likes

Download the Hubitat app