[RELEASE] Fibaro Smart Implant FGBS-222

If you go that route, you need to press "reinstall" in my driver to re-create the child devices after you switch driver.

WRONG! It didn't work and really messed things up!
There is no way to do this without a re-install and rule recreation!

I should have been more specific... sorry.

What I am trying to do is use a micro switch that senses the position of a valve handle, on the digital input. IE valve handle closed=a micro switch connected to the SI's dig input closed.

Then use the state of the SI's input 1 to control a pump in a rule, so that the pump will not run if the valve is closed.
I wanted to use the SI since I am also monitoring temperature with the SI and it is next to the valve, and this has been working great.

The switch "output" from the SI is not used. Only the digital input being operated by the micro switch.
So in my rule, I would test for the SI's digital input 1 open/closed?

I see, just connect the switch between input 1 and ground and configure it as a normally open or closed alarm input (note that they are reversed in the code and I never changed it so you probably want normally closed...).

When the switch closes/open, the implant will automatically update the digital input state, which can be used to trigger rules when the state changes. you can also poll the state value if you need to.

Thank you!
I can deal with the reversal so no problem!

Worked like a dream! Thank you!
The instructions were not clear on how to accomplish this... it was not obvious that setting the input to alarm mode would do this.
Got it now!

Now all I have to do on my other SI is to switch to your driver and reconfigure the rules that this SI controls.

1 Like

New release 1.7.6 "Modified temperature handling to avoid use of scientific notation in reporting" is now available directly or through the Hubitat package manager, see this for some background.


I purchased a new Fibaro Smart Implant this week along with 3 DS18B20 temperature sensors. Plan to use them to monitor outside temperatures and pool water temperature. Application of the digital I/O is TBD. First, thanks to christi999 for a great driver. Makes an awkward device much more usable. First steps were to wire up, include and test the temperatures. After a few tries, got that working. Needed to reinstall to get the internal temp to work, while I reconfigured and added the digital inputs as alarm inputs. Then decoupled the inputs from the outputs and have everything working…. almost.

The only issue I have is the two digital input statuses change (open/close) on the child device pages, but not on the dashboard. On the dashboard I used the contact template, but they just show as circled (?). I have them temporarily wired to the outputs for testing. I turn on Out 1 on the dash board and the child page status changes for the connected input, but nothing on the dashboard (other than the output updates). I tried a few other templates, but nothing. Any suggestions?

I just tested the dashboard with my input configured as an alarm and using the contact template (using the digital input child, not analog...). Works fine here.

The inputs when configured as alarm should be connected to ground through a contact. I assume Out 1 is connected to ground? I guess that could work.

I assume you mean the "digital input" child device. If the status change there then it should be reflected in the dashboard, if not the it is most likely an "Hubitat" problem, not the driver.

Thanks for looking into it. Yeah, electrically it works. One side of the output is wired to ground the other to the input. The status on the "digital input" child device indicates it works. I think the circled (?) icon on the tile indicates something is broken. Will try removing and restoring. If that doesn't work it is likely a Hubitat issue. I just wasn't sure if the digital type in the child driver could be incompatible with the contact template.

The digital input child is coded with "capability ContactSensor" so the template should always work. You will get a (?) if you use an template incompatible with the device capability, e.g. using the analog input child device (not defined as a contact sensor) with the contact template. That's why I wanted to make sure you use the right child device when you created the dashboard tile.

So strange. I just checked it and it is now working, WITHOUT having done anything. The (?)'s on the input tiles are replaced with the contact icons and are responding. Only thing I did was power down the implant for the night and just powered it back up.

1 Like

What do you use that for? It's affected by the running of the implant.

Not really using it for anything, yet. Just testing the device functions before deploying. Before it started working it was stuck on 68F. The other sensors responded to heat, but not the internal one.
Suspect it won't get used since it is affected by the implant's own heat generation.

Maybe if the heat output was constant, which I doubt, you could use an offset to correct.

Thought of that, but as you mention, doubt it is constant. Most I'd use it for would be ambient temperature in the basement where it will end up. FYI, it is currently reporting 15F higher than the 3 sensors lying on the floor next to it. I saw it's deviation was even higher yesterday, maybe 25F.

Yeah, so likely useless.

Useless for ambient temps but I always thought it was there to protect the implant. There is a message sent when the device is overheating:

System hardware failure
with manufacturer proprietary
failure code [0x03]
Device Overheat

1 Like

Well, the implant has been off line waiting for some additional sensors. Hardware arrived and I tried adding a 4th DS18B20. Changed the parameter to 4, saved preferences, and re-installed. The 4th temperature child appeared. Re-added child devices to a dashboard and the digital inputs are back to the (?). After a day of no change, I deleted/excluded the implant and started over. All child devices are there (1 internal temp, 4 external, 2 DI, 2 DO, and 2 AI). Rebuilt dashboard and still the same (?). FYI, only have 1 DS18B20 connected at the moment. Would that be an issue? If not all DS18B20's are present will any work? They all show "unknown" on the dashboard. Implant is talking, the internal temp displays correctly.

I can share config screen shots and log entries, but they are long (14 pages saved in Word).
Also, no events logged.

Whenever I get ? on a dashboard it's because the device is no longer there. I have to add it to the dashboard app, then pick the new device in the tile edit screen. Can see that happening to you with all the excluding/including you're doing.