Fibaro Smart Implant FGBS-222 w/ DSB18B20

Yes, start with simpicity. Connect one and get it working.
Curious, what's the use case for 5 sensors on one input?

I have three freezer and one side by side in our basement. We do alot of gardening and have an orchard. Want to be able to be notified if one or all goes down. I will have to play around with it this weekend. I wonder if the probes are good ? Bought then off Amazon. Been reading that there are alot of fake ds18b20 out there.

Funny ive just spent the best part of today failing to set mine up.

Ive just done a quick search ( dont know why i didnt to that 10 jours ago) and apparently you need to connect the DSB18B20s to the implant then pair.
Which is literally the only thing i didnt do as it is already used with my smoke alarms.
Also you apparently dont need the 4.7k resistor.

Also i got my five to read 20c which is 68f but couldnt get them to change.

That's funny same issue. I had all the ds18b20 connected prior to pairing so that is not it. I was doing some reading on this page [Tutorial] - Attaching DS18B20 temperature sensors to a Smart Implant - Tutorials and Guides - Smart Home Forum by FIBARO
They talk about a resistor. I also wonder if more power is needed with multiple probes. I used a 5v.

Ok, my easy fix is now in tatters....

My implant is currently powered by a small 12v 0.25w supply which i tried.
I also tried a 12v 3 amp, and a 5v 2amp same result.
I read and reread that many times today.
Im trying to use AZDelivery 5 x DS18B20 probes from amazon.

In the article I listed, they mention using a resistor? The directons that came with it do not mention that and dnickel said he did not use one. Unless some have them built in?

I had a 5k resistor to hand so i tried that didn't make any difference, not sure how critical that .3k is?
Im going to order a second implant and a 4.7k resistor for my next play and see how that turns out.

I have some and will try this weekend

Report back as im not going to have a chance before next weekend

I took a quick look in the full manual and didn't see anywhere where they show a pull up resistor in a diagram or text.
Yes, the off shore sensors have b een a bit of acrap shoot, mine all seemed to be fine.
I ordered a gauranteed working one as I needed 3M from

so had a quick 5 mins play.
excluded my smart implant
reset implant
connected 3 x dsb18b20 no resistor
included implant set up 3 x dsb18b20

one in ice water, one in hot water one sat on the table and the internal one.

happy with that

as a little experiment i just added 2 more dsb1820 with out excluding the implant and they didn't read
so a exclude include and all 5 now work

they are all sat in the same ice water so need abit of calibration


That's great, glad you got it working. I wish I had the same luck. I tried the same steps. It helped but inconsistant readings. I excluded did factory reset and re included. Still no good. I took it all apart and checked all the wiring put it back together. The probes all read within 2 degrees of 56. Figured I would accept that. I put one probe in the freezer and after about an hour it read -4. So not correct. Tried adding a pull up resistor and didn't work. So I am not at all sure where the problem is.

Wondered if anyone can help here, i guess this is a driver issue-
i have this device relaying the temperature value (using an external DB sensor) to the web via a http get rule. (using the Fibaro Smart Implant FGBS-222 driver
Occasionally it is sending non-numeric values, such as "2E+1"
I'm logging temperature values abour every 30 mins and i get this erroneous value 5 or 6 times per month so its not a major issue but rather a minor annoyance that i have to filter out at the receiving end.
not sure whats happening here, might be an out of range value but is there anyway to avoid this?
Realistically, the range is -10 to +40 (ambient/outdoor temperature in degrees celsius)

Are you using version 1.7.6 of my driver which corrected a similar problem (2E+1 is 20 degrees in scientific notation...) ? see this post: link

Just going to mention. This sounds like the fix you did for me.

Havent updated the driver this year so assume this has been updated since.
Will check the version asap and upgrade if applicable.

Having never upgraded a driver before, do i just copy and paste/replace the existing driver-code?
Many thanks

Yes, just copy and paste. The alternative is the Hubitat package manager App which updates the files for you.

After updating, you might want to do a "save preferences" in order for the displayed driver version to get updated.

Thats great, many thanks.
Im running an older firmware (reliable- if it aint broke dont fix it approach) so may not be included in the OS driver library i have at present.

Could you please confirm the direct link to the driver code, just to make sure i get the correct/latest. Very much appreciated.

Fantastic, @christi999, have updated. (i was on 1.7.5)
much appreciated

1 Like