[Release] Fibaro FGS-224, FGS-223 and FGS-222

I know a couple of people have asked for the Fibaro FGS-224 device handler so I thought I would create a post for it, so its easier for people to find. This thread is now combined with the FGS-222 and FGS-223 so that they can live in the same place, given the actual device handler and function is very similar.

You can also install it through Hubitat Package Manager which I thoroughly recommend for keeping up to date with any bugfixes/improvements.

The link to Github for the individual drivers is: FGS224, FGS223 and FGS222 if you want the code directly.


Perfect.......thanks a lot!!!

I just tried it quickly and it works well when I control it from the Device page in Hubitat.

However, I still have one issue and that is that one output (think it is S2) requires (during manual control with the toggle switch) that I have the switch in off position, push it to on and then quickly back to off, to be able to turn on the lights. Same procedure is required to turn off the lights.

The other switch works like it should, and I have the same settings for both switches.
Any ideas what could cause this?

I had the same issue when I used the FGS-223 driver.

Have you changed the setting in this device handler (and pressed configure)?

If you have, and left it a bit, then I think you need to unpair and repair, since some of the settings from 223 seem to conflict with the settings for the 224 (e.g. you could configure a parameter that is used by the 223, but for the 224 it causes strange behaviour - I think I experienced something similar to this).

I have tried the settings and configure, but I will try to unpair and pair it again.

Earlier when I tried to reset the switch to factory defaults following the Fibaro instruction below, I never got any yellow light.........only red, magenta and then green.
Not sure if the Fibaro manual is incorrect and that yellow actually should be green?
Have you reset your switches and seen the same colors?

Never done a reset procedure, but the exclude/join process forces a reset.

I have unpaired, reset and paired the device.

Now, to manually turn on or off the lights, I have to push the switch to on and then quickly (less than 1 second, maybe 0,5 seconds) to off again otherwise nothing happens and now it is like this for both outputs (S1 and S2).

Everything works fine when turning on and off from the Device page though.

I have tried changing the Preferences (Saved and Configured), but it doesn't seem to make any differences what I choose (momentary or toggle).

What do you see in live logging when you press configure?

I see the following:

What firmware are you running on Hubitat?

It looks like you are possibly on an old version as that was a problem I had until the 2.2.4 firmware arrived and fixed things, it doesn't look like configuration messages are being sent at all...

EDIT, try changing the switch configuration to momentary and saving preferences (not save device), then press configure and see if you see any extra messages in the logs.

I believe I have the latest firmware:

When I look at the logs, I don't see anything when I do as you say..........change to momentary, save preferences and press configure :thinking:

I only see information in the logs when I'm turning the switches on or off.

Just so we are talking about the same thing...............you mean this yellow marked log right?

"Kitchen - In wall Double Switch" is my FGS-224 device.

Not sure if that matters or not, but I'm in EU (Sweden)......not UK or US that has other Z-wave frequencies I believe.

Just to make sure, I saved preferences and configured another device (not FGS-224) and that shows up in the logs.

You're right, Ive just tried to do it again myself and its not working....

I guess the testing I did was on an earlier version of the Hubitat firmware ( I'll try and work out what is happening to the configurationSet messages which don't seem to be sending any more.... I expect I need to encapsulate them or something.

Is your FGS224 paired with S2 security?

Yes, it is paired with S2 security.........S2 Authenticated (pre-selected when I added the device).

Hi, firstly; thanks for creating the FGS-224 driver.

Iā€™m having the same issue having installed a couple of these today.

I have to quickly toggle the switch on S1 or S2 within a second for the device to change state. It changes state fine from the dashboard.

Was any further progress made on the fix?

Many thanks


@Chewbacca and @hollandautomation16
I have just updated my device handler to use the new Hubitat secure encapsulation method which I found by lots of trial and error. Does seem to work perfectly for me again, please let me know how you get on, Im going to bed now!!!

Hi @cjcharles,

Thank you so much! That works a treat!

Thanks again!

1 Like

Thanks a lot!!!
It works like a charm for me too.

1 Like

is possible to handle all the functionalities ?

Are they not enabled by default? According to that... It's super simple to add extra configuration parameters if something isn't working.

1 Like

For those using this device handler I have just released an update that includes most of the extra configuration parameters, and uses the built in Hubitat component/child devices (no need to use the metering switch any more).

This makes it a breaking change for this handler, however the fix is easy, you just need to go into the two child devices and change the handler to "Generic Component Switch" which you should find in the list of built in Hubitat device handlers. After this you can probably delete the 'Metering switch child device' handler (unless you are using it with another device)

I just updated the driver and it works fine for me (at least on/off which is the only thing I use at the moment).
Thanks for the good work.