[Release] Enerwave ZWN-SC7 Scene Controller (0.70)

Enerwave ZWN-SC7 Scene Controller

Current Version: 0.70 (Oct 29, 2019)

Yes, it's finally working!

Each button can be used with rule machine!

In the above image, starting from the top-left, the buttons are:


1, 2
3, 4
5, 6
7


Getting Started

  1. Install the driver's code
  2. Pair your ZWN-SC7 with your hub

(Detailed instructions to be added)

Download the driver here

Copy the raw URL for importing here


I develop for fun and certainly don't require payment, but if you want to buy me a coffee or something, you can use the button below :slightly_smiling_face:

donate-button

3 Likes

@strangely @mterrace @toglide510 @acrow311 @ptdalen @michaelahess

If, for any reason, you’ve been holding out this long in hopes that I could get this device to work, there is finally a driver out for your Enerwaves :blush:

Edit: I just want to throw out how much more responsive this device is on Hubitat than it was on that other system. I never knew how fast it could respond until I was watching it in the logs here.

1 Like

Thanks so much!

Just tested it out with at least seeing the button pushes register, and it works :slight_smile:

They both took a bit of time I think to configure (maybe a few mins), but now at least all the lights on it are out too and not bugging me. Now I just need to set up some automation around them.

Can I make a donation or something for your work?

Can you even buy this device anymore? I wasn't even able to find it on Ebay.

They discontinued it and were going to bring out a Zwave plus version, but it never saw light of day. If you keep an eye on eBay from time to time, you'll see some refurb ones pop up.

I'm glad it's working! I've only got one, and it seemed to configure relatively instantly, but it does send out quite a few z-wave packets in a short amount of time, so there may have been some congestion. How many devices are on your mesh?

Sure! I'll never ask or require them, but if you'd like, I've put a button in the first post :slight_smile:

Thank you so much!
I will give this a try after I get this to pair with my Hubitat. The last time I tried the ZWN-SC7 would not pair.
I have missed having these ever since I moved to hubitat 12 months ago.

The last one I saw sold for ~$70 on eBay. I was really hoping to find another one, but there's a Zigbee one I may pursue...

Same here! I regret not finishing this driver sooner lol

Thanks, I will give this a try. I have had the switch installed and non-functional ever since switching to Hubitat. Fingers crossed.

1 Like

I just wanted to say thank you! I got all 5 of my Scene Controllers up and running again. They are all responding very fast.

Have a coffee on me.

1 Like

I’m glad they’re working!! :cowboy_hat_face::cowboy_hat_face:

I'm trying this with the new c-7 chip (2.2.2.129) and I can't get it to configure. Button 1 works.

1 Like

I'll take a look into that this week --- starting over with my C7. Thanks for letting me know, and sorry about the issue!

Every time I attempt to pair I get this in the logs:

sys:12021-01-03 09:32:58.312 pm infoZ-Wave Discovery Stopped
dev:7132021-01-03 09:32:57.918 pm errorgroovy.lang.MissingMethodException: No signature of method: user_driver_enerwave_ZWN_SC7_Enerwave_7_Button_Scene_Controller_187.parse() is applicable for argument types: (java.lang.String, java.lang.Integer) values: [numberOfButtons, 7]
Possible solutions: parse(java.lang.Object), wait(), run(), run(), grep(), any() (parse)
dev:7132021-01-03 09:32:57.852 pm debugnull buttons stored
dev:7132021-01-03 09:32:57.839 pm debugParsing 'zw device: 46, command: 8506, payload: 07 , isMulticast: false'
sys:12021-01-03 09:32:57.836 pm infoZ-Wave Discovery Stopped
dev:7132021-01-03 09:32:57.779 pm debugParsing 'zw device: 46, command: 7205, payload: 01 1A 08 01 0B 03 , isMulticast: false'
sys:12021-01-03 09:32:57.741 pm infoZ-Wave Discovery Stopped
sys:12021-01-03 09:32:57.739 pm infoZ-Wave Device Discovered: ZWN-SC7 Enerwave 7 Button Scene Controller
dev:7132021-01-03 09:32:57.730 pm debugSending configuration: [7204, 8505, 2D01010100, 2D01020200, 2D01030300, 2D01040400, 2D01050500, 2D01060600, 2D01070700]
sys:12021-01-03 09:32:47.354 pm infoInitializing Z-Wave Device : 46
sys:12021-01-03 09:32:27.355 pm infoZ-Wave Discovery Running

I have deleted and re-added it several times as well as deleted and re-added the driver code.

Any suggestions?

Are you using a C7?

Nope, I have the first version with the zwave stick.

1 Like

Okay. I’ll see what’s up. You’re on the latest hub software?

Yep, Currently running version: 2.2.4.158.

1 Like

Hi! I have seven of these ZWN-SC7 Scene Controllers and a buddy has two. We also have brand new hubs / C-7.

Tried the custom driver but ONLY THE FIRST BUTTON WORKS as described above. All other buttons just blink when pressed.

Is this a known issue?

Nope. Let me see if I can replicate it on my c7!

Download the Hubitat app