[RELEASE] Echo Speaks V4

There is something broken with this. I was able to working again and sorted out the HPM too so it looks at that correct store. However, Once I install it all goes to hell in a handbasket.
I have it "working" but it still not Correct. 2.7.2 server works on the but not on the .5. After A LOT of playing around I was able to change the error message. Oauth might be an issue too. So instead of getting the error message above

Now I get this.

Something is very broken, I'm not sure where it is.

after some more playing around. I think I have it working but I'm getting errors on the server.

2022-05-04T21:21:57.745093+00:00 heroku[router]: at=info method=GET path="/checkVersion" host=echo-speaks-1616uapp.com request_id=-62de-493c-9795-5e30d0b826b3 fwd="XX.XXX.XXX.XXX" dyno=web.1 connect=0ms service=7ms status=200 bytes=227 protocol=https
2022-05-04T21:21:57.740088+00:00 app[web.1]: 5-4-2022 - 9:21:57pm info: Checking for Server Version Updates...
2022-05-04T21:21:57.738411+00:00 heroku[router]: at=info method=GET path="/configData" host=echo-speaks-16664u.herokuapp.com request_id=-6e6c-4975-9a9f-22b826ecc7e3 fwd="XXX.XXX.XXX.XXX" dyno=web.1 connect=0ms service=2ms status=200 bytes=767 protocol=https
2022-05-04T21:21:58.701712+00:00 app[web.1]: 5-4-2022 - 9:21:58pm info: Server Version is Up-to-Date.

Heroku forced a password reset today because of a security incident on their servers. I would have expected Echo Speaks to stop working. But it is still working for now. Do I need to update the password somewhere in Hubitat? And where is that if so?

Jay W

I have the same question, I changed the password and there was a note in the email on generating a new token:

NOTE: A password reset will also invalidate your API access tokens. As a result, any automations you’ve built to integrate with the Heroku Platform API that use these tokens may result in 403 forbidden errors . To avoid downtime you will need to re-enable direct authorizations by following the instructions here and update your integrations to use your newly generated token.

1 Like

I changed my password but Echo Speaks is still working. I did not generate a new API key.

I didn't have to do that too. One of the things I had found is "restart all Dynos" help getting things going again.

I noticing that I'm getting this in Heroku.
2022-05-05T00:11:10.204876+00:00 heroku[web.1]: Process exited with status 0

Disconnected from log stream. There may be events happening that you do not see here! Attempting to reconnect...

Connection to log stream failed. Please try again later.

There is something broken here. I attempted to reset Cookie and back to the broken page.

I just pushed out v4.2.0.6 to address the issues with the app not showing ing up to date.
However, I did test the Heroku deployment and now see the error reported by others. Please wait to update until I resolve the issue.


I just release v4.2.0.7 to address the issues with new heroku deployments.


Thanks so much, Anthony. Amazing software.

1 Like

@tonesto7 Thank you very much! We much appreciate it.
It looks like it is working now.

1 Like

Thanks for the quick fix

1 Like

Perhaps a naive question here but does anyone know the criteria for which users were selected for the Heroku’s email notification. I am currently on 2.7.2 and of course am using ES. I never received a notice forcing a password reset and ES continues to work. Should I be concerned?

24 hours after my password change and everything still working. Not going to jinx my setup and keeping my hands off any configuration screens :grinning:


Just received my email. Changed password this morning and so far everything still working without making any changes to API token. Fingers crossed.

1 Like

I changed password but ES still works. Anyone else having the same experience? Should I try to get a new API token for security reasons or since ES still works, should I leave well enough alone? Any advice is appreciated. @tonesto7 ?

If I'm not mistaken, ES doesn't use API tokens on Heroku so resetting the password will not affect ES. I reset my password per that email for Heroku but didn't affect my ES at all like others has mentioned so I think you're good to just reset the password and not have to worry about anything else.

1 Like

I'm up to date on heroku and ES afaik. I updated ES recently to the .07 - today I found an error in my logs I've never seen before... can anyone shed light?

(this is a 9am routine - moving from Morning to Day mode)...
I'm specifically concerned with the 'device will retry in Null'. The expectation was a notification on my local Echo Dot saying 'Mode is now Day'.

I have exactly the same error/warn messages. I'm on latest version (App:v4.2.0.7; Device:v4.2.0.7; Server:v2.7.2).

I'm new to hubitat and trying to get this up and running. I have it installed and deployed in heroku. I'm getting a message that I still need to login to Amazon to complete the setup but when I connect to the app and click goto login page I get "There's nothing here, yet Build something amazing"

What am I missing?


Download the Hubitat app