[RELEASE] Echo Speaks V4

my time is worth much more than 5 dollars a month!!

I didn't bother with a container. I had it running on my Linux box inside of about 10 minutes.

Avoiding Heroku's $5 charge is more than just the charge... it's the principle of the matter. And ensuring you're in control of your own ecosystem (that's Hubitat's major sales pitch - reduced cloud dependence).

Honestly, if the choice was between paying $100 for a local instance and paying Heroku $5/mo indefinitely, I'd choose the local instance any day. That it strips Salesforce of additional customer count / revenue is a nice bonus.


Fair enough, mine is too. But learning a little bit about Linux and docker containers for this and other home automation or server tasks is part of the hobby aspect of all this for me.

To be clear, I have absolutely no background in computer coding or IT.

You are seeing only the problematic aspects here when people ask for help. It’s much harder to say what % of people get it working without a hitch or with minimal hassle.

From what I can tell, where things go sideways for people is often related to the quirks of how docker containers on various platforms interact with the network, which can differ slightly or even greatly.

And as @doctorkb just mentioned, sometimes running the server without docker (there are step-by-step instructions for that here too) is easier and meets the same need.

ETA: but in the end, there’s nothing wrong per se with paying a subscription charge to host this server if that’s what someone decides provides the most value to them. But obviously this is a crowd that, all other things being equal, generally prefers a locally run option to anything in the cloud.


I just wish we had a different topic for those discussions. This topic is completely hijacked by Docker issues by now. I am on heroku and see contant exceptions in the logs, but my call for help was burried in container issues in a matter of minutes. Oh, well.


@jbaruch I totally agree with you. There should be a separate thread on server setup issues and containers etc I too have had questions missed. This thread should be about Echo Speaks itself, how it works, how people use it, getting the most out of it. So much valuable info has been lost, and I'm sure I'm not utilizing not even 5% of what this great project can do.

There are several of them.

1 Like

I just made another one as well, with the instructions I wrote up.
Also linking to any other guides at the top of my post for a one-stop-shop!


Yeah I’ve sunk more time than I should have into figuring this out, but on the plus side I’ve learned a ton about docker lately and have been able to apply that toward other projects. So, hobby time isn’t completely wasted.

Anyway, I’ll move docker talk to the other threads to stop hijacking’s this one


The Echo Speaks tile on my dashboard - is there a way to reflect the volume numerically?
I've been tweaking all my echo's and there are small diffs - increments of 5% or so and I can't think of a way to easily monitor them - hmm. maybe a smart tile?

1 Like

Use the Music Player template for the tile, seems to work for me

Also, Just tested the "Volume" Template which works IF you turn off the "Hide Helper Text" option in the dashboard settings.


@bobbyD Thread needs a mod cleanup to move all the docker install issues into one of those other reference threads.

FWIW, My Linux VM install has worked great from day 1.


Has anyone figured out how to restart the docker on a QNAP after an update? Mine just updated the cookie and then stopped. I tried the mentioned "docker update --restart=unless-stopped echo-speaks-server" from the docker terminal but it did not like it:

/bin/sh: 1: docker: not found

Any help would be appreciated.

You would have to look up how to set the restart policy. It is running portainer or what runs the containers?

QNAP has what they call Container Station. I see a setting to Autostart, but nothing about restart.

So, I tried something. Created a new Docker and added the Restart Policy to I HOPE the correct place. Thoughts?

Docker isn't a command available within the container itself. You will need to SSH to your NAS and run the command there. I have some automation happening within NodeRed for another container and the patch should be similar to the following that I use for mine:
/share/CACHEDEV1_DATA/.qpkg/container-station/bin/docker update --restart=unless-stopped echo-speaks-server

I haven't tested this myself as I am restarting mine via NodeRed but curious if this will work for you.

That makes much more sense, thank you for the direction. I enabled SSH, logged in and ran the following:

docker update --restart=unless-stopped echo-speaks-server

No error was returned, so I am very hopeful. Next scheduled update is Friday, 2-3-23. I will report back then.

1 Like

PLEASE take the Docker discussions to the appropriate threads! Please…


Is this (from OP) just a typo? Or do I really have to reinstall HPM to install Echo Speaks for the first time? Smells funny.

It’s really simple. A Match Up will catch all the tracked packages after you reinstall.

Download the Hubitat app