[GUIDE] Synology docker for echo-speaks-server ( echo-speaks)




4 Likes

Problem docker on the PC looks different . I figured it out you press run and then it has a pull down menu under the 3 dots. Then select terminal.

So how do you redirect echo speaks to your local IP?

Do you have instructions on what to do after the docker image is running?

Go to your browser and enter YOUR_NAS_IP:8091. It should bring the amazon login page.

After the last screenshot, I had to do this in the Web Server pop-up window:

IMPORTANT: the ipAddress field in one of the screenshots is for the ip address of the NAS, NOT the ip address of the hubitat.

Then as @jbilodea mentioned (thanks!), I have to go to <nas_ip_address:8091> to confirm that the docker instance is up.

Now go to hubitat portal. If Echo Speaks was configured for Heroku before, then the instructions below will reset that first:

  1. Open Echo Speaks app.
  2. Go into Alexa Login Service section
  3. Expand Reset Options and toggle Reset Service Data > Leave App
  4. Go back to Echo Speaks app. It should show steps to setup cookie server. At top, disable 'Deploy server to Heroku' and click Begin Server Setup.
  5. A new window will show a url for appCallbackUrl. Copy the url.

Now to go back to <nas_ip_address:8091>

  1. Login to amazon
  2. Paste in the App Callback Url
  3. Click Save Settings

Go back to hubitat portal and check login status. Should have green checkmarks.
It should also show that Server as <nas_ip_address:8091>. If you had previously entered the wrong ipAddress variable value, then the Echo Speaks app will show the wrong ip and it's not going to work.

1 Like

I've followed the instructions above (thanks for those!) religiously, yet keep seeing the well-known 0.0.0.0 IP issue as shown in the Echo Speaks app's config page. Went around a few more times, making sure I hadn't omitted any steps, but now have a red x under Login status. :frowning:

(Even restarted the server hoping for all-green results, but no such luck.)

App: v4.2.2.0 Notes
Device: v4.2.2.0
Action: v4.2.2.0
Server: v2.8.0 Running on Synology NAS in Docker app (no errors)

Has a later/newer Docker container image been pushed out to solve this issue?
Kinda wish I hadn't tinkered with it, because it was all green checks until I did, lol.

According to the registry page, the image was updated on 11/28/2022.

No idea why your echo speaks thinks the server is 0.0.0.0. Maybe check the spelling of environment variable ipAddress (all lower-case except for A).

It's unclear how that ipAddress is transferred to Echo Speaks app. I'm guessing when you are on <nas_ip_address:8091> and click Save Settings, it connects to hubitat via the appCallbackUrl and sends the nas ip and port.

And your docker containers are using bridge networking?

1 Like

Evidently it affects a subset of those installing the ES server under Docker.

1 Like

Yep, that was the ticket! Had not until now understood that this env var was required for Docker installs using the pre-fabbed Container image, but evidently so.
Happily, adding it brought the ES app up to speed on where the server lives:
From


To

Thanks for steering me straight! Will leave these posts here for others similarly afflicted.

1 Like

Download the Hubitat app