[RELEASE] Conditional Image Server --> for dynamic dashboard background

I should be doing something wrong. If I also click on the link at the APP it gives me an error:


The issue is that the image source does not have an extension, so the app doesn't know how to render it. I just updated the code so that it attempts to render files with unknown extensions as a jpg. That should get it to work for you.

Looks like the APP is not "linking" to the device.
Look what I have:



Device Events:

And the RM which is working since the device is being updated:

So what I am seeing is that the link that is on the APP that would refer to the link I have on the device (that is being updated) is not working. If I try the URL that is written on the device it works, it goes to a page with a CD cover from the music it is playing at the moment. When I click on the URL generated on the first image above (APP image) it just give me an error. If I put the URL directly on the tile at the dashboard it shows to me just fine the image. But with the URL of the APP it returns the an error.

Right. The issue was that the app returned an error because the URL you are trying to use does not have a file extension at the end, like .jpg. Updating the app code to the latest version I just released should make it to where it works, even though there's no file extension. Did you update to the latest code?

I did sir. I used the HPM to do so. It showed in there the update and I applied it. If I am not mistaken it was versio 1.02 and now it is 1.03. Even though it didnt work also. One thing that I noticed is that on the Echo Speaks device I have 2 fields regarding the picture. One field is the URL and the other field is the picture itself as showed below:

I tried to use both attributes also but it didnt worked.

So I used I random image on a website:


And added to the device directly via the device itself:

And even so, when I click on the link of the APP:

I still get the same error.

Ok I think I see the issue now. It looks like you created your own virtual device with the custom device driver and named it "virtual-Echo-Studio". That's not what you should do. The app creates the device itself. Should be listed under your Devices page, called "Dynamic Image URL Device". Use that device instead of the virtual device you created yourself.

1 Like


feeling stupid here. :confused:
So if I am not able to create the device is it possible to have different devices to use? In a situation to do the same thing but for different Echo devices? Like one for each Echo?

That use case wasn't something considered when developing. Should be easy to revise though. I'll put it on my to-do list for feature enhancement.


I have tried multiple times to configure the server…can someone please provide a REALLY simple step-by-step using an example?

1 Like

@JustinL I too have been storing images for static backgrounds directly on my hubitat. This has worked just fine. I switched over to this app today and have no difficulty with non-local images. However, my locally stored image does not work. The device is showing the correct url, the same one that works correctly on my other dashboards with static backgrounds.

What file extension? Does the same image work nob-locally but not locally?

@JustinL, I took the image from the comment above mulher_de_fases.jpg and downloaded it locally. I had used that URL previously in testing and it worked fine with your application. It also worked fine as a static URL. I then added the local URL to your app, I altered my rule accordingly and ran the rule. The device updated as expected (see pic). I replaced the static URL with the app generated one, Refreshed the dashboard and alas I'm back to a black background.

@JustinL, and this might be of help. Hubitat is refusing the connection.

Looks like Conditional Image Server will have to be updated to support reading local files from the hub. Will put it on the to-do list. Not sure if we can read binary files, but I will try.

Hm...this is a good workaround to be able to create multiple dynamic image tiles + dynamic background.

But then, how can we use 1 x conditional image server selecting "global connector variable" and another one to use "custom device"?

Can you please share the screenshots how you did it? (screenshots of the device and conditional image server app)

Hey @Televisi I have switched over to dynamic Image And don't have this one installed any longer

1 Like

I think you can just install multiple instances of the app. So, assuming you already have an instance of the app installed, go to the App page and click to add another User App, and select Conditional Image Server. Then, under the App list, you'll have two instances of Conditional Image Server. I think you'll be able to have independent settings across those different instances.

Thank you, will give this a try

Any progress on this? I too would like to use local stored images I have uploaded to Hubitat file manager. They can be accessed with a URL, so I do not understand why the hub denies access to your app. Dashboards can access these local file URL links to use custom icons in tiles using CSS. What is stopping your app from accessing http:///local/file.svg?

The app works with internet URLs, just not with local hubitat file URLs, where all my icon images are stored.

errorConditional Image Server exception: Connect to [/] failed: Connection refused (Connection refused)

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.