[Release] Alpha version of August Home (wifi door lock)

Just setting this up and having issues. In the logs I'm getting a message
"connectToAugust failed -- Unauthorized: [code:InvalidCredentials, message:access token not associated with a user]"
I have tried 2FA through both phone and email, uninstalled and re-installed the app, and confirmed my credentials. 2FA seems to be working as I'm not seeing an error with it. All three drivers and the app are installed.

I am having the same issue. I installed my lock a week ago and hubitat connected fine but after 3 days I lost connection and now I am just getting the error msg " [error]connectToAugust failed -- Unauthorized: [code:InvalidCredentials, message:access token not associated with a user]" even after I am able to connect to my account using either email and phone but still not able to discover my lock. Did anything happen in the last week as it was working fine?

I also encountered this issue after reinitialising the app. I debugged it and it looks like the API doesn't allow two authtokens to be generated with the same UUID (today the driver uses the uuid from the HUB so once you re init it it fails).

So updating the line
def installID = getHubUID()
to:
def installID = UUID.randomUUID().toString()

solved it for me.

I have also made a fix so that the info can be polled more often (10 seconds intervall) . Will need to run it for a couple of days to see if I stumble upon any issues.

@taylor Are you intressted in a PR if this works ok (the first issue I think would be good to get in either way since that seem to cause issues for people)

I am having the same issue. I changed the code per @fizzyflaskan and got the same result. The debug logs show the same error about an invalid token etc.

Do you mean you still see the issue or that it worked with that fix?

@fizzyflaskan, I tried your fix and still see the same error:
connectToAugust failed -- status code: 409, reason phrase: Conflict: [code:InvalidArgument, message:Invalid code]

Also noticed it seems to be kind of temperamental about sending the verification code (sort of moot at the moment). I have to hit the Login button twice, which keeps making me think maybe I didn't wait long enough for the code to arrive, but putting that to the test, no code arrives unless I hit the Login button again. It also seems to be very picky about the phone number format... +1(123)456-7890, not 1234567890 or any other combo or I get a "not a valid phone number" message in the logs (which probably should show up on the login screen not just in the logs - not everyone is going to know right off the bat to look there).

Try tapping somewhere else besides the Login button. Then tap on the Login button. Works for me, sometimes…

@taylor

I'm having the same 409 invalid code issue (see below). I've tried the code fix above. I've tried email and phone verification. Any suggestions?

[error](http://c-5l/installedapp/configure/251)connectToAugust failed -- status code: 409, reason phrase: Conflict: [code:InvalidArgument, message:Invalid code]

Alan

I mentioned this on the Honeywell thread as well, I got a new job (promotion more accurately) and with some other hobbies during summer I have had zero time / energy to work on my IoT stuff. I am happy to donate / migrate code to a common repro or promote maintainers who will continue to move the projects forward.

Congrats! I will play with the code, but don't want to take it over. I don't respond timely enough for most people! :slight_smile:

FYI, i put in some debug code to follow the path, found that the code was not being populated on the first click, but clicking it a second time works. Note I haven't fixed the code since it is just configuration.

Alan

1 Like

Thanks for your work on this. Great to have some control of the lock.
With regards to the status update have you tried using the status endpoint on the api mentioned here.
Probably what your refresh is already doing I guess?

Lately I've been having some issues with the app refreshing the contact settings. I have to open the August app for it to refresh. Is that a known issue?

I've seen that a few times as well were it seems like the lock never informed the cloud of it's current state but when you open the app it forces an update. I saw the same thing with the current SmartThings cloud integration. I've only seen it a few times. I have also had the lock go off WiFi for various reasons and it will show unlocked even though it is locked and probably was before it lost WiFi. As soon as WiFi is restored (sometimes on it's own other times with pulling and replacing the battery) it updates to the correct state again.

Can anyone tell me if the battery status of this works accurately? My device via Hubitat reports 50% battery remaining but I have started to get notified in my August smart lock app that the battery is low (25% or lower).
Not sure which is accurate. It's August 4 wifi smart lock btw.

Thanks

Probably neither is accurate. I would actually check the battery level using a VOM tester.

In Sweden, we have have a system called Yale Doorman L3 / Yale Linus (different type of locks) that seems to use the same software as August Home (same owner of both brands).
For example, in IFTTT, Yale uses the August Home applet.

I have managed to log in using this app in Hubitat and my login information for Yale, but unfortunately I can't find the Yale locks.

Is there anyone that has managed to add the Yale locks?
Or is skilled enough to add the locks to this app?

There are some more information about the Yale locks in this post:
Yale Connect Wi-Fi Bridge & Yale Access - Built-In Apps and Drivers - Hubitat

I have been trying to connect and I keep getting invalid code errors in the log when I validate the codes I just received over text. What am I doing wrong?

@alan564923 Double-clicking on Verify did it for me too. Thanks for posting. Despite not connecting via z-wave, I am thrilled to be able to control my locks!

I had this working and it was just terrific. As of this morning, I cannot control the locks with HE. When I attempt to unlock a door, I get receive this error:

Any advice on what I can do to get these locks working again?

Download the Hubitat app