[RELEASE] Advanced Zooz Zen27 / Zen26 Central Scene Dimmer and Switch Drivers

Note on the button controllers after a Zooz FW update when using this driver.

Delete the old button controller and start over from scratch.

Brian has mapped eight buttons with pushed functions only. I have three Zen27 and two of them map button 1 to the upper paddle and one maps it to the lower. It was my first Zen27 so maybe it’s an older version of HW. Dunno. But before you start doing button controllers, watch the logs and press a button so you know which way it’s mapped.

I have also have a couple of my zen26 that don’t follow the other dozen I have.

1 Like

See this post for anticipated button mapping

1 Like

Thanks! Buttons are now all working as expected. Greatly appreciated!

1 Like

Hi,

I've released an update to the Zen27 driver based on the updates I made to the Zen22 driver. It's completely untested (since I don't have any Zen27 devices yet) but the code looked exactly the same. Changes:

  1. Fixed certain parameters that should be able to be set to 0 but the driver didn't allow it
  2. Added support for 4-tap and 5-tap
  3. Added support for held and released

The driver can be found here:

FWIW, I am having the same issue mentioned by several individuals above. I recently purchased about 20 ZEN27 dimmers, and started installing/adding them to my hub (Hubitat C7; Platform 2.2.4.148). All devices were installed S2, and worked great with stock Hubitat drivers. I've now attempted to update all of the switches to the custom driver for additional functionality, and all the switches immediately stopped responding. This issue does not exist on switches of other brands (ie: I can run the advanced/custom drivers for Inovelli Red through S2 security) so must be a driver issue.

@agnes.zooz - Can we expect an updated custom driver that supports S2 connectivity? The idea of reverting zwave connectivity to an outdated/less secure protocol in order to more fully utilize the features of this switch, is not that appealing.

I suppose I will revert to the stock Hubitat integrated driver in the meantime.

1 Like

These are a community drivers as far as know, they were not provided by Zooz. I dont think they create or post drivers while inovelli does. So not much to do but wait for someone to own this drivers and work on them or you may give it a try.

1 Like

That's interesting, as they list the advanced driver here on their website: www**[dot]support[dot]getzooz[dot]**com/kb/article/440-how-to-access-advanced-settings-for-zen27-dimmer-switch-on-hubitat/ (sorry... I had to remove the dots from the hyperlink as I am too new to the forum)

So, I assumed that they were officially supported by Zooz?!

No, not officially supported by Zooz. They just point us here as a courtesy, more or less. :confused:

1 Like

I believe it was authored by bcopeland before he joined Hubitat Staff. So we'll see if the "community" driver gets fixed OR the native driver gets updated to out date the community driver.

1 Like

I made a change to my fork of the driver that you can try if you want, and let me know if it works.
(Disclaimer: I don't know much about writing a Z-wave driver.)

Driver is here:

https://raw.githubusercontent.com/dds82/hubitat/master/Drivers/zooz/zen27-dimmer.groovy

Many thanks, I'll give it a try.

One comment though, unless I missed it I didn't see any note on your modification. You should at least add a date and your name, screen name or initials with a statement that you changed "...........". Not in detail but maybe something like " change the way the _____ worked.

2 Likes

Thanks @dsegall I'll probably take a look at your driver in the near future... but after the hiccup today, I'm going to finish installing all of my new switches and devices first, make sure the system and z-wave network are stable... and THEN I'll start trying to access the advanced features! I'll post back once I get a chance to try it.

1 Like

We're not planning to release a separate custom driver for this model in the near future but @bcopeland mentioned this driver should receive an update soon :slight_smile:

3 Likes

I can confirm your updated driver seems to work with S2. The output from "configure" seems to be much different than the default driver so not sure if everything is working but going to give it a try. I will probably be forking your repo to make changes if I find anything.

Does the latest driver work well with the v3.01 release of ZEN27 firmware?

I stopped using these drivers because I found the ones below instead. They're more up to date and are being actively maintained

It will work if you have them paired without security. If you paired with S2 you have to modify it to get it work. Here is another one which will work on all security and has all the advanced settings as well: [RELEASE] Zooz ZEN Switches Advanced Drivers

On the Zen27 - Is it possible to have the Upper Paddle x3 ONLY push button 5, and not enter inclusion mode?

From the documentation...
3 x tap: enter inclusion (pairing) mode; Scene 2, attribute 04 (button 5)

Or, perhaps another question - Should I care if I enter inclusion mode a bunch?

Use my custom driver linked above, coupled with the newest firmware, yes you can disable the 3x taps for inclusion/exclusion mode from the settings on the ZEN27. No it does not hurt anything but I found it annoying.

image

Thanks @jtp10181 , worked like a charm.

Download the Hubitat app