[RECURRING] OAuth Connections Down / Performance Issues

@bobbyD ?

having similar issues with actiontiles...Their support is non responsive

Checking, thanks for your feedback.

1 Like

Is this why my Google assistant keeps telling me that Hubitat is unavailable?

1 Like

No, more likely your hub isn't connected to the cloud. The oauth would prevent linking with a third party cloud provider, but wouldn't prevent using it, once linked (Sharptools is an exception).

Just an update that SharpTools shouldn't depend on OAuth after the account is linked anymore as we pushed an enhancement last night.

As for why SharpTools talked to the OAuth servers during normal use... most integrations like Google Home, Alexa, etc. only use the OAuth servers during the initial "linking" step. SharpTools may need to synchronize your devices again while you are using it -- and the device sync has one very small, but critical step where it asks Hubitat's OAuth servers for a list of your locations.

The update we pushed won't fix things for initial account linking as that fundamentally relies on Hubitat's OAuth servers, but it should workaround it for ongoing use. We now read from an internal location snapshot if you need to sync devices after the account is linked.


Can you specify which "cloud," you're talking about? Hubitat's or Google's? I've had mine linked to the Google cloud for years. Now that I'm not home, I just noticed the HD+ dashboard app telling me it can't connect to the server. Remotely connecting to the hub also seems to be failing for my C7 hub but not my C5 hub. Is there a way I could remotely tell one hub to reboot the other?

@bobbyD It looks like the Hubitat OAuth servers are down. I tried to reconnect my Google Home and won't load oauth.cloud.hubitat.com.

I can't ping it either:

ping oauth.cloud.hubitat.com

Pinging cloudservices-env-1.3vqyxkmn9w.us-east-2.elasticbeanstalk.com [] with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),
1 Like

I'm still getting reports of issues with the OAuth services.

@mike.maxwell @bobbyD @gopher.ny any chance we could get this prioritized? It impacts Alexa, Google Home, IFTTT, SharpTools and anything else that uses OAuth.

1 Like

This has been going on for weeks now. Very frustrating.

Oath servers (https://oauth.cloud.hubitat.com) are still not responding,

I'm not able to add my hubitat devices to my Google home app which is a huge pain because I use my nest minis throughout the house to voice control most of the lights in my house which are all z-wave connected to my hubitat.

Please fix this. Is there a direct support email for things like this, does hubitat even know their servers are not working?

Can we get a response from hubitat on what is going on with the oath service?

@bobbyD @support_team

It should be working now.


Whatever you did fixed it.


Just came back to using my C7 after moving and not having the time to hook up everything until now. It is frustrating that this problem has continued. I just bought myself a new Zigbee motion sensor and garage door opener too. :frowning:

Welcome to the Hubitat community, sorry you are having issues.

I am not sure what that has to do with OAuth? Zigbee in particular, as far as I know, doesn't rely on OAuth at all. Typically it would affect Alexa, Google, or other similar cloud based apps.

Maybe it would help if you could tell us which app is affected by this. You didn't leave much to go by.


What problem?

1 Like

I have new toys which I have connected to the hub, and was looking forward to connecting them to Google. Also I have existing devices that were connected with Google that I can't use how I would like to use them currently. Hence why the OAuth issues are affecting me. Sorry for not being clear.

Typically you would be getting some message in logs. Could you post those logs or how you became aware that OAuth wasn't working.

I am not familiar with Google, so I am not sure what I can do to help. Maybe someone else would recognize the error message in logs, if you were to take a screenshot of the error.

1 Like

I appreciate your trying to help. Thanks!
Not sure what happened - Last night I was getting the exact same thing that zman above posted when trying to connect my hub to google. Today it magically started working again.

OAuth is still not working for me. My hub is connected to he cloud. I get ERR_TIMED_OUT