[RECURRING] OAuth Connections Down / Performance Issues

I'm not experiencing any issues, What service/integration are you having issues with?


Aaargh. Updated blocklist on my pihole has caused this I think. Groan. My bad.


Well at least you found it!

1 Like

Hey @DeathJaguar I saw your reply come across in my email notifications, so I checked and I am seeing intermittent Hubitat OAuth issues again too.

Just curious why you deleted your post? Did things start working for you again?


I apologize. I posted out of frustration and deleted it since I don't know if the problem is on my end or if something larger is going on. Everything worked great for the last year, but maintaining a connection between my Google Home and my Hubitat has been intermittent for the last month. Yes, I also use a Pi-hole, but the problem persists whether it's active or not.

My Google Home again lost connection to my Hubitat around 4am UTC last night. I tried to reconnect and it could not reach OAuth. Rebooting doesn't resolve the problem, but it will come back online if I manually unplug it and plug it back in, which doesn't makes sense to me (does it cache it or something?), but I'm not a developer, I'm just a user. Yes, it's a basic fix, but I'm pretty darn tired of having to do it.

Ah, that makes sense.

Issues with maintaining a connection to Google Home might not be directly related. But the error with not being able to complete the OAuth flow -- either the process timing out or displaying errors could be related.

After seeing your post, I tried reauthorizing and I'm having issues with Google Home, SharpTools, and other services that use Hubitat's OAuth flow, so something seems to be broken again.

As with before, it's somewhat of an intermittent issue, so sometimes just waiting 5 minutes and trying again will get you through.

Tagging @bobbyD @mike.maxwell @gopher.ny for awareness.

1 Like

I'm seeing OAuth problems again. I've disabled my Pi-hole to ensure that's not getting in the way but still no luck. Anyone else having issues?

Sharptools gives me this message:

...and, working again, for now.

This continues to be a problem. Is anyone working on it?

1 Like

@support_team Having OAuth issues again this morning. Been waiting about an hour but can't get it to work.


We are aware of issues this morning:

1 Like

Please try again. The issue has been identified and a fix was implemented. Let us know if you continue to have any more problems.

Still having issues. I do get through to the login, then the hub selection, and then the devices to authorize. But it hangs after this screen and times out.

Just did another test with both Alexa and Google, they did work for me with no delays.
I'll be reviewing the entire process next week to get to the bottom of these issues.


Having remote login issues , cannot remote admin access hub anymore

For subscription related issues, please be sure to submit a case by visiting the following page:

We have checked the service and it is operational, so likely the problem may be with your account or hub.

I'm not convinced this is resolved. I think it's getting close to time to stick my pair of C-8s on eBay.

Is this the same thing that causes a lot of back and forth and time outs when trying to expose new buttons in Google Home?

Iā€™m seeing the same intermittent issues with Hubitat authorization this morning across Alexa, Google Home, SharpTools, etc. as well.

Usually just waiting a few minutes and trying again works...